From 8353a3bd455f1ee5e0250d0a97b5d058f21316c7 Mon Sep 17 00:00:00 2001
From: Jonas Gorski <jogo@openwrt.org>
Date: Mon, 30 Mar 2015 20:20:10 +0000
Subject: generic: relocate: make the cacheline size configurable

Different targets have different cache line sizes.

Signed-off-by: Jonas Gorski <jogo@openwrt.org>

SVN-Revision: 45163
---
 target/linux/generic/image/relocate/Makefile | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

(limited to 'target/linux/generic')

diff --git a/target/linux/generic/image/relocate/Makefile b/target/linux/generic/image/relocate/Makefile
index 500423b63b..5f6ebeb096 100644
--- a/target/linux/generic/image/relocate/Makefile
+++ b/target/linux/generic/image/relocate/Makefile
@@ -22,6 +22,7 @@ BOARD		:=
 FLASH_OFFS	:=
 FLASH_MAX	:=
 PLATFORM	:=
+CACHELINE_SIZE	:= 32
 
 CC		:= $(CROSS_COMPILE)gcc
 LD		:= $(CROSS_COMPILE)ld
@@ -36,7 +37,8 @@ CFLAGS		= -D__KERNEL__ -Wall -Wstrict-prototypes -Wno-trigraphs -Os \
 		  -fno-common -ffreestanding -fhonour-copts \
 		  -mabi=32 -march=mips32r2 \
 		  -Wa,-32 -Wa,-march=mips32r2 -Wa,-mips32r2 -Wa,--trap \
-		  -DCONFIG_CACHELINE_SIZE=32 -DKERNEL_ADDR=$(KERNEL_ADDR)
+		  -DCONFIG_CACHELINE_SIZE=$(CACHELINE_SIZE) \
+		  -DKERNEL_ADDR=$(KERNEL_ADDR)
 
 ASFLAGS		= $(CFLAGS) -D__ASSEMBLY__
 
-- 
cgit v1.2.3