From d4161798dd4061bd861aac5b34bca0e2900bc3fd Mon Sep 17 00:00:00 2001
From: Marek BehĂșn <kabel@blackhole.sk>
Date: Sat, 26 Sep 2020 21:42:52 +0000
Subject: perf: fix building with musl when NLS is enabled
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

This package fails with a strange error when building with musl when NLS
is enabled. The configuration thinks that libelf is not present, even
though DEPENDS contains +libelf, because when NLS is enabled, libelf.so
depends on libintl, and the correct LDFLAGS are missing for
libintl-full. This then causes the configuration script to check for
glibc, but this fails because we are using musl.

Signed-off-by: Marek BehĂșn <kabel@blackhole.sk>
---
 package/devel/perf/Makefile | 3 +++
 1 file changed, 3 insertions(+)

(limited to 'package')

diff --git a/package/devel/perf/Makefile b/package/devel/perf/Makefile
index 3bb403916b..e611d5eca3 100644
--- a/package/devel/perf/Makefile
+++ b/package/devel/perf/Makefile
@@ -22,6 +22,7 @@ PKG_FLAGS:=nonshared
 PKG_BUILD_DIR:=$(LINUX_DIR)/tools/perf-$(TARGET_DIR_NAME)
 
 include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/nls.mk
 
 define Package/perf
   SECTION:=devel
@@ -38,6 +39,8 @@ endef
 
 HOST_CFLAGS += -I$(LINUX_DIR)/tools/include
 
+TARGET_LDFLAGS += $(INTL_LDFLAGS)
+
 MAKE_FLAGS = \
 	ARCH="$(LINUX_KARCH)" \
 	NO_LIBPERL=1 \
-- 
cgit v1.2.3