From a12ab07e21fd554c558254c145ae9e75a54e964e Mon Sep 17 00:00:00 2001
From: Michael Heimpold <mhei@heimpold.de>
Date: Thu, 11 Apr 2019 21:01:08 +0200
Subject: procd: allow passing optional syslog facility as instance parameter

Optional syslog facility can be set by adding procd_set_param facility
$myfacility.
While at, also add stdout/stderr documentation.

Signed-off-by: Michael Heimpold <mhei@heimpold.de>
Signed-off-by: Hans Dedecker <dedeckeh@gmail.com> [PKG_SOURCE_VERSION update]
---
 package/system/procd/Makefile       | 8 ++++----
 package/system/procd/files/procd.sh | 5 ++++-
 2 files changed, 8 insertions(+), 5 deletions(-)

(limited to 'package/system/procd')

diff --git a/package/system/procd/Makefile b/package/system/procd/Makefile
index c6d1b05ca0..f31c8d0cea 100644
--- a/package/system/procd/Makefile
+++ b/package/system/procd/Makefile
@@ -8,13 +8,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=procd
-PKG_RELEASE:=2
+PKG_RELEASE:=1
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL=$(PROJECT_GIT)/project/procd.git
-PKG_SOURCE_DATE:=2019-04-26
-PKG_SOURCE_VERSION:=cfaed5630cdef2c1bf58bf57859ce36c62ad0905
-PKG_MIRROR_HASH:=2271f0dd3bd3b3a4a8261aa5017d4d384d37521974a8f7495e17559f16a59cac
+PKG_SOURCE_DATE:=2019-05-02
+PKG_SOURCE_VERSION:=61a8be6cb4423dde9c7e7262456f4a16752b9abc
+PKG_MIRROR_HASH:=6020e59d1a2983a5039e10fd1f5e7b89f229fefecdff9472729709fccc7cdf43
 CMAKE_INSTALL:=1
 
 PKG_LICENSE:=GPL-2.0
diff --git a/package/system/procd/files/procd.sh b/package/system/procd/files/procd.sh
index 72f25fe0c0..6115f0702f 100644
--- a/package/system/procd/files/procd.sh
+++ b/package/system/procd/files/procd.sh
@@ -20,6 +20,9 @@
 #     limits: resource limits (passed to the process)
 #     user info: array with 1 values $username
 #     pidfile: file name to write pid into
+#     stdout: boolean whether to redirect commands stdout to syslog (default: 0)
+#     stderr: boolean whether to redirect commands stderr to syslog (default: 0)
+#     facility: syslog facility used when logging to syslog (default: daemon)
 #
 #   No space separation is done for arrays/tables - use one function argument per command line argument
 #
@@ -249,7 +252,7 @@ _procd_set_param() {
 		reload_signal)
 			json_add_int "$type" $(kill -l "$1")
 		;;
-		pidfile|user|seccomp|capabilities)
+		pidfile|user|seccomp|capabilities|facility)
 			json_add_string "$type" "$1"
 		;;
 		stdout|stderr|no_new_privs)
-- 
cgit v1.2.3