From 4bcf6acb1454a4450c3060054e0e2d15183c836f Mon Sep 17 00:00:00 2001
From: Felix Fietkau <nbd@nbd.name>
Date: Thu, 29 Mar 2018 11:57:08 +0200
Subject: Revert "ppp: make ppp-multilink provide ppp"

opkg currently has some issues with Provides and this change makes the
image builder fail because of that. Revert the change for now until opkg
is fixed

This reverts commit 092d75aa3e86db8331fffdbd0a99987df9dc438b.

Signed-off-by: Felix Fietkau <nbd@nbd.name>
---
 package/network/services/ppp/Makefile | 19 +++++++++----------
 1 file changed, 9 insertions(+), 10 deletions(-)

(limited to 'package/network')

diff --git a/package/network/services/ppp/Makefile b/package/network/services/ppp/Makefile
index ab8780b83d..beeaa53c22 100644
--- a/package/network/services/ppp/Makefile
+++ b/package/network/services/ppp/Makefile
@@ -46,7 +46,6 @@ $(call Package/ppp/Default)
   DEPENDS:=+kmod-ppp
   TITLE:=PPP daemon (with multilink support)
   VARIANT:=multilink
-  PROVIDES:=ppp
 endef
 
 define Package/ppp/description
@@ -65,7 +64,7 @@ endef
 
 define Package/ppp-mod-pppoa
 $(call Package/ppp/Default)
-  DEPENDS:=ppp +linux-atm +kmod-pppoa
+  DEPENDS:=@(PACKAGE_ppp||PACKAGE_ppp-multilink) +linux-atm +kmod-pppoa
   TITLE:=PPPoA plugin
 endef
 
@@ -75,7 +74,7 @@ endef
 
 define Package/ppp-mod-pppoe
 $(call Package/ppp/Default)
-  DEPENDS:=ppp +kmod-pppoe
+  DEPENDS:=@(PACKAGE_ppp||PACKAGE_ppp-multilink) +kmod-pppoe
   TITLE:=PPPoE plugin
 endef
 
@@ -85,7 +84,7 @@ endef
 
 define Package/ppp-mod-radius
 $(call Package/ppp/Default)
-  DEPENDS:=ppp
+  DEPENDS:=@(PACKAGE_ppp||PACKAGE_ppp-multilink)
   TITLE:=RADIUS plugin
 endef
 
@@ -101,7 +100,7 @@ endef
 
 define Package/ppp-mod-pppol2tp
 $(call Package/ppp/Default)
-  DEPENDS:=ppp +kmod-pppol2tp
+  DEPENDS:=@(PACKAGE_ppp||PACKAGE_ppp-multilink) +kmod-pppol2tp
   TITLE:=PPPoL2TP plugin
 endef
 
@@ -111,7 +110,7 @@ endef
 
 define Package/ppp-mod-pptp
 $(call Package/ppp/Default)
-  DEPENDS:=ppp +kmod-pptp +kmod-mppe +resolveip
+  DEPENDS:=@(PACKAGE_ppp||PACKAGE_ppp-multilink) +kmod-pptp +kmod-mppe +resolveip
   TITLE:=PPtP plugin
 endef
 
@@ -121,7 +120,7 @@ endef
 
 define Package/ppp-mod-passwordfd
 $(call Package/ppp/Default)
-  DEPENDS:=ppp
+  DEPENDS:=@(PACKAGE_ppp||PACKAGE_ppp-multilink)
   TITLE:=pap/chap secret from filedescriptor
 endef
 
@@ -142,7 +141,7 @@ endef
 
 define Package/pppdump
 $(call Package/ppp/Default)
-  DEPENDS:=ppp
+  DEPENDS:=@(PACKAGE_ppp||PACKAGE_ppp-multilink)
   TITLE:=Read PPP record file
 endef
 
@@ -152,7 +151,7 @@ endef
 
 define Package/pppstats
 $(call Package/ppp/Default)
-  DEPENDS:=ppp
+  DEPENDS:=@(PACKAGE_ppp||PACKAGE_ppp-multilink)
   TITLE:=Report PPP statistics
 endef
 
@@ -162,7 +161,7 @@ endef
 
 define Package/pppoe-discovery
 $(call Package/ppp/Default)
-  DEPENDS:=ppp +ppp-mod-pppoe
+  DEPENDS:=@(PACKAGE_ppp||PACKAGE_ppp-multilink) +ppp-mod-pppoe
   TITLE:=Perform a PPPoE-discovery process
 endef
 
-- 
cgit v1.2.3