From 007e947976132cb6a39befcf8883beef69e7bee9 Mon Sep 17 00:00:00 2001
From: Michael Heimpold <mhei@heimpold.de>
Date: Tue, 26 Mar 2019 22:09:24 +0100
Subject: fconfig: cleanup Makefile

We do not need to define an empty Build/Configure since
the default checks for existing ./configure and does nothing
in case nothing is found.

Similar for Build/Compile: we can remove the definition
when we only call the default.

Signed-off-by: Michael Heimpold <mhei@heimpold.de>
---
 package/boot/fconfig/Makefile | 7 -------
 1 file changed, 7 deletions(-)

(limited to 'package/boot/fconfig')

diff --git a/package/boot/fconfig/Makefile b/package/boot/fconfig/Makefile
index d82fa8db90..9b806fe97c 100644
--- a/package/boot/fconfig/Makefile
+++ b/package/boot/fconfig/Makefile
@@ -30,13 +30,6 @@ define Package/fconfig/description
 	displays and (if writable) also edits the RedBoot configuration.
 endef
 
-define Build/Configure
-endef
-
-define Build/Compile
-	$(call Build/Compile/Default)
-endef
-
 define Package/fconfig/install
 	$(INSTALL_DIR) $(1)/usr/sbin
 	$(INSTALL_BIN) $(PKG_BUILD_DIR)/fconfig $(1)/usr/sbin/
-- 
cgit v1.2.3