From 9ecec14ce0e40ef50e83dc48a44a3fd9e6fe9049 Mon Sep 17 00:00:00 2001
From: Felix Fietkau <nbd@openwrt.org>
Date: Thu, 23 Apr 2009 14:55:02 +0000
Subject: emit proper error messages if important kernel config files are
 missing

SVN-Revision: 15352
---
 include/target.mk | 8 +++++++-
 1 file changed, 7 insertions(+), 1 deletion(-)

(limited to 'include')

diff --git a/include/target.mk b/include/target.mk
index 5484592def..a554386cd8 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -119,7 +119,13 @@ LINUX_SUBCONFIG?=$(firstword $(wildcard $(PLATFORM_SUBDIR)/config-$(KERNEL_PATCH
 ifeq ($(LINUX_CONFIG),$(LINUX_SUBCONFIG))
   LINUX_SUBCONFIG:=
 endif
-LINUX_CONFCMD=$(if $(LINUX_CONFIG),$(SCRIPT_DIR)/kconfig.pl + $(GENERIC_LINUX_CONFIG) $(if $(LINUX_SUBCONFIG),+ $(LINUX_CONFIG) $(LINUX_SUBCONFIG),$(LINUX_CONFIG)),true)
+LINUX_CONFCMD=$(if $(LINUX_CONFIG), \
+	$(if $(GENERIC_LINUX_CONFIG),,$(error The generic kernel config for your kernel version is mising)) \
+	$(if $(LINUX_CONFIG),,$(error The target kernel config for your kernel version is mising)) \
+	$(SCRIPT_DIR)/kconfig.pl \
+		+ $(GENERIC_LINUX_CONFIG) \
+		$(if $(LINUX_SUBCONFIG),+ $(LINUX_CONFIG) $(LINUX_SUBCONFIG),$(LINUX_CONFIG)), \
+	true)
 
 ifeq ($(DUMP),1)
   BuildTarget=$(BuildTargets/DumpCurrent)
-- 
cgit v1.2.3