summaryrefslogtreecommitdiff
path: root/target/linux/lantiq/modules.mk
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2010-12-12 22:57:16 +0000
committerJohn Crispin <john@openwrt.org>2010-12-12 22:57:16 +0000
commit9f47e80bb30bed05ebcdfe671d4f2a9e9c7bfe55 (patch)
tree3d80c2524b0e73b5f7c9982eca4fe9301efdf75a /target/linux/lantiq/modules.mk
parentf590b304ef7d22242e08c86866cbb37927f0a404 (diff)
adds new lantiq kernel. once the codebase is fully tested and know to be working on all the devices previously supported by ifxmips, we will drop ifxmips support.
SVN-Revision: 24526
Diffstat (limited to 'target/linux/lantiq/modules.mk')
-rw-r--r--target/linux/lantiq/modules.mk47
1 files changed, 47 insertions, 0 deletions
diff --git a/target/linux/lantiq/modules.mk b/target/linux/lantiq/modules.mk
new file mode 100644
index 0000000000..78289a1a11
--- /dev/null
+++ b/target/linux/lantiq/modules.mk
@@ -0,0 +1,47 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define KernelPackage/lantiq-deu
+ TITLE:=Lantiq data encryption unit
+ SUBMENU:=$(CRYPTO_MENU)
+ DEPENDS:=@TARGET_lantiq
+ KCONFIG:=CONFIG_CRYPTO_DEV_LANTIQ \
+ CONFIG_CRYPTO_HW=y \
+ CONFIG_CRYPTO_DEV_LANTIQ_AES=y \
+ CONFIG_CRYPTO_DEV_LANTIQ_DES=y \
+ CONFIG_CRYPTO_DEV_LANTIQ_MD5=y \
+ CONFIG_CRYPTO_DEV_LANTIQ_SHA1=y
+ $(call AddDepends/crypto)
+endef
+
+define KernelPackage/lantiq-deu/description
+ Kernel support for the Lantiq crypto HW
+endef
+
+$(eval $(call KernelPackage,lantiq-deu))
+
+USB_MENU:=USB Support
+
+define KernelPackage/usb-dwc-otg
+ TITLE:=Synopsis DWC_OTG support
+ SUBMENU:=$(USB_MENU)
+ DEPENDS+=@TARGET_lantiq_xway +kmod-usb-core
+ KCONFIG:=CONFIG_DWC_OTG \
+ CONFIG_DWC_OTG_DEBUG=n \
+ CONFIG_DWC_OTG_LANTIQ=y \
+ CONFIG_DWC_OTG_HOST_ONLY=y
+ FILES:=$(LINUX_DIR)/drivers/usb/dwc_otg/dwc_otg.ko
+ AUTOLOAD:=$(call AutoLoad,50,dwc_otg)
+endef
+
+define KernelPackage/usb-dwc-otg/description
+ Kernel support for Synopsis USB on XWAY
+endef
+
+$(eval $(call KernelPackage,usb-dwc-otg))
+
+