From 5d8d4fbbcb5c5de9370711c19bb3510210989a98 Mon Sep 17 00:00:00 2001
From: Ilya Lipnitskiy <ilya.lipnitskiy@gmail.com>
Date: Sat, 20 Feb 2021 16:02:15 -0800
Subject: treewide: Run refresh on all packages

The crude loop I wrote to come up with this changeset:

  find -L package/feeds/packages/ -name patches | \
  sed 's/patches$/refresh/' | sort | xargs make

Signed-off-by: Ilya Lipnitskiy <ilya.lipnitskiy@gmail.com>
---
 sound/espeak/patches/010-uclibcxx.patch            |  2 +-
 .../patches/0001-switch-to-new-alsa-api.patch      | 47 +++++++++---------
 sound/mpd/patches/010-iconv.patch                  |  2 -
 sound/mpd/patches/020-npupnp.patch                 | 46 +++++-------------
 sound/pulseaudio/patches/010-iconv.patch           |  2 +-
 ...nly-check-for-dns_sd.h-in-case-libdl-was-.patch |  5 --
 .../patches/010-select_broadcast_interface.patch   | 56 +++++++++++-----------
 sound/squeezelite/patches/020-no_libmad.patch      |  2 +-
 .../0002-gitignore-for-autotools-files.patch       |  6 ---
 ...onvert-text-to-.wav-using-svox-text-to-sp.patch | 12 -----
 sound/svox/patches/0004-add-header-files.patch     |  5 --
 sound/svox/patches/0005-Install-lang-files.patch   |  5 --
 sound/svox/patches/0006-Set-picolangdir.patch      |  9 +---
 sound/svox/patches/0008-64bits.patch               | 12 ++---
 sound/svox/patches/0009-Fix-link-order.patch       | 10 ++--
 sound/svox/patches/0011-subdir.patch               |  7 ++-
 sound/svox/patches/0012-no-headers.patch           |  7 ++-
 17 files changed, 83 insertions(+), 152 deletions(-)

(limited to 'sound')

diff --git a/sound/espeak/patches/010-uclibcxx.patch b/sound/espeak/patches/010-uclibcxx.patch
index f4d2f9a3a..127df3999 100644
--- a/sound/espeak/patches/010-uclibcxx.patch
+++ b/sound/espeak/patches/010-uclibcxx.patch
@@ -1,6 +1,6 @@
 --- a/src/Makefile
 +++ b/src/Makefile
-@@ -83,15 +83,15 @@ libespeak_SOURCES = speak_lib.cpp compiledict.cpp dictionary.cpp intonation.cpp
+@@ -83,15 +83,15 @@ libespeak_SOURCES = speak_lib.cpp compil
  
  SRCS1=$(speak_SOURCES)
  OBJS1=$(patsubst %.cpp,%.o,$(SRCS1))
diff --git a/sound/madplay/patches/0001-switch-to-new-alsa-api.patch b/sound/madplay/patches/0001-switch-to-new-alsa-api.patch
index 60d7bd379..d043818b0 100644
--- a/sound/madplay/patches/0001-switch-to-new-alsa-api.patch
+++ b/sound/madplay/patches/0001-switch-to-new-alsa-api.patch
@@ -2,24 +2,24 @@ Switch madplay to the new API. This is done thanks to a patch written
 by Micha Nelissen <micha@neli.hopto.org> and available at
 http://article.gmane.org/gmane.comp.audio.mad.devel/729.
 
---- madplay-0.15.2b/audio_alsa.c	2008-10-18 15:10:16.000000000 +0200
-+++ madplay-0.15.2b/audio_alsa.c.new	2008-10-18 15:03:27.000000000 +0200
+--- a/audio_alsa.c
++++ b/audio_alsa.c
 @@ -28,31 +28,30 @@
-
+ 
  #include <errno.h>
-
+ 
 -#define ALSA_PCM_OLD_HW_PARAMS_API
 -#define ALSA_PCM_OLD_SW_PARAMS_API
  #include <alsa/asoundlib.h>
-
+ 
  #include <mad.h>
-
+ 
  #include "audio.h"
-
+ 
 -char *buf	= NULL;
 -int paused	= 0;
 +#define BUFFER_TIME_MAX     500000
-
+ 
 -int rate	= -1;
 -int channels	= -1;
 -int bitdepth	= -1;
@@ -39,17 +39,17 @@ http://article.gmane.org/gmane.comp.audio.mad.devel/729.
 +unsigned int buffer_time;
 +unsigned int period_time;
 +char *defaultdev	    = "plughw:0,0";
-
+ 
  snd_pcm_hw_params_t *alsa_hwparams;
  snd_pcm_sw_params_t *alsa_swparams;
-
+ 
 -snd_pcm_sframes_t buffer_size;
 -snd_pcm_sframes_t period_size;
 +snd_pcm_uframes_t buffer_size;
-
+ 
  snd_pcm_format_t  alsa_format = -1;
  snd_pcm_access_t  alsa_access = SND_PCM_ACCESS_MMAP_INTERLEAVED;
-@@ -66,14 +65,20 @@
+@@ -66,14 +65,20 @@ int set_hwparams(snd_pcm_t *handle,
  		 snd_pcm_hw_params_t *params,
  		 snd_pcm_access_t access)
  {
@@ -72,7 +72,7 @@ http://article.gmane.org/gmane.comp.audio.mad.devel/729.
  	/* set the sample format */
  	err = snd_pcm_hw_params_set_format(handle, params, alsa_format);
  	if (err < 0) {
-@@ -87,29 +92,38 @@
+@@ -87,29 +92,38 @@ int set_hwparams(snd_pcm_t *handle,
  		return err;
  	}
  	/* set the stream rate */
@@ -120,15 +120,15 @@ http://article.gmane.org/gmane.comp.audio.mad.devel/729.
  	/* write the parameters to device */
  	err = snd_pcm_hw_params(handle, params);
  	if (err < 0) {
-@@ -123,6 +137,7 @@
+@@ -123,6 +137,7 @@ static
  int set_swparams(snd_pcm_t *handle,
  		 snd_pcm_sw_params_t *params)
  {
 +        unsigned int start_threshold;
  	int err;
-
+ 
          /* get current swparams */
-@@ -136,13 +151,7 @@
+@@ -136,13 +151,7 @@ int set_swparams(snd_pcm_t *handle,
          if (err < 0) {
                  printf("Unable to set start threshold mode for playback: %s\n", snd_strerror(err));
                  return err;
@@ -143,31 +143,30 @@ http://article.gmane.org/gmane.comp.audio.mad.devel/729.
          /* align all transfers to 1 samples */
          err = snd_pcm_sw_params_set_xfer_align(handle, params, 1);
          if (err < 0) {
-@@ -190,7 +199,7 @@
+@@ -190,7 +199,7 @@ int config(struct audio_config *config)
  	rate		= config->speed;
-
+ 
  	if ( bitdepth == 0 )
 -		config->precision = bitdepth = 32;
 +		config->precision = bitdepth = 16;
-
+ 
  	switch (bitdepth)
  	{
-@@ -241,7 +250,7 @@
+@@ -241,7 +250,7 @@ int config(struct audio_config *config)
  		return -1;
  	}
-
+ 
 -	buf = malloc(buffer_size);
 +	buf = malloc(buffer_size * sample_size);
  	if (buf == NULL) {
  		audio_error="unable to allocate output buffer table";
  		return -1;
-@@ -279,7 +288,7 @@
+@@ -279,7 +288,7 @@ static
  int play(struct audio_play *play)
  {
  	int err, len;
 -	char *ptr;
 +	unsigned char *ptr;
-
+ 
  	ptr = buf;
  	len = play->nsamples;
-
diff --git a/sound/mpd/patches/010-iconv.patch b/sound/mpd/patches/010-iconv.patch
index d589db30e..c1f1ffcca 100644
--- a/sound/mpd/patches/010-iconv.patch
+++ b/sound/mpd/patches/010-iconv.patch
@@ -16,8 +16,6 @@ Signed-off-by: Rosen Penev <rosenp@gmail.com>
  src/lib/icu/meson.build | 14 ++++++++++++--
  1 file changed, 12 insertions(+), 2 deletions(-)
 
-diff --git a/src/lib/icu/meson.build b/src/lib/icu/meson.build
-index bd6e30944..e63d614a0 100644
 --- a/src/lib/icu/meson.build
 +++ b/src/lib/icu/meson.build
 @@ -18,8 +18,18 @@ if icu_dep.found()
diff --git a/sound/mpd/patches/020-npupnp.patch b/sound/mpd/patches/020-npupnp.patch
index 02d255673..dbe21e094 100644
--- a/sound/mpd/patches/020-npupnp.patch
+++ b/sound/mpd/patches/020-npupnp.patch
@@ -18,11 +18,9 @@ Subject: [PATCH] Modification to use npupnp instead of pupnp when the upnp
  src/lib/upnp/meson.build                      |  20 +++-
  11 files changed, 170 insertions(+), 11 deletions(-)
 
-diff --git a/meson_options.txt b/meson_options.txt
-index d17ac1ca8..da90ccfd8 100644
 --- a/meson_options.txt
 +++ b/meson_options.txt
-@@ -54,7 +54,10 @@ option('dsd', type: 'boolean', value: true, description: 'Support the DSD audio
+@@ -54,7 +54,10 @@ option('dsd', type: 'boolean', value: tr
  #
  
  option('database', type: 'boolean', value: true, description: 'enable support for the music database')
@@ -34,8 +32,6 @@ index d17ac1ca8..da90ccfd8 100644
  option('libmpdclient', type: 'feature', description: 'libmpdclient support (for the proxy database plugin)')
  
  #
-diff --git a/src/db/plugins/upnp/ContentDirectoryService.cxx b/src/db/plugins/upnp/ContentDirectoryService.cxx
-index 99893d89d..29d58ca23 100644
 --- a/src/db/plugins/upnp/ContentDirectoryService.cxx
 +++ b/src/db/plugins/upnp/ContentDirectoryService.cxx
 @@ -18,7 +18,10 @@
@@ -61,7 +57,7 @@ index 99893d89d..29d58ca23 100644
  static void
  ReadResultTag(UPnPDirContent &dirbuf, IXML_Document *response)
  {
-@@ -39,6 +45,7 @@ ReadResultTag(UPnPDirContent &dirbuf, IXML_Document *response)
+@@ -39,6 +45,7 @@ ReadResultTag(UPnPDirContent &dirbuf, IX
  
  	dirbuf.Parse(p);
  }
@@ -69,7 +65,7 @@ index 99893d89d..29d58ca23 100644
  
  inline void
  ContentDirectoryService::readDirSlice(UpnpClient_Handle hdl,
-@@ -47,6 +54,7 @@ ContentDirectoryService::readDirSlice(UpnpClient_Handle hdl,
+@@ -47,6 +54,7 @@ ContentDirectoryService::readDirSlice(Up
  				      unsigned &didreadp,
  				      unsigned &totalp) const
  {
@@ -77,7 +73,7 @@ index 99893d89d..29d58ca23 100644
  	// Some devices require an empty SortCriteria, else bad params
  	IXML_Document *request =
  		MakeActionHelper("Browse", m_serviceType.c_str(),
-@@ -82,6 +90,37 @@ ContentDirectoryService::readDirSlice(UpnpClient_Handle hdl,
+@@ -82,6 +90,37 @@ ContentDirectoryService::readDirSlice(Up
  		totalp = ParseUnsigned(value);
  
  	ReadResultTag(dirbuf, response);
@@ -115,7 +111,7 @@ index 99893d89d..29d58ca23 100644
  }
  
  UPnPDirContent
-@@ -110,6 +149,7 @@ ContentDirectoryService::search(UpnpClient_Handle hdl,
+@@ -110,6 +149,7 @@ ContentDirectoryService::search(UpnpClie
  	unsigned offset = 0, total = -1, count;
  
  	do {
@@ -123,7 +119,7 @@ index 99893d89d..29d58ca23 100644
  		UniqueIxmlDocument request(MakeActionHelper("Search", m_serviceType.c_str(),
  							    "ContainerID", objectId,
  							    "SearchCriteria", ss,
-@@ -147,6 +187,39 @@ ContentDirectoryService::search(UpnpClient_Handle hdl,
+@@ -147,6 +187,39 @@ ContentDirectoryService::search(UpnpClie
  			total = ParseUnsigned(value);
  
  		ReadResultTag(dirbuf, response.get());
@@ -171,7 +167,7 @@ index 99893d89d..29d58ca23 100644
  	// Create request
  	UniqueIxmlDocument request(MakeActionHelper("Browse", m_serviceType.c_str(),
  						    "ObjectID", objectId,
-@@ -179,4 +253,31 @@ ContentDirectoryService::getMetadata(UpnpClient_Handle hdl,
+@@ -179,4 +253,31 @@ ContentDirectoryService::getMetadata(Upn
  	UPnPDirContent dirbuf;
  	ReadResultTag(dirbuf, response.get());
  	return dirbuf;
@@ -203,11 +199,9 @@ index 99893d89d..29d58ca23 100644
 +	return dirbuf;
 +#endif
  }
-diff --git a/src/lib/upnp/Action.hxx b/src/lib/upnp/Action.hxx
-index 49ed75198..4ecf4cb06 100644
 --- a/src/lib/upnp/Action.hxx
 +++ b/src/lib/upnp/Action.hxx
-@@ -38,6 +38,7 @@ CountNameValuePairs(gcc_unused const char *name, gcc_unused const char *value,
+@@ -38,6 +38,7 @@ CountNameValuePairs(gcc_unused const cha
  	return 1 + CountNameValuePairs(args...);
  }
  
@@ -215,15 +209,13 @@ index 49ed75198..4ecf4cb06 100644
  /**
   * A wrapper for UpnpMakeAction() that counts the number of name/value
   * pairs and adds the nullptr sentinel.
-@@ -52,5 +53,6 @@ MakeActionHelper(const char *action_name, const char *service_type,
+@@ -52,5 +53,6 @@ MakeActionHelper(const char *action_name
  			      args...,
  			      nullptr, nullptr);
  }
 +#endif
  
  #endif
-diff --git a/src/lib/upnp/ClientInit.cxx b/src/lib/upnp/ClientInit.cxx
-index 23ba9cade..54b677fa2 100644
 --- a/src/lib/upnp/ClientInit.cxx
 +++ b/src/lib/upnp/ClientInit.cxx
 @@ -31,14 +31,12 @@ static Mutex upnp_client_init_mutex;
@@ -246,8 +238,6 @@ index 23ba9cade..54b677fa2 100644
  	if (cookie == nullptr)
  		/* this is the cookie passed to UpnpRegisterClient();
  		   but can this ever happen?  Will libupnp ever invoke
-diff --git a/src/lib/upnp/Compat.hxx b/src/lib/upnp/Compat.hxx
-index 7fba1d83b..b9a4d7cf3 100644
 --- a/src/lib/upnp/Compat.hxx
 +++ b/src/lib/upnp/Compat.hxx
 @@ -22,14 +22,14 @@
@@ -267,8 +257,6 @@ index 7fba1d83b..b9a4d7cf3 100644
  #include "util/Compiler.h"
  
  gcc_pure
-diff --git a/src/lib/upnp/ContentDirectoryService.cxx b/src/lib/upnp/ContentDirectoryService.cxx
-index ae514c717..eed28b41a 100644
 --- a/src/lib/upnp/ContentDirectoryService.cxx
 +++ b/src/lib/upnp/ContentDirectoryService.cxx
 @@ -17,15 +17,21 @@
@@ -293,7 +281,7 @@ index ae514c717..eed28b41a 100644
  ContentDirectoryService::ContentDirectoryService(const UPnPDevice &device,
  						 const UPnPService &service) noexcept
  	:m_actionURL(uri_apply_base(service.controlURL, device.URLBase)),
-@@ -51,6 +57,7 @@ ContentDirectoryService::~ContentDirectoryService() noexcept
+@@ -51,6 +57,7 @@ ContentDirectoryService::~ContentDirecto
  std::forward_list<std::string>
  ContentDirectoryService::getSearchCapabilities(UpnpClient_Handle hdl) const
  {
@@ -301,7 +289,7 @@ index ae514c717..eed28b41a 100644
  	UniqueIxmlDocument request(UpnpMakeAction("GetSearchCapabilities", m_serviceType.c_str(),
  						  0,
  						  nullptr, nullptr));
-@@ -69,6 +76,24 @@ ContentDirectoryService::getSearchCapabilities(UpnpClient_Handle hdl) const
+@@ -69,6 +76,24 @@ ContentDirectoryService::getSearchCapabi
  
  	const char *s = ixmlwrap::getFirstElementValue(response.get(),
  						       "SearchCaps");
@@ -326,8 +314,6 @@ index ae514c717..eed28b41a 100644
  	if (s == nullptr || *s == 0)
  		/* we could just "return {}" here, but GCC 5 doesn't
  		   understand that */
-diff --git a/src/lib/upnp/Init.cxx b/src/lib/upnp/Init.cxx
-index 7ad4d565a..10510402a 100644
 --- a/src/lib/upnp/Init.cxx
 +++ b/src/lib/upnp/Init.cxx
 @@ -23,7 +23,9 @@
@@ -351,8 +337,6 @@ index 7ad4d565a..10510402a 100644
  }
  
  void
-diff --git a/src/lib/upnp/UniqueIxml.hxx b/src/lib/upnp/UniqueIxml.hxx
-index 2ff2afa62..8a0ea0a1f 100644
 --- a/src/lib/upnp/UniqueIxml.hxx
 +++ b/src/lib/upnp/UniqueIxml.hxx
 @@ -20,6 +20,7 @@
@@ -369,8 +353,6 @@ index 2ff2afa62..8a0ea0a1f 100644
  
 +#endif /* USING_PUPNP */
  #endif
-diff --git a/src/lib/upnp/ixmlwrap.cxx b/src/lib/upnp/ixmlwrap.cxx
-index 4e44f35a6..c7798e557 100644
 --- a/src/lib/upnp/ixmlwrap.cxx
 +++ b/src/lib/upnp/ixmlwrap.cxx
 @@ -15,6 +15,9 @@
@@ -383,13 +365,11 @@ index 4e44f35a6..c7798e557 100644
  #include "ixmlwrap.hxx"
  #include "UniqueIxml.hxx"
  
-@@ -39,3 +42,4 @@ getFirstElementValue(IXML_Document *doc, const char *name) noexcept
+@@ -39,3 +42,4 @@ getFirstElementValue(IXML_Document *doc,
  }
  
  }
 +#endif
-diff --git a/src/lib/upnp/ixmlwrap.hxx b/src/lib/upnp/ixmlwrap.hxx
-index 6713d59bd..4b01801f7 100644
 --- a/src/lib/upnp/ixmlwrap.hxx
 +++ b/src/lib/upnp/ixmlwrap.hxx
 @@ -17,6 +17,7 @@
@@ -406,8 +386,6 @@ index 6713d59bd..4b01801f7 100644
  
 +#endif /* USING_PUPNP */
  #endif /* _IXMLWRAP_H_INCLUDED_ */
-diff --git a/src/lib/upnp/meson.build b/src/lib/upnp/meson.build
-index 9e16f7319..bdc248e6c 100644
 --- a/src/lib/upnp/meson.build
 +++ b/src/lib/upnp/meson.build
 @@ -1,4 +1,22 @@
diff --git a/sound/pulseaudio/patches/010-iconv.patch b/sound/pulseaudio/patches/010-iconv.patch
index c98a24d5b..5a6f394a7 100644
--- a/sound/pulseaudio/patches/010-iconv.patch
+++ b/sound/pulseaudio/patches/010-iconv.patch
@@ -1,6 +1,6 @@
 --- a/meson.build
 +++ b/meson.build
-@@ -380,12 +380,11 @@ if dl_dep.found()
+@@ -391,12 +391,11 @@ if dl_dep.found()
  endif
  
  have_iconv = false
diff --git a/sound/shairplay/patches/010-configure-only-check-for-dns_sd.h-in-case-libdl-was-.patch b/sound/shairplay/patches/010-configure-only-check-for-dns_sd.h-in-case-libdl-was-.patch
index 5aa5c5300..84db6b8c6 100644
--- a/sound/shairplay/patches/010-configure-only-check-for-dns_sd.h-in-case-libdl-was-.patch
+++ b/sound/shairplay/patches/010-configure-only-check-for-dns_sd.h-in-case-libdl-was-.patch
@@ -8,8 +8,6 @@ Subject: [PATCH] [configure] - only check for dns_sd.h in case libdl was not
  configure.ac | 2 +-
  1 file changed, 1 insertion(+), 1 deletion(-)
 
-diff --git a/configure.ac b/configure.ac
-index 5a4b8ad..682d74b 100644
 --- a/configure.ac
 +++ b/configure.ac
 @@ -19,7 +19,7 @@ LT_LIB_DLLOAD
@@ -21,6 +19,3 @@ index 5a4b8ad..682d74b 100644
  then
    AC_CHECK_HEADERS([dns_sd.h], [],
                     [AC_MSG_ERROR([Could not find dns_sd.h header, please install libavahi-compat-libdnssd-dev or equivalent.])])
--- 
-2.17.1
-
diff --git a/sound/squeezelite/patches/010-select_broadcast_interface.patch b/sound/squeezelite/patches/010-select_broadcast_interface.patch
index 145287379..e101fc0bb 100644
--- a/sound/squeezelite/patches/010-select_broadcast_interface.patch
+++ b/sound/squeezelite/patches/010-select_broadcast_interface.patch
@@ -76,7 +76,7 @@
  	stream_close();
 --- a/slimproto.c
 +++ b/slimproto.c
-@@ -113,7 +113,7 @@ void send_packet(u8_t *packet, size_t len) {
+@@ -113,7 +113,7 @@ void send_packet(u8_t *packet, size_t le
  	}
  }
  
@@ -94,7 +94,7 @@
  	struct sockaddr_in d;
  	struct sockaddr_in s;
  	char *buf;
-@@ -778,7 +778,7 @@ in_addr_t discover_server(char *default_server) {
+@@ -778,7 +778,7 @@ in_addr_t discover_server(char *default_
  	memset(&d, 0, sizeof(d));
  	d.sin_family = AF_INET;
  	d.sin_port = htons(PORT);
@@ -103,7 +103,7 @@
  
  	pollinfo.fd = disc_sock;
  	pollinfo.events = POLLIN;
-@@ -813,7 +813,7 @@ in_addr_t discover_server(char *default_server) {
+@@ -813,7 +813,7 @@ in_addr_t discover_server(char *default_
  #define FIXED_CAP_LEN 256
  #define VAR_CAP_LEN   128
  
@@ -112,7 +112,7 @@
  	struct sockaddr_in serv_addr;
  	static char fixed_cap[FIXED_CAP_LEN], var_cap[VAR_CAP_LEN] = "";
  	bool reconnect = false;
-@@ -834,7 +834,7 @@ void slimproto(log_level level, char *server, u8_t mac[6], const char *name, con
+@@ -834,7 +834,7 @@ void slimproto(log_level level, char *se
  	}
  
  	if (!slimproto_ip) {
@@ -121,7 +121,7 @@
  	}
  
  	if (!slimproto_port) {
-@@ -915,7 +915,7 @@ void slimproto(log_level level, char *server, u8_t mac[6], const char *name, con
+@@ -915,7 +915,7 @@ void slimproto(log_level level, char *se
  
  			// rediscover server if it was not set at startup
  			if (!server && ++failed_connect > 5) {
@@ -132,7 +132,7 @@
  		} else {
 --- a/squeezelite.h
 +++ b/squeezelite.h
-@@ -455,7 +455,7 @@ char* strcasestr(const char *haystack, const char *needle);
+@@ -455,7 +455,7 @@ char* strcasestr(const char *haystack, c
  
  char *next_param(char *src, char c);
  u32_t gettime_ms(void);
@@ -141,7 +141,7 @@
  void set_nonblock(sockfd s);
  int connect_timeout(sockfd sock, const struct sockaddr *addr, socklen_t addrlen, int timeout);
  void server_addr(char *server, in_addr_t *ip_ptr, unsigned *port_ptr);
-@@ -511,7 +511,7 @@ void buf_init(struct buffer *buf, size_t size);
+@@ -511,7 +511,7 @@ void buf_init(struct buffer *buf, size_t
  void buf_destroy(struct buffer *buf);
  
  // slimproto.c
@@ -220,29 +220,23 @@
 +	unsigned char *ptr;
 +	in_addr_t bcast_addr = 0;
 +	int have_mac = 0, have_ifname = 0;
- 
--	}
++
 +	loglevel = level;
- 
--	mac[0] = mac[1] = mac[2] = mac[3] = mac[4] = mac[5] = 0;
++
 +	// Check for non-zero MAC
 +	if (mac[0] | mac[1] | mac[2] != 0)
 +		have_mac = 1;
- 
--	int s = socket(AF_INET, SOCK_DGRAM, 0);
++
 +	// Copy interface name, if it was provided.
 +	if (iface != NULL) {
 +		if (strlen(iface) > sizeof(ifname))
 +			return -1;
  
--	ifc.ifc_len = sizeof(ifs);
--	ifc.ifc_req = ifs;
 +		strncpy(ifname, iface, sizeof(ifname) - 1);
 +		have_ifname = 1;
-+	}
+ 	}
  
--	if (ioctl(s, SIOCGIFCONF, &ifc) == 0) {
--		ifend = ifs + (ifc.ifc_len / sizeof(struct ifreq));
+-	mac[0] = mac[1] = mac[2] = mac[3] = mac[4] = mac[5] = 0;
 +	if (getifaddrs(&addrs) == 0) {
 +		//iterate to find corresponding ethernet address
 +		for (ifa = addrs; ifa; ifa = ifa->ifa_next) {
@@ -253,7 +247,8 @@
 +                                || !ifa->ifa_flags & IFF_BROADCAST) {
 +				continue;
 +			}
-+
+ 
+-	int s = socket(AF_INET, SOCK_DGRAM, 0);
 +			if (!have_ifname) {
 +				// We have found a valid interface name. Keep it.
 +				strncpy(ifname, ifa->ifa_name, sizeof(ifname) - 1);
@@ -265,15 +260,11 @@
 +				}
 +			}
  
--		for (ifr = ifc.ifc_req; ifr < ifend; ifr++) {
--			if (ifr->ifr_addr.sa_family == AF_INET) {
+-	ifc.ifc_len = sizeof(ifs);
+-	ifc.ifc_req = ifs;
  
--				strncpy(ifreq.ifr_name, ifr->ifr_name, sizeof(ifreq.ifr_name) - 1);
--				if (ioctl (s, SIOCGIFHWADDR, &ifreq) == 0) {
--					memcpy(mac, ifreq.ifr_hwaddr.sa_data, 6);
--					if (mac[0]+mac[1]+mac[2] != 0) {
--						break;
--					}
+-	if (ioctl(s, SIOCGIFCONF, &ifc) == 0) {
+-		ifend = ifs + (ifc.ifc_len / sizeof(struct ifreq));
 +			// Check address family.
 +			if (ifa->ifa_addr && ifa->ifa_addr->sa_family == AF_INET &&
 +			    ((struct sockaddr_in *)ifa->ifa_broadaddr)->sin_addr.s_addr != 0) {
@@ -287,7 +278,16 @@
 +					have_ifname = 0;
 +			}
 +		}
-+
+ 
+-		for (ifr = ifc.ifc_req; ifr < ifend; ifr++) {
+-			if (ifr->ifr_addr.sa_family == AF_INET) {
+-
+-				strncpy(ifreq.ifr_name, ifr->ifr_name, sizeof(ifreq.ifr_name) - 1);
+-				if (ioctl (s, SIOCGIFHWADDR, &ifreq) == 0) {
+-					memcpy(mac, ifreq.ifr_hwaddr.sa_data, 6);
+-					if (mac[0]+mac[1]+mac[2] != 0) {
+-						break;
+-					}
 +		// Find MAC address matching interface
 +		if (!have_mac && bcast_addr != 0) {
 +			for (ifa = addrs; ifa; ifa = ifa->ifa_next) {
diff --git a/sound/squeezelite/patches/020-no_libmad.patch b/sound/squeezelite/patches/020-no_libmad.patch
index c65243210..435a31e82 100644
--- a/sound/squeezelite/patches/020-no_libmad.patch
+++ b/sound/squeezelite/patches/020-no_libmad.patch
@@ -20,7 +20,7 @@
  LINKALL_IR       = -llirc_client
 --- a/decode.c
 +++ b/decode.c
-@@ -184,11 +184,7 @@ void decode_init(log_level level, const char *include_codecs, const char *exclud
+@@ -184,11 +184,7 @@ void decode_init(log_level level, const
  	if (!strstr(exclude_codecs, "pcm")	&& (!include_codecs || (order_codecs = strstr(include_codecs, "pcm"))))
  		sort_codecs((include_codecs ? order_codecs - include_codecs : i), register_pcm());
  
diff --git a/sound/svox/patches/0002-gitignore-for-autotools-files.patch b/sound/svox/patches/0002-gitignore-for-autotools-files.patch
index df57df7f7..9fc0d792a 100644
--- a/sound/svox/patches/0002-gitignore-for-autotools-files.patch
+++ b/sound/svox/patches/0002-gitignore-for-autotools-files.patch
@@ -8,9 +8,6 @@ Subject: [PATCH 2/7] gitignore for autotools files
  1 files changed, 32 insertions(+), 0 deletions(-)
  create mode 100644 pico/.gitignore
 
-diff --git a/pico/.gitignore b/pico/.gitignore
-new file mode 100644
-index 0000000..4235569
 --- /dev/null
 +++ b/pico/.gitignore
 @@ -0,0 +1,32 @@
@@ -46,6 +43,3 @@ index 0000000..4235569
 +.libs
 +libttspico.la
 +
--- 
-1.7.1
-
diff --git a/sound/svox/patches/0003-pico2wave-Convert-text-to-.wav-using-svox-text-to-sp.patch b/sound/svox/patches/0003-pico2wave-Convert-text-to-.wav-using-svox-text-to-sp.patch
index 19b6df1b9..7744964ad 100644
--- a/sound/svox/patches/0003-pico2wave-Convert-text-to-.wav-using-svox-text-to-sp.patch
+++ b/sound/svox/patches/0003-pico2wave-Convert-text-to-.wav-using-svox-text-to-sp.patch
@@ -11,8 +11,6 @@ Subject: [PATCH 3/7] pico2wave: Convert text to .wav using svox text-to-speech s
  4 files changed, 352 insertions(+), 0 deletions(-)
  create mode 100644 pico/bin/pico2wave.c
 
-diff --git a/pico/.gitignore b/pico/.gitignore
-index 4235569..a110298 100644
 --- a/pico/.gitignore
 +++ b/pico/.gitignore
 @@ -29,4 +29,5 @@ libtool
@@ -21,8 +19,6 @@ index 4235569..a110298 100644
  libttspico.la
 +pico2wave
  
-diff --git a/pico/Makefile.am b/pico/Makefile.am
-index 6d8a10c..0d9472d 100644
 --- a/pico/Makefile.am
 +++ b/pico/Makefile.am
 @@ -34,3 +34,10 @@ libttspico_la_SOURCES = \
@@ -36,9 +32,6 @@ index 6d8a10c..0d9472d 100644
 +	libttspico.la -lm -lpopt
 +pico2wave_CFLAGS = -Wall -I lib
 +
-diff --git a/pico/bin/pico2wave.c b/pico/bin/pico2wave.c
-new file mode 100644
-index 0000000..0c035a7
 --- /dev/null
 +++ b/pico/bin/pico2wave.c
 @@ -0,0 +1,342 @@
@@ -384,8 +377,6 @@ index 0000000..0c035a7
 +    exit(ret);
 +}
 +
-diff --git a/pico/configure.in b/pico/configure.in
-index 0afb56d..349eb1d 100644
 --- a/pico/configure.in
 +++ b/pico/configure.in
 @@ -14,3 +14,6 @@ AC_CONFIG_FILES([Makefile])
@@ -395,6 +386,3 @@ index 0afb56d..349eb1d 100644
 +
 +AC_CHECK_LIB(popt, poptGetContext)
 +
--- 
-1.7.1
-
diff --git a/sound/svox/patches/0004-add-header-files.patch b/sound/svox/patches/0004-add-header-files.patch
index f05730827..3294b1467 100644
--- a/sound/svox/patches/0004-add-header-files.patch
+++ b/sound/svox/patches/0004-add-header-files.patch
@@ -7,8 +7,6 @@ Subject: [PATCH 4/7] add header files
  pico/Makefile.am |   36 ++++++++++++++++++++++++++++++++++++
  1 files changed, 36 insertions(+), 0 deletions(-)
 
-diff --git a/pico/Makefile.am b/pico/Makefile.am
-index 0d9472d..9151042 100644
 --- a/pico/Makefile.am
 +++ b/pico/Makefile.am
 @@ -34,6 +34,42 @@ libttspico_la_SOURCES = \
@@ -54,6 +52,3 @@ index 0d9472d..9151042 100644
  bin_PROGRAMS = pico2wave
  pico2wave_SOURCES = \
  	bin/pico2wave.c
--- 
-1.7.1
-
diff --git a/sound/svox/patches/0005-Install-lang-files.patch b/sound/svox/patches/0005-Install-lang-files.patch
index 95344e31f..b5dbf78e0 100644
--- a/sound/svox/patches/0005-Install-lang-files.patch
+++ b/sound/svox/patches/0005-Install-lang-files.patch
@@ -7,8 +7,6 @@ Subject: [PATCH 5/7] Install lang files
  pico/Makefile.am |    9 +++++++++
  1 files changed, 9 insertions(+), 0 deletions(-)
 
-diff --git a/pico/Makefile.am b/pico/Makefile.am
-index 9151042..8898050 100644
 --- a/pico/Makefile.am
 +++ b/pico/Makefile.am
 @@ -70,6 +70,15 @@ libttspico_la_HEADERS = \
@@ -27,6 +25,3 @@ index 9151042..8898050 100644
  bin_PROGRAMS = pico2wave
  pico2wave_SOURCES = \
  	bin/pico2wave.c
--- 
-1.7.1
-
diff --git a/sound/svox/patches/0006-Set-picolangdir.patch b/sound/svox/patches/0006-Set-picolangdir.patch
index 1ec646d75..c6291a666 100644
--- a/sound/svox/patches/0006-Set-picolangdir.patch
+++ b/sound/svox/patches/0006-Set-picolangdir.patch
@@ -8,8 +8,6 @@ Subject: [PATCH 6/7] Set picolangdir
  pico/bin/pico2wave.c |    4 ++++
  2 files changed, 5 insertions(+), 1 deletions(-)
 
-diff --git a/pico/Makefile.am b/pico/Makefile.am
-index 8898050..a19c42a 100644
 --- a/pico/Makefile.am
 +++ b/pico/Makefile.am
 @@ -84,5 +84,5 @@ pico2wave_SOURCES = \
@@ -19,11 +17,9 @@ index 8898050..a19c42a 100644
 -pico2wave_CFLAGS = -Wall -I lib
 +pico2wave_CFLAGS = -Wall -Dpicolangdir=\"$(picolangdir)\" -I lib
  
-diff --git a/pico/bin/pico2wave.c b/pico/bin/pico2wave.c
-index 0c035a7..ec7ab79 100644
 --- a/pico/bin/pico2wave.c
 +++ b/pico/bin/pico2wave.c
-@@ -35,7 +35,11 @@
+@@ -36,7 +36,11 @@
  
  /* string constants */
  #define MAX_OUTBUF_SIZE     128
@@ -35,6 +31,3 @@ index 0c035a7..ec7ab79 100644
  const char * PICO_VOICE_NAME                = "PicoVoice";
  
  /* supported voices
--- 
-1.7.1
-
diff --git a/sound/svox/patches/0008-64bits.patch b/sound/svox/patches/0008-64bits.patch
index 883a42e6d..432c16905 100644
--- a/sound/svox/patches/0008-64bits.patch
+++ b/sound/svox/patches/0008-64bits.patch
@@ -2,9 +2,9 @@ Description: fix execution on 64bit archs
 Bug: http://code.google.com/p/android/issues/detail?id=12224
 Author: Samuel Thibault <sthibault@debian.org>
 
---- svox/pico/lib/picoapi.c.original	2010-10-25 19:06:57.000000000 +0200
-+++ svox/pico/lib/picoapi.c	2010-10-25 19:07:18.000000000 +0200
-@@ -90,7 +90,7 @@
+--- a/pico/lib/picoapi.c
++++ b/pico/lib/picoapi.c
+@@ -90,7 +90,7 @@ pico_Status pico_initialize_priv(
          status = PICO_ERR_NULLPTR_ACCESS;
      } else {
          byte_ptr_t rest_mem;
@@ -13,9 +13,9 @@ Author: Samuel Thibault <sthibault@debian.org>
          pico_System sys;
          picoos_MemoryManager sysMM;
          picoos_ExceptionManager sysEM;
---- svox/pico/lib/picosig2.c.original	2010-10-26 00:17:18.000000000 +0200
-+++ svox/pico/lib/picosig2.c	2010-10-26 00:17:19.000000000 +0200
-@@ -568,7 +568,7 @@
+--- a/pico/lib/picosig2.c
++++ b/pico/lib/picosig2.c
+@@ -552,7 +552,7 @@ void mel_2_lin_lookup(sig_innerobj_t *si
      for (nI = 1; nI < m1; nI++) {
          XXr[nI] = c1[nI] << shift;
      }
diff --git a/sound/svox/patches/0009-Fix-link-order.patch b/sound/svox/patches/0009-Fix-link-order.patch
index bcf3870fe..b9c650397 100644
--- a/sound/svox/patches/0009-Fix-link-order.patch
+++ b/sound/svox/patches/0009-Fix-link-order.patch
@@ -1,8 +1,6 @@
-Index: svox-1.0+git20130326/pico/Makefile.am
-===================================================================
---- svox-1.0+git20130326.orig/pico/Makefile.am	2013-11-12 12:37:05.939979854 -0500
-+++ svox-1.0+git20130326/pico/Makefile.am	2013-11-12 13:00:52.336945041 -0500
-@@ -70,6 +70,8 @@
+--- a/pico/Makefile.am
++++ b/pico/Makefile.am
+@@ -70,6 +70,8 @@ libttspico_la_HEADERS = \
      lib/picotrns.h \
      lib/picowa.h
  
@@ -11,7 +9,7 @@ Index: svox-1.0+git20130326/pico/Makefile.am
  picolangdir = $(datadir)/pico/lang
  picolang_DATA = \
      lang/de-DE*.bin \
-@@ -83,6 +85,6 @@
+@@ -83,6 +85,6 @@ bin_PROGRAMS = pico2wave
  pico2wave_SOURCES = \
  	bin/pico2wave.c
  pico2wave_LDADD = \
diff --git a/sound/svox/patches/0011-subdir.patch b/sound/svox/patches/0011-subdir.patch
index fa9e91ffc..6f3e34f32 100644
--- a/sound/svox/patches/0011-subdir.patch
+++ b/sound/svox/patches/0011-subdir.patch
@@ -1,7 +1,6 @@
-diff -urN a/pico/configure.in b/pico/configure.in
---- a/pico/configure.in	2015-01-21 18:59:39.604452795 +0100
-+++ b/pico/configure.in	2015-01-21 19:00:53.288777298 +0100
-@@ -4,7 +4,7 @@
+--- a/pico/configure.in
++++ b/pico/configure.in
+@@ -4,7 +4,7 @@ AC_PREREQ(2.59)
  
  AC_INIT([svox], [1.0], [math.parent@gmail.com])
  
diff --git a/sound/svox/patches/0012-no-headers.patch b/sound/svox/patches/0012-no-headers.patch
index edf4d046e..6e932556c 100644
--- a/sound/svox/patches/0012-no-headers.patch
+++ b/sound/svox/patches/0012-no-headers.patch
@@ -1,7 +1,6 @@
-diff -urN a/pico/Makefile.am b/pico/Makefile.am
---- a/pico/Makefile.am	2015-01-22 01:33:21.470895431 +0100
-+++ b/pico/Makefile.am	2015-01-22 01:36:03.042228475 +0100
-@@ -34,42 +34,6 @@
+--- a/pico/Makefile.am
++++ b/pico/Makefile.am
+@@ -34,42 +34,6 @@ libttspico_la_SOURCES = \
  	lib/picotrns.c \
  	lib/picowa.c
  
-- 
cgit v1.2.3