From 9f8e5aca342c806d1031e063b00a0045e0eb6c57 Mon Sep 17 00:00:00 2001
From: Felix Fietkau <nbd@openwrt.org>
Date: Wed, 20 Jan 2016 20:30:04 +0100
Subject: treewide: use $(STAGING_DIR)/host instead of $(STAGING_DIR_HOST),
 sync with changes in trunk

Signed-off-by: Felix Fietkau <nbd@openwrt.org>
---
 libs/boost/Makefile                                          | 4 ++--
 libs/libgee/Makefile                                         | 4 ++--
 libs/libmraa/Makefile                                        | 4 ++--
 libs/libsearpc/Makefile                                      | 4 ++--
 libs/libupm/Makefile                                         | 4 ++--
 libs/libzdb/Makefile                                         | 4 ++--
 libs/libzdb/patches/020-filterh-use-host-built-version.patch | 2 +-
 libs/protobuf/Makefile                                       | 2 +-
 8 files changed, 14 insertions(+), 14 deletions(-)

(limited to 'libs')

diff --git a/libs/boost/Makefile b/libs/boost/Makefile
index ecd65fa3b..3c488ce71 100644
--- a/libs/boost/Makefile
+++ b/libs/boost/Makefile
@@ -397,11 +397,11 @@ endef
 
 define Host/Install
 	$(INSTALL_DIR) \
-		$(STAGING_DIR_HOST)/bin
+		$(STAGING_DIR)/host/bin
 
 	$(CP) \
 		$(HOST_BUILD_DIR)/tools/build/src/engine/bin.*/b2 \
-		$(STAGING_DIR_HOST)/bin/
+		$(STAGING_DIR)/host/bin/
 endef
 
 define Package/boost/Default/install
diff --git a/libs/libgee/Makefile b/libs/libgee/Makefile
index d03a79d4f..9be56482d 100644
--- a/libs/libgee/Makefile
+++ b/libs/libgee/Makefile
@@ -57,10 +57,10 @@ define Build/InstallDev
 	$(INSTALL_DATA) \
 		$(PKG_INSTALL_DIR)/usr/lib/pkgconfig/*.pc \
 		$(1)/usr/lib/pkgconfig/
-	$(INSTALL_DIR) $(STAGING_DIR_HOST)/share/vala-0.30/vapi/
+	$(INSTALL_DIR) $(STAGING_DIR)/host/share/vala-0.30/vapi/
 	$(INSTALL_DATA) \
                 $(PKG_INSTALL_DIR)/usr/share/vala/vapi/* \
-                $(STAGING_DIR_HOST)/share/vala-0.30/vapi
+                $(STAGING_DIR)/host/share/vala-0.30/vapi
 endef
 
 define Package/libgee/install
diff --git a/libs/libmraa/Makefile b/libs/libmraa/Makefile
index 3e3202ad2..1bff5ff99 100644
--- a/libs/libmraa/Makefile
+++ b/libs/libmraa/Makefile
@@ -28,8 +28,8 @@ include $(INCLUDE_DIR)/cmake.mk
 
 CMAKE_OPTIONS=-DBUILDARCH=$(CONFIG_ARCH) \
 	-DENABLEEXAMPLES=0 \
-	-DNODE_EXECUTABLE=$(STAGING_DIR_HOST)/bin/node \
-	-DSWIG_DIR=$(STAGING_DIR_HOST)/bin
+	-DNODE_EXECUTABLE=$(STAGING_DIR)/host/bin/node \
+	-DSWIG_DIR=$(STAGING_DIR)/host/bin
 
 TARGET_CFLAGS+=-I$(STAGING_DIR)/usr/include/node
 
diff --git a/libs/libsearpc/Makefile b/libs/libsearpc/Makefile
index 4ec9e93a0..15c0e8ba3 100644
--- a/libs/libsearpc/Makefile
+++ b/libs/libsearpc/Makefile
@@ -52,8 +52,8 @@ define Host/Compile
 endef
 
 define Host/Install
-	$(INSTALL_DIR) $(STAGING_DIR_HOST)/bin
-	$(INSTALL_BIN) $(HOST_BUILD_DIR)/lib/searpc-codegen.py $(STAGING_DIR_HOST)/bin/
+	$(INSTALL_DIR) $(STAGING_DIR)/host/bin
+	$(INSTALL_BIN) $(HOST_BUILD_DIR)/lib/searpc-codegen.py $(STAGING_DIR)/host/bin/
 endef
 
 $(eval $(call HostBuild))
diff --git a/libs/libupm/Makefile b/libs/libupm/Makefile
index 93287c52d..c1eaad16e 100644
--- a/libs/libupm/Makefile
+++ b/libs/libupm/Makefile
@@ -36,8 +36,8 @@ UPM_MODULES:= \
 	th02 tm1637 tsl2561 ttp223 ublox6 uln200xa waterlevel wheelencoder wt5001 yg1006 zfm20
 
 CMAKE_OPTIONS=-DBUILDARCH=$(CONFIG_ARCH) \
-	-DNODE_EXECUTABLE=$(STAGING_DIR_HOST)/bin/node \
-	-DSWIG_DIR=$(STAGING_DIR_HOST)/bin
+	-DNODE_EXECUTABLE=$(STAGING_DIR)/host/bin/node \
+	-DSWIG_DIR=$(STAGING_DIR)/host/bin
 
 define Package/libupm/Default
   SECTION:=libs
diff --git a/libs/libzdb/Makefile b/libs/libzdb/Makefile
index f3fc66eed..cf17a2cff 100644
--- a/libs/libzdb/Makefile
+++ b/libs/libzdb/Makefile
@@ -67,8 +67,8 @@ define Host/Compile
 endef
 
 define Host/Install
-	$(INSTALL_DIR) $(STAGING_DIR_HOST)/bin
-	$(CP) $(HOST_BUILD_DIR)/tools/bin/filterh $(STAGING_DIR_HOST)/bin/
+	$(INSTALL_DIR) $(STAGING_DIR)/host/bin
+	$(CP) $(HOST_BUILD_DIR)/tools/bin/filterh $(STAGING_DIR)/host/bin/
 endef
 
 $(eval $(call HostBuild))
diff --git a/libs/libzdb/patches/020-filterh-use-host-built-version.patch b/libs/libzdb/patches/020-filterh-use-host-built-version.patch
index 74c166a6c..1edfd77b3 100644
--- a/libs/libzdb/patches/020-filterh-use-host-built-version.patch
+++ b/libs/libzdb/patches/020-filterh-use-host-built-version.patch
@@ -14,7 +14,7 @@ diff -rupN libzdb-3.0.orig/Makefile.am libzdb-3.0/Makefile.am
  RE2C		= @RE2C@
  RE2CFLAGS       = -b
 -FILTERH         = ./tools/bin/filterh
-+FILTERH         = $(STAGING_DIR_HOST)/bin/filterh
++FILTERH         = $(STAGING_DIR)/host/bin/filterh
  
  AM_CPPFLAGS     = $(CPPFLAGS) $(DBCPPFLAGS)
  AM_CPPFLAGS     += -Isrc -Isrc/util -Isrc/net -Isrc/db -Isrc/exceptions
diff --git a/libs/protobuf/Makefile b/libs/protobuf/Makefile
index 72133be86..1e70a12fc 100644
--- a/libs/protobuf/Makefile
+++ b/libs/protobuf/Makefile
@@ -41,7 +41,7 @@ define Package/protobuf/description
  of its internal RPC protocols and file formats.
 endef
 
-CONFIGURE_ARGS += --with-protoc=$(STAGING_DIR_HOST)/bin/protoc
+CONFIGURE_ARGS += --with-protoc=$(STAGING_DIR)/host/bin/protoc
 
 define Build/InstallDev
 	$(INSTALL_DIR) \
-- 
cgit v1.2.3