From ca800e60b040a2b409801560dc16dbcac6cba2b1 Mon Sep 17 00:00:00 2001
From: Alexandru Ardelean <ardeleanalex@gmail.com>
Date: Fri, 6 Jan 2017 15:29:19 +0200
Subject: python: don't use libressl for host build

Fixes: https://github.com/openwrt/packages/issues/3767

Since commit:
https://github.com/lede-project/source/commit/f6e6341d896adb78f9b496f71aab8f45e1742d5a

libressl is built on the host-side.

Python picks it up [ via the openssl/* headers ] and assumes
it has SSL libs.
Compiling works fine, linking fails.
Doesn't look like it's because:
https://github.com/lede-project/source/commit/2fd5ce9488d11c7e6eee7dc30f128bd12be889f5

Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
---
 lang/python/Makefile                                          |  2 +-
 .../012-disable-openssl-for-hashlib-on-host-build.patch       | 11 +++++++++++
 2 files changed, 12 insertions(+), 1 deletion(-)
 create mode 100644 lang/python/patches/012-disable-openssl-for-hashlib-on-host-build.patch

(limited to 'lang')

diff --git a/lang/python/Makefile b/lang/python/Makefile
index b803b8c65..fbdd06cd5 100644
--- a/lang/python/Makefile
+++ b/lang/python/Makefile
@@ -12,7 +12,7 @@ include ./files/python-version.mk
 
 PKG_NAME:=python
 PKG_VERSION:=$(PYTHON_VERSION).$(PYTHON_VERSION_MICRO)
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=Python-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=https://www.python.org/ftp/python/$(PKG_VERSION)
diff --git a/lang/python/patches/012-disable-openssl-for-hashlib-on-host-build.patch b/lang/python/patches/012-disable-openssl-for-hashlib-on-host-build.patch
new file mode 100644
index 000000000..1a442e0f8
--- /dev/null
+++ b/lang/python/patches/012-disable-openssl-for-hashlib-on-host-build.patch
@@ -0,0 +1,11 @@
+--- a/setup.py
++++ b/setup.py
+@@ -859,7 +859,7 @@ class PyBuildExt(build_ext):
+ 
+         min_openssl_ver = 0x00907000
+         have_any_openssl = ssl_incs is not None and ssl_libs is not None
+-        have_usable_openssl = (have_any_openssl and
++        have_usable_openssl = cross_compiling and (have_any_openssl and
+                                openssl_ver >= min_openssl_ver)
+ 
+         if have_any_openssl:
-- 
cgit v1.2.3