From 449acc7dacf867db2a00ea886b7e4484ceeca6d9 Mon Sep 17 00:00:00 2001
From: Michael Heimpold <mhei@heimpold.de>
Date: Mon, 30 Aug 2021 13:34:46 +0200
Subject: php8: update to 8.0.10

Signed-off-by: Michael Heimpold <mhei@heimpold.de>
---
 lang/php8/Makefile                                         |  4 ++--
 ...d-support-for-use-of-the-system-timezone-database.patch | 14 ++++++++------
 lang/php8/patches/0022-Use-system-timezone.patch           |  2 +-
 ...-patch-to-remove-build-timestamps-from-generated-.patch |  4 ++--
 4 files changed, 13 insertions(+), 11 deletions(-)

(limited to 'lang')

diff --git a/lang/php8/Makefile b/lang/php8/Makefile
index ff3e112fd..c6f22acc8 100644
--- a/lang/php8/Makefile
+++ b/lang/php8/Makefile
@@ -6,7 +6,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=php
-PKG_VERSION:=8.0.9
+PKG_VERSION:=8.0.10
 PKG_RELEASE:=1
 
 PKG_MAINTAINER:=Michael Heimpold <mhei@heimpold.de>
@@ -16,7 +16,7 @@ PKG_CPE_ID:=cpe:/a:php:php
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=http://www.php.net/distributions/
-PKG_HASH:=71a01b2b56544e20e28696ad5b366e431a0984eaa39aa5e35426a4843e172010
+PKG_HASH:=66dc4d1bc86d9c1bc255b51b79d337ed1a7a035cf71230daabbf9a4ca35795eb
 
 PKG_BUILD_PARALLEL:=1
 PKG_USE_MIPS16:=0
diff --git a/lang/php8/patches/0007-Add-support-for-use-of-the-system-timezone-database.patch b/lang/php8/patches/0007-Add-support-for-use-of-the-system-timezone-database.patch
index b5071bcd4..8ca9a823f 100644
--- a/lang/php8/patches/0007-Add-support-for-use-of-the-system-timezone-database.patch
+++ b/lang/php8/patches/0007-Add-support-for-use-of-the-system-timezone-database.patch
@@ -99,7 +99,7 @@ r1: initial revision
  	/* read ID */
  	version = (*tzf)[3] - '0';
  	*tzf += 4;
-@@ -418,7 +436,429 @@ void timelib_dump_tzinfo(timelib_tzinfo
+@@ -435,7 +453,429 @@ void timelib_dump_tzinfo(timelib_tzinfo
  	}
  }
  
@@ -530,7 +530,7 @@ r1: initial revision
  {
  	int left = 0, right = tzdb->index_size - 1;
  
-@@ -444,9 +884,48 @@ static int seek_to_tz_position(const uns
+@@ -461,9 +901,48 @@ static int seek_to_tz_position(const uns
  	return 0;
  }
  
@@ -579,7 +579,7 @@ r1: initial revision
  }
  
  const timelib_tzdb_index_entry *timelib_timezone_identifiers_list(const timelib_tzdb *tzdb, int *count)
-@@ -458,7 +937,30 @@ const timelib_tzdb_index_entry *timelib_
+@@ -475,7 +954,30 @@ const timelib_tzdb_index_entry *timelib_
  int timelib_timezone_id_is_valid(const char *timezone, const timelib_tzdb *tzdb)
  {
  	const unsigned char *tzf;
@@ -611,7 +611,7 @@ r1: initial revision
  }
  
  static int skip_64bit_preamble(const unsigned char **tzf, timelib_tzinfo *tz)
-@@ -500,12 +1002,14 @@ static timelib_tzinfo* timelib_tzinfo_ct
+@@ -517,6 +1019,8 @@ static timelib_tzinfo* timelib_tzinfo_ct
  timelib_tzinfo *timelib_parse_tzfile(const char *timezone, const timelib_tzdb *tzdb, int *error_code)
  {
  	const unsigned char *tzf;
@@ -620,14 +620,16 @@ r1: initial revision
  	timelib_tzinfo *tmp;
  	int version;
  	int transitions_result, types_result;
- 	unsigned int type; /* TIMELIB_TZINFO_PHP or TIMELIB_TZINFO_ZONEINFO */
+@@ -524,7 +1028,7 @@ timelib_tzinfo *timelib_parse_tzfile(con
+ 
+ 	*error_code = TIMELIB_ERROR_NO_ERROR;
  
 -	if (seek_to_tz_position(&tzf, timezone, tzdb)) {
 +	if (seek_to_tz_position(&tzf, timezone, &memmap, &maplen, tzdb)) {
  		tmp = timelib_tzinfo_ctor(timezone);
  
  		version = read_preamble(&tzf, tmp, &type);
-@@ -540,11 +1044,36 @@ timelib_tzinfo *timelib_parse_tzfile(con
+@@ -563,11 +1067,36 @@ timelib_tzinfo *timelib_parse_tzfile(con
  		}
  		skip_posix_string(&tzf, tmp);
  
diff --git a/lang/php8/patches/0022-Use-system-timezone.patch b/lang/php8/patches/0022-Use-system-timezone.patch
index b7ad1882c..2225fc39b 100644
--- a/lang/php8/patches/0022-Use-system-timezone.patch
+++ b/lang/php8/patches/0022-Use-system-timezone.patch
@@ -15,7 +15,7 @@ To be used in tandem with use_embedded_timezonedb.patch and use_embedded_timezon
 
 --- a/ext/date/php_date.c
 +++ b/ext/date/php_date.c
-@@ -538,6 +538,23 @@ static char* guess_timezone(const timeli
+@@ -545,6 +545,23 @@ static char* guess_timezone(const timeli
  		DATEG(timezone_valid) = 1;
  		return DATEG(default_timezone);
  	}
diff --git a/lang/php8/patches/0041-Add-patch-to-remove-build-timestamps-from-generated-.patch b/lang/php8/patches/0041-Add-patch-to-remove-build-timestamps-from-generated-.patch
index 36cde693a..6b2ed167a 100644
--- a/lang/php8/patches/0041-Add-patch-to-remove-build-timestamps-from-generated-.patch
+++ b/lang/php8/patches/0041-Add-patch-to-remove-build-timestamps-from-generated-.patch
@@ -40,7 +40,7 @@ Subject: Add patch to remove build timestamps from generated binaries.
    PHP_SUBST(LIBPHP_CFLAGS)
 --- a/sapi/cgi/cgi_main.c
 +++ b/sapi/cgi/cgi_main.c
-@@ -2371,9 +2371,9 @@ parent_loop_end:
+@@ -2372,9 +2372,9 @@ parent_loop_end:
  							SG(headers_sent) = 1;
  							SG(request_info).no_headers = 1;
  #if ZEND_DEBUG
@@ -67,7 +67,7 @@ Subject: Add patch to remove build timestamps from generated binaries.
  #else
 --- a/sapi/fpm/fpm/fpm_main.c
 +++ b/sapi/fpm/fpm/fpm_main.c
-@@ -1691,9 +1691,9 @@ int main(int argc, char *argv[])
+@@ -1692,9 +1692,9 @@ int main(int argc, char *argv[])
  				SG(request_info).no_headers = 1;
  
  #if ZEND_DEBUG
-- 
cgit v1.2.3