From 8f9564387d136c2a09c763b4c4ac7e4aa16baeb5 Mon Sep 17 00:00:00 2001
From: Jo-Philipp Wich <jo@mein.io>
Date: Fri, 5 Apr 2024 01:33:50 +0200
Subject: nano: fix syntax highlighting for raw ucode scripts

Text between interpreter line and start of first directive should only
highlighted as uninterpreted when running in template mode, so adjust
the match rule accordingly.

Fixes: #23761
Signed-off-by: Jo-Philipp Wich <jo@mein.io>
---
 utils/nano/Makefile           | 2 +-
 utils/nano/files/ucode.nanorc | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)

diff --git a/utils/nano/Makefile b/utils/nano/Makefile
index 4400b780f..064a25e3d 100644
--- a/utils/nano/Makefile
+++ b/utils/nano/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=nano
 PKG_VERSION:=7.2
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@GNU/nano
diff --git a/utils/nano/files/ucode.nanorc b/utils/nano/files/ucode.nanorc
index 96c7848e2..647f21d85 100644
--- a/utils/nano/files/ucode.nanorc
+++ b/utils/nano/files/ucode.nanorc
@@ -43,7 +43,7 @@ color ,green "[[:space:]]+$"
 
 # Text outside template directives
 color slate start="[}%#]\}" end="\{[{%#]"
-color slate start="^#!" end="\{[{%#]"
+color slate start="^#!.*(\<utpl\>|[[:space:]]-[[:alnum:]]*T[[:alnum:]]*\>)" end="\{[{%#]"
 color slate "^([^{%#}]|\{[^{%#]|[%#}][^}])+\{[{%#]"
 
 # Template tags
-- 
cgit v1.2.3