aboutsummaryrefslogtreecommitdiff
path: root/libs/postgresql/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'libs/postgresql/Makefile')
-rw-r--r--libs/postgresql/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/libs/postgresql/Makefile b/libs/postgresql/Makefile
index 77e0f1bce..c33bbd442 100644
--- a/libs/postgresql/Makefile
+++ b/libs/postgresql/Makefile
@@ -6,7 +6,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=postgresql
PKG_VERSION:=12.1
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
PKG_LICENSE:=PostgreSQL
PKG_CPE_ID:=cpe:/a:postgresql:postgresql
@@ -156,6 +156,8 @@ CONFIGURE_ARGS += \
--enable-depend \
$(if $(CONFIG_arc),--disable-spinlocks)
+HOST_CFLAGS += -std=gnu99
+
# Need a native zic and pg_config for build
define Host/Compile
+$(HOST_MAKE_VARS) MAKELEVEL=0 $(MAKE) -C $(HOST_BUILD_DIR)/src/bin/pg_config CC="$(HOSTCC)"