aboutsummaryrefslogtreecommitdiff
path: root/lang/python
diff options
context:
space:
mode:
Diffstat (limited to 'lang/python')
-rw-r--r--lang/python/host-pip-requirements/Cython.txt2
-rw-r--r--lang/python/numpy/Makefile4
-rw-r--r--lang/python/python-dns/Makefile6
-rw-r--r--lang/python/python-lxml/Makefile4
-rw-r--r--lang/python/python-paramiko/Makefile4
-rw-r--r--lang/python/python-zeroconf/Makefile4
-rw-r--r--lang/python/python3-libselinux/Makefile6
-rw-r--r--lang/python/python3-networkx/Makefile6
8 files changed, 18 insertions, 18 deletions
diff --git a/lang/python/host-pip-requirements/Cython.txt b/lang/python/host-pip-requirements/Cython.txt
index 0b3d03d01..be0f28a12 100644
--- a/lang/python/host-pip-requirements/Cython.txt
+++ b/lang/python/host-pip-requirements/Cython.txt
@@ -1 +1 @@
-Cython==0.29.24 --hash=sha256:cdf04d07c3600860e8c2ebaad4e8f52ac3feb212453c1764a49ac08c827e8443
+Cython==0.29.26 --hash=sha256:af377d543a762867da11fcf6e558f7a4a535ff8693f30cce123fab10c00fa312
diff --git a/lang/python/numpy/Makefile b/lang/python/numpy/Makefile
index bf71978bd..b0860617c 100644
--- a/lang/python/numpy/Makefile
+++ b/lang/python/numpy/Makefile
@@ -6,11 +6,11 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=numpy
-PKG_VERSION:=1.21.4
+PKG_VERSION:=1.21.5
PKG_RELEASE:=$(AUTORELEASE)
PYPI_NAME:=$(PKG_NAME)
-PKG_HASH:=e6c76a87633aa3fa16614b61ccedfae45b91df2767cf097aa9c933932a7ed1e0
+PKG_HASH:=6a5928bc6241264dce5ed509e66f33676fc97f464e7a919edc672fb5532221ee
PKG_MAINTAINER:=Alexandru Ardelean <ardeleanalex@gmail.com>
diff --git a/lang/python/python-dns/Makefile b/lang/python/python-dns/Makefile
index 2c71f078b..9d399ed8a 100644
--- a/lang/python/python-dns/Makefile
+++ b/lang/python/python-dns/Makefile
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=python-dns
-PKG_VERSION:=1.16.0
-PKG_RELEASE:=2
+PKG_VERSION:=2.1.0
+PKG_RELEASE:=1
PYPI_NAME:=dnspython
PYPI_SOURCE_EXT:=zip
-PKG_HASH:=36c5e8e38d4369a08b6780b7f27d790a292b2b08eea01607865bf0936c558e01
+PKG_HASH:=e4a87f0b573201a0f3727fa18a516b055fd1107e0e5477cded4a2de497df1dd4
PKG_LICENSE:=ISC
PKG_LICENSE_FILES:=LICENSE
diff --git a/lang/python/python-lxml/Makefile b/lang/python/python-lxml/Makefile
index c77c94d34..e76ca6b9d 100644
--- a/lang/python/python-lxml/Makefile
+++ b/lang/python/python-lxml/Makefile
@@ -8,11 +8,11 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=python-lxml
-PKG_VERSION:=4.6.4
+PKG_VERSION:=4.7.1
PKG_RELEASE:=$(AUTORELEASE)
PYPI_NAME:=lxml
-PKG_HASH:=daf9bd1fee31f1c7a5928b3e1059e09a8d683ea58fb3ffc773b6c88cb8d1399c
+PKG_HASH:=a1613838aa6b89af4ba10a0f3a972836128801ed008078f8c1244e65958f1b24
PKG_LICENSE:=BSD-3-Clause
PKG_LICENSE_FILES:=LICENSES.txt
diff --git a/lang/python/python-paramiko/Makefile b/lang/python/python-paramiko/Makefile
index 397bd601e..96499c58b 100644
--- a/lang/python/python-paramiko/Makefile
+++ b/lang/python/python-paramiko/Makefile
@@ -1,11 +1,11 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=python-paramiko
-PKG_VERSION:=2.8.0
+PKG_VERSION:=2.9.1
PKG_RELEASE:=1
PYPI_NAME:=paramiko
-PKG_HASH:=e673b10ee0f1c80d46182d3af7751d033d9b573dd7054d2d0aa46be186c3c1d2
+PKG_HASH:=a1fdded3b55f61d23389e4fe52d9ae428960ac958d2edf50373faa5d8926edd0
PKG_MAINTAINER:=Javier Marcet <javier@marcet.info>
PKG_LICENSE:=LGPL-2.1-or-later
diff --git a/lang/python/python-zeroconf/Makefile b/lang/python/python-zeroconf/Makefile
index 121a3f973..9b3e220c0 100644
--- a/lang/python/python-zeroconf/Makefile
+++ b/lang/python/python-zeroconf/Makefile
@@ -8,11 +8,11 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=python-zeroconf
-PKG_VERSION:=0.29.0
+PKG_VERSION:=0.38.1
PKG_RELEASE:=1
PYPI_NAME:=zeroconf
-PKG_HASH:=7aefbb658b452b1fd7e51124364f938c6f5e42d6ea893fa2557bea8c06c540af
+PKG_HASH:=10c501b25d8881b656e56c34674d98fe6bc752240a572e74f918bc849c93ba9c
PKG_MAINTAINER:=Josef Schlehofer <pepe.schlehofer@gmail.com>
PKG_LICENSE:=Apache-2.0
diff --git a/lang/python/python3-libselinux/Makefile b/lang/python/python3-libselinux/Makefile
index 18caa46b4..d51c4035b 100644
--- a/lang/python/python3-libselinux/Makefile
+++ b/lang/python/python3-libselinux/Makefile
@@ -7,13 +7,13 @@ include $(TOPDIR)/rules.mk
SRC_NAME:=libselinux
PKG_NAME:=python3-$(SRC_NAME)
-PKG_VERSION:=3.2
-PKG_RELEASE:=1
+PKG_VERSION:=3.3
+PKG_RELEASE:=$(AUTORELEASE)
PKG_BUILD_DIR:=$(BUILD_DIR)/python-libselinux/$(SRC_NAME)-$(PKG_VERSION)
PKG_SOURCE:=$(SRC_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://github.com/SELinuxProject/selinux/releases/download/20200710
-PKG_HASH:=df758ef1d9d4811051dd901ea6b029ae334ffd7c671c128beb16bce1e25ac161
+PKG_HASH:=acfdee27633d2496508c28727c3d41d3748076f66d42fccde2e6b9f3463a7057
PKG_BUILD_DEPENDS:=swig/host
PKG_MAINTAINER:=Thomas Petazzoni <thomas.petazzoni@bootlin.com>
diff --git a/lang/python/python3-networkx/Makefile b/lang/python/python3-networkx/Makefile
index 7e0b005dc..44ac41af1 100644
--- a/lang/python/python3-networkx/Makefile
+++ b/lang/python/python3-networkx/Makefile
@@ -6,11 +6,11 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=python3-networkx
-PKG_VERSION:=2.5
-PKG_RELEASE:=1
+PKG_VERSION:=2.6.3
+PKG_RELEASE:=$(AUTORELEASE)
PYPI_NAME:=networkx
-PKG_HASH:=7978955423fbc9639c10498878be59caf99b44dc304c2286162fd24b458c1602
+PKG_HASH:=c0946ed31d71f1b732b5aaa6da5a0388a345019af232ce2f49c766e2d6795c51
PKG_LICENSE:=BSD-3-clause
PKG_LICENSE_FILES:=LICENSE.txt