aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python-pycparser
diff options
context:
space:
mode:
Diffstat (limited to 'lang/python/python-pycparser')
-rw-r--r--lang/python/python-pycparser/Makefile6
-rw-r--r--lang/python/python-pycparser/patches/001-use-external-ply.patch14
2 files changed, 10 insertions, 10 deletions
diff --git a/lang/python/python-pycparser/Makefile b/lang/python/python-pycparser/Makefile
index 29d81c9cb..c0da35157 100644
--- a/lang/python/python-pycparser/Makefile
+++ b/lang/python/python-pycparser/Makefile
@@ -8,11 +8,11 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=python-pycparser
-PKG_VERSION:=2.20
-PKG_RELEASE:=5
+PKG_VERSION:=2.21
+PKG_RELEASE:=1
PYPI_NAME:=pycparser
-PKG_HASH:=2d475327684562c3a96cc71adf7dc8c4f0565175cf86b6d7a404ff4c771f15f0
+PKG_HASH:=e644fdec12f7872f86c58ff790da456218b10f863970249516d60a5eaca77206
PKG_LICENSE:=BSD-3-Clause
PKG_LICENSE_FILES:=LICENSE
diff --git a/lang/python/python-pycparser/patches/001-use-external-ply.patch b/lang/python/python-pycparser/patches/001-use-external-ply.patch
index 23c43d280..b6f2eac95 100644
--- a/lang/python/python-pycparser/patches/001-use-external-ply.patch
+++ b/lang/python/python-pycparser/patches/001-use-external-ply.patch
@@ -1,8 +1,8 @@
--- a/pycparser/c_lexer.py
+++ b/pycparser/c_lexer.py
-@@ -9,8 +9,8 @@
+@@ -8,8 +8,8 @@
+ #------------------------------------------------------------------------------
import re
- import sys
-from .ply import lex
-from .ply.lex import TOKEN
@@ -13,10 +13,10 @@
class CLexer(object):
--- a/pycparser/c_parser.py
+++ b/pycparser/c_parser.py
-@@ -8,7 +8,7 @@
+@@ -6,7 +6,7 @@
+ # Eli Bendersky [https://eli.thegreenplace.net/]
+ # License: BSD
#------------------------------------------------------------------------------
- import re
-
-from .ply import yacc
+from ply import yacc
@@ -24,8 +24,8 @@
from .c_lexer import CLexer
--- a/setup.py
+++ b/setup.py
-@@ -60,7 +60,7 @@ setup(
- 'Programming Language :: Python :: 3.6',
+@@ -64,7 +64,7 @@ setup(
+ 'Programming Language :: Python :: 3.10',
],
python_requires=">=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*",
- packages=['pycparser', 'pycparser.ply'],