aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python-pycparser/patches/001-use-external-ply.patch
diff options
context:
space:
mode:
Diffstat (limited to 'lang/python/python-pycparser/patches/001-use-external-ply.patch')
-rw-r--r--lang/python/python-pycparser/patches/001-use-external-ply.patch14
1 files changed, 7 insertions, 7 deletions
diff --git a/lang/python/python-pycparser/patches/001-use-external-ply.patch b/lang/python/python-pycparser/patches/001-use-external-ply.patch
index 23c43d280..b6f2eac95 100644
--- a/lang/python/python-pycparser/patches/001-use-external-ply.patch
+++ b/lang/python/python-pycparser/patches/001-use-external-ply.patch
@@ -1,8 +1,8 @@
--- a/pycparser/c_lexer.py
+++ b/pycparser/c_lexer.py
-@@ -9,8 +9,8 @@
+@@ -8,8 +8,8 @@
+ #------------------------------------------------------------------------------
import re
- import sys
-from .ply import lex
-from .ply.lex import TOKEN
@@ -13,10 +13,10 @@
class CLexer(object):
--- a/pycparser/c_parser.py
+++ b/pycparser/c_parser.py
-@@ -8,7 +8,7 @@
+@@ -6,7 +6,7 @@
+ # Eli Bendersky [https://eli.thegreenplace.net/]
+ # License: BSD
#------------------------------------------------------------------------------
- import re
-
-from .ply import yacc
+from ply import yacc
@@ -24,8 +24,8 @@
from .c_lexer import CLexer
--- a/setup.py
+++ b/setup.py
-@@ -60,7 +60,7 @@ setup(
- 'Programming Language :: Python :: 3.6',
+@@ -64,7 +64,7 @@ setup(
+ 'Programming Language :: Python :: 3.10',
],
python_requires=">=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*",
- packages=['pycparser', 'pycparser.ply'],