aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python-cryptodome/patches/002-omit-tests.patch
diff options
context:
space:
mode:
Diffstat (limited to 'lang/python/python-cryptodome/patches/002-omit-tests.patch')
-rw-r--r--lang/python/python-cryptodome/patches/002-omit-tests.patch54
1 files changed, 8 insertions, 46 deletions
diff --git a/lang/python/python-cryptodome/patches/002-omit-tests.patch b/lang/python/python-cryptodome/patches/002-omit-tests.patch
index 6f16b2175..cbaf70f25 100644
--- a/lang/python/python-cryptodome/patches/002-omit-tests.patch
+++ b/lang/python/python-cryptodome/patches/002-omit-tests.patch
@@ -1,50 +1,12 @@
--- a/setup.py
+++ b/setup.py
-@@ -245,16 +245,6 @@
- "Crypto.Signature",
- "Crypto.Util",
- "Crypto.Math",
-- "Crypto.SelfTest",
-- "Crypto.SelfTest.Cipher",
-- "Crypto.SelfTest.Hash",
-- "Crypto.SelfTest.IO",
-- "Crypto.SelfTest.Protocol",
-- "Crypto.SelfTest.PublicKey",
-- "Crypto.SelfTest.Random",
-- "Crypto.SelfTest.Signature",
-- "Crypto.SelfTest.Util",
-- "Crypto.SelfTest.Math",
- ]
- package_dir = {"Crypto": "lib/Crypto"}
- package_data = {
-@@ -268,30 +258,6 @@
- "Crypto.Signature" : [ "*.pyi" ],
- "Crypto.IO" : [ "*.pyi" ],
- "Crypto.Util" : [ "*.pyi" ],
-- "Crypto.SelfTest.Cipher" : [
-- "test_vectors/AES/*.rsp",
-- "test_vectors/TDES/*.rsp",
-- "test_vectors/wycheproof/*.json",
-- ],
-- "Crypto.SelfTest.Hash" : [
-- "test_vectors/SHA1/*.rsp",
-- "test_vectors/SHA2/*.rsp",
-- "test_vectors/SHA3/*.txt",
-- "test_vectors/keccak/*.txt",
-- "test_vectors/BLAKE2s/*.txt",
-- "test_vectors/BLAKE2b/*.txt",
-- "test_vectors/wycheproof/*.json",
-- ],
-- "Crypto.SelfTest.Signature" : [
-- "test_vectors/DSA/*.*",
-- "test_vectors/ECDSA/*.*",
-- "test_vectors/PKCS1-v1.5/*.*",
-- "test_vectors/PKCS1-PSS/*.*",
-- "test_vectors/wycheproof/*.json",
-- ],
-- "Crypto.SelfTest.PublicKey" : [
-- "test_vectors/ECC/*.*",
-- ],
+@@ -293,6 +293,9 @@ package_data = {
+ ],
}
- system_bits = 8 * struct.calcsize("P")
++packages = [i for i in packages if not i.startswith('Crypto.SelfTest')]
++package_data = {k: v for k, v in package_data.items() if not k.startswith('Crypto.SelfTest')}
++
+ ext_modules = [
+ # Hash functions
+ Extension("Crypto.Hash._MD2",