aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--admin/sudo/Makefile6
-rw-r--r--admin/sudo/patches/010-cross-compile-fixes.patch2
-rw-r--r--admin/sudo/patches/020-no-owner-change.patch2
-rw-r--r--net/dnscrypt-proxy2/Makefile4
-rw-r--r--net/git/Makefile4
-rw-r--r--net/git/patches/100-configure_for_crosscompiling.patch6
-rw-r--r--net/git/patches/200-imapsend_without_curl.patch2
-rw-r--r--net/git/patches/300-openssl-deprecated.patch7
8 files changed, 14 insertions, 19 deletions
diff --git a/admin/sudo/Makefile b/admin/sudo/Makefile
index aaf4934f6..b6ea46a52 100644
--- a/admin/sudo/Makefile
+++ b/admin/sudo/Makefile
@@ -8,14 +8,14 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=sudo
-PKG_VERSION:=1.8.27
+PKG_VERSION:=1.8.28p1
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://www.sudo.ws/dist
-PKG_HASH:=7beb68b94471ef56d8a1036dbcdc09a7b58a949a68ffce48b83f837dd33e2ec0
+PKG_HASH:=23ba5a84af31e3b5ded58d4be6d3f6939a495a55561fba92c6941b79a6e8b027
-PKG_MAINTAINER:=Gergely Kiss <mail.gery@gmail.com>
+PKG_MAINTAINER:=
PKG_LICENSE:=ISC
PKG_LICENSE_FILES:=doc/LICENSE
PKG_CPE_ID:=cpe:/a:todd_miller:sudo
diff --git a/admin/sudo/patches/010-cross-compile-fixes.patch b/admin/sudo/patches/010-cross-compile-fixes.patch
index f29efb77d..ba71c9de2 100644
--- a/admin/sudo/patches/010-cross-compile-fixes.patch
+++ b/admin/sudo/patches/010-cross-compile-fixes.patch
@@ -1,6 +1,6 @@
--- a/lib/util/Makefile.in
+++ b/lib/util/Makefile.in
-@@ -182,10 +182,10 @@ libsudo_util.la: $(LTOBJS) @LT_LDDEP@
+@@ -188,10 +188,10 @@ libsudo_util.la: $(LTOBJS) @LT_LDDEP@
esac
siglist.c: mksiglist
diff --git a/admin/sudo/patches/020-no-owner-change.patch b/admin/sudo/patches/020-no-owner-change.patch
index 7e7205cdc..ec145488c 100644
--- a/admin/sudo/patches/020-no-owner-change.patch
+++ b/admin/sudo/patches/020-no-owner-change.patch
@@ -1,6 +1,6 @@
--- a/Makefile.in
+++ b/Makefile.in
-@@ -62,7 +62,7 @@ SHELL = @SHELL@
+@@ -64,7 +64,7 @@ SHELL = @SHELL@
SED = @SED@
INSTALL = $(SHELL) $(top_srcdir)/install-sh -c
diff --git a/net/dnscrypt-proxy2/Makefile b/net/dnscrypt-proxy2/Makefile
index 6854384e3..061f903c6 100644
--- a/net/dnscrypt-proxy2/Makefile
+++ b/net/dnscrypt-proxy2/Makefile
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=dnscrypt-proxy2
-PKG_VERSION:=2.0.27
+PKG_VERSION:=2.0.28
PKG_RELEASE:=1
PKG_SOURCE:=dnscrypt-proxy-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/jedisct1/dnscrypt-proxy/tar.gz/$(PKG_VERSION)?
-PKG_HASH:=a501f44af39cb43e00489ef9e6678aa8adba2bc98f9042dd61ce60e9ad074d5a
+PKG_HASH:=2ba28343ded15233c69c2353cce159ab2ad4e7eb6ba018caf495e1e5d333d86d
PKG_BUILD_DIR:=$(BUILD_DIR)/dnscrypt-proxy-$(PKG_VERSION)
PKG_MAINTAINER:=Josef Schlehofer <josef.schlehofer@nic.cz>
diff --git a/net/git/Makefile b/net/git/Makefile
index 42a1adc3d..725a965ae 100644
--- a/net/git/Makefile
+++ b/net/git/Makefile
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=git
-PKG_VERSION:=2.22.0
+PKG_VERSION:=2.23.0
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@KERNEL/software/scm/git/
-PKG_HASH:=159e4b599f8af4612e70b666600a3139541f8bacc18124daf2cbe8d1b934f29f
+PKG_HASH:=234fa05b6839e92dc300b2dd78c92ec9c0c8d439f65e1d430a7034f60af16067
PKG_INSTALL:=1
PKG_FIXUP:=autoreconf
diff --git a/net/git/patches/100-configure_for_crosscompiling.patch b/net/git/patches/100-configure_for_crosscompiling.patch
index 07796e6df..bb7a61d13 100644
--- a/net/git/patches/100-configure_for_crosscompiling.patch
+++ b/net/git/patches/100-configure_for_crosscompiling.patch
@@ -1,6 +1,6 @@
--- a/configure.ac
+++ b/configure.ac
-@@ -929,7 +929,8 @@ AC_RUN_IFELSE(
+@@ -952,7 +952,8 @@ AC_RUN_IFELSE(
FILE *f = fopen(".", "r");
return f != NULL;]])],
[ac_cv_fread_reads_directories=no],
@@ -10,7 +10,7 @@
])
if test $ac_cv_fread_reads_directories = yes; then
FREAD_READS_DIRECTORIES=UnfortunatelyYes
-@@ -963,7 +964,8 @@ AC_RUN_IFELSE(
+@@ -986,7 +987,8 @@ AC_RUN_IFELSE(
if (snprintf(buf, 3, "%s", "12345") != 5
|| strcmp(buf, "12")) return 1]])],
[ac_cv_snprintf_returns_bogus=no],
@@ -20,7 +20,7 @@
])
if test $ac_cv_snprintf_returns_bogus = yes; then
SNPRINTF_RETURNS_BOGUS=UnfortunatelyYes
-@@ -986,7 +988,8 @@ yippeeyeswehaveit
+@@ -1009,7 +1011,8 @@ yippeeyeswehaveit
#endif
]),
[ac_cv_sane_mode_bits=yes],
diff --git a/net/git/patches/200-imapsend_without_curl.patch b/net/git/patches/200-imapsend_without_curl.patch
index 75268a48f..c13336ef0 100644
--- a/net/git/patches/200-imapsend_without_curl.patch
+++ b/net/git/patches/200-imapsend_without_curl.patch
@@ -1,6 +1,6 @@
--- a/Makefile
+++ b/Makefile
-@@ -1312,7 +1312,7 @@ else
+@@ -1365,7 +1365,7 @@ endif
endif
curl_check := $(shell (echo 072200; $(CURL_CONFIG) --vernum | sed -e '/^70[BC]/s/^/0/') 2>/dev/null | sort -r | sed -ne 2p)
ifeq "$(curl_check)" "072200"
diff --git a/net/git/patches/300-openssl-deprecated.patch b/net/git/patches/300-openssl-deprecated.patch
index e3a9ad831..20a5a2a0b 100644
--- a/net/git/patches/300-openssl-deprecated.patch
+++ b/net/git/patches/300-openssl-deprecated.patch
@@ -12,11 +12,9 @@ Signed-off-by: Rosen Penev <rosenp@gmail.com>
imap-send.c | 2 ++
1 file changed, 2 insertions(+)
-diff --git a/imap-send.c b/imap-send.c
-index b4eb886e2..877a4e368 100644
--- a/imap-send.c
+++ b/imap-send.c
-@@ -284,8 +284,10 @@ static int ssl_socket_connect(struct imap_socket *sock, int use_tls_only, int ve
+@@ -284,8 +284,10 @@ static int ssl_socket_connect(struct ima
int ret;
X509 *cert;
@@ -27,6 +25,3 @@ index b4eb886e2..877a4e368 100644
meth = SSLv23_method();
if (!meth) {
---
-2.20.1
-