aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--libs/libgpg-error/Makefile10
-rw-r--r--libs/libgpg-error/patches/020-gawk5-support.patch158
-rw-r--r--net/lcdringer/Makefile2
-rw-r--r--net/miniupnpd/Makefile2
-rw-r--r--net/miniupnpd/files/miniupnpd.hotplug24
-rw-r--r--net/miniupnpd/files/miniupnpd.init177
-rw-r--r--net/miniupnpd/files/upnpd.config4
-rw-r--r--net/miniupnpd/patches/100-no-daemon.patch25
-rw-r--r--net/udpxy/Makefile16
-rw-r--r--utils/collectd/Makefile2
-rw-r--r--utils/rtty/Makefile4
11 files changed, 134 insertions, 290 deletions
diff --git a/libs/libgpg-error/Makefile b/libs/libgpg-error/Makefile
index 8a18cd18a..0e66164e0 100644
--- a/libs/libgpg-error/Makefile
+++ b/libs/libgpg-error/Makefile
@@ -8,22 +8,22 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=libgpg-error
-PKG_VERSION:=1.36
-PKG_RELEASE:=3
+PKG_VERSION:=1.37
+PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=https://mirrors.dotsrc.org/gcrypt/libgpg-error \
http://ring.ksc.gr.jp/archives/net/gnupg/libgpg-error \
https://www.gnupg.org/ftp/gcrypt/libgpg-error
-PKG_HASH:=babd98437208c163175c29453f8681094bcaf92968a15cafb1a276076b33c97c
+PKG_HASH:=b32d6ff72a73cf79797f7f2d039e95e9c6f92f0c1450215410840ab62aea9763
PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
PKG_LICENSE:=LGPL-2.1-or-later
PKG_LICENSE_FILES:=COPYING
-PKG_BUILD_PARALLEL:=1
-PKG_INSTALL:=1
PKG_FIXUP:=autoreconf
+PKG_INSTALL:=1
+PKG_BUILD_PARALLEL:=1
include $(INCLUDE_DIR)/package.mk
diff --git a/libs/libgpg-error/patches/020-gawk5-support.patch b/libs/libgpg-error/patches/020-gawk5-support.patch
deleted file mode 100644
index 17e881645..000000000
--- a/libs/libgpg-error/patches/020-gawk5-support.patch
+++ /dev/null
@@ -1,158 +0,0 @@
-From 7865041c77f4f7005282f10f9b6666b19072fbdf Mon Sep 17 00:00:00 2001
-From: NIIBE Yutaka <gniibe@fsij.org>
-Date: Mon, 15 Apr 2019 15:10:44 +0900
-Subject: [PATCH] awk: Prepare for Gawk 5.0.
-
-* src/Makefile.am: Use pkg_namespace (instead of namespace).
-* src/mkerrnos.awk: Likewise.
-* lang/cl/mkerrcodes.awk: Don't escape # in regexp.
-* src/mkerrcodes.awk, src/mkerrcodes1.awk, src/mkerrcodes2.awk: Ditto.
-
---
-
-In Gawk 5.0, regexp routines are replaced by Gnulib implementation,
-which only allows escaping specific characters.
-
-GnuPG-bug-id: 4459
-Reported-by: Marius Schamschula
-Signed-off-by: NIIBE Yutaka <gniibe@fsij.org>
----
- lang/cl/mkerrcodes.awk | 2 +-
- src/Makefile.am | 2 +-
- src/mkerrcodes.awk | 2 +-
- src/mkerrcodes1.awk | 2 +-
- src/mkerrcodes2.awk | 2 +-
- src/mkerrnos.awk | 2 +-
- src/mkstrtable.awk | 10 +++++-----
- 7 files changed, 11 insertions(+), 11 deletions(-)
-
-diff --git a/lang/cl/mkerrcodes.awk b/lang/cl/mkerrcodes.awk
-index ae29043..9a1fc18 100644
---- a/lang/cl/mkerrcodes.awk
-+++ b/lang/cl/mkerrcodes.awk
-@@ -122,7 +122,7 @@ header {
- }
-
- !header {
-- sub (/\#.+/, "");
-+ sub (/#.+/, "");
- sub (/[ ]+$/, ""); # Strip trailing space and tab characters.
-
- if (/^$/)
-diff --git a/src/Makefile.am b/src/Makefile.am
-index ce1b882..f2590cb 100644
---- a/src/Makefile.am
-+++ b/src/Makefile.am
-@@ -293,7 +293,7 @@ code-from-errno.h: mkerrcodes$(EXEEXT_FOR_BUILD) Makefile
-
- errnos-sym.h: Makefile mkstrtable.awk errnos.in
- $(AWK) -f $(srcdir)/mkstrtable.awk -v textidx=2 -v nogettext=1 \
-- -v prefix=GPG_ERR_ -v namespace=errnos_ \
-+ -v prefix=GPG_ERR_ -v pkg_namespace=errnos_ \
- $(srcdir)/errnos.in >$@
-
-
-diff --git a/src/mkerrcodes.awk b/src/mkerrcodes.awk
-index 46d436c..e9c857c 100644
---- a/src/mkerrcodes.awk
-+++ b/src/mkerrcodes.awk
-@@ -85,7 +85,7 @@ header {
- }
-
- !header {
-- sub (/\#.+/, "");
-+ sub (/#.+/, "");
- sub (/[ ]+$/, ""); # Strip trailing space and tab characters.
-
- if (/^$/)
-diff --git a/src/mkerrcodes1.awk b/src/mkerrcodes1.awk
-index a771a73..4578e29 100644
---- a/src/mkerrcodes1.awk
-+++ b/src/mkerrcodes1.awk
-@@ -81,7 +81,7 @@ header {
- }
-
- !header {
-- sub (/\#.+/, "");
-+ sub (/#.+/, "");
- sub (/[ ]+$/, ""); # Strip trailing space and tab characters.
-
- if (/^$/)
-diff --git a/src/mkerrcodes2.awk b/src/mkerrcodes2.awk
-index ea58503..188f7a4 100644
---- a/src/mkerrcodes2.awk
-+++ b/src/mkerrcodes2.awk
-@@ -91,7 +91,7 @@ header {
- }
-
- !header {
-- sub (/\#.+/, "");
-+ sub (/#.+/, "");
- sub (/[ ]+$/, ""); # Strip trailing space and tab characters.
-
- if (/^$/)
-diff --git a/src/mkerrnos.awk b/src/mkerrnos.awk
-index f79df66..15b1aad 100644
---- a/src/mkerrnos.awk
-+++ b/src/mkerrnos.awk
-@@ -83,7 +83,7 @@ header {
- }
-
- !header {
-- sub (/\#.+/, "");
-+ sub (/#.+/, "");
- sub (/[ ]+$/, ""); # Strip trailing space and tab characters.
-
- if (/^$/)
-diff --git a/src/mkstrtable.awk b/src/mkstrtable.awk
-index c9de9c1..285e45f 100644
---- a/src/mkstrtable.awk
-+++ b/src/mkstrtable.awk
-@@ -77,7 +77,7 @@
- #
- # The variable prefix can be used to prepend a string to each message.
- #
--# The variable namespace can be used to prepend a string to each
-+# The variable pkg_namespace can be used to prepend a string to each
- # variable and macro name.
-
- BEGIN {
-@@ -102,7 +102,7 @@ header {
- print "/* The purpose of this complex string table is to produce";
- print " optimal code with a minimum of relocations. */";
- print "";
-- print "static const char " namespace "msgstr[] = ";
-+ print "static const char " pkg_namespace "msgstr[] = ";
- header = 0;
- }
- else
-@@ -110,7 +110,7 @@ header {
- }
-
- !header {
-- sub (/\#.+/, "");
-+ sub (/#.+/, "");
- sub (/[ ]+$/, ""); # Strip trailing space and tab characters.
-
- if (/^$/)
-@@ -150,7 +150,7 @@ END {
- else
- print " gettext_noop (\"" last_msgstr "\");";
- print "";
-- print "static const int " namespace "msgidx[] =";
-+ print "static const int " pkg_namespace "msgidx[] =";
- print " {";
- for (i = 0; i < coded_msgs; i++)
- print " " pos[i] ",";
-@@ -158,7 +158,7 @@ END {
- print " };";
- print "";
- print "static GPG_ERR_INLINE int";
-- print namespace "msgidxof (int code)";
-+ print pkg_namespace "msgidxof (int code)";
- print "{";
- print " return (0 ? 0";
-
---
-2.21.0
-
diff --git a/net/lcdringer/Makefile b/net/lcdringer/Makefile
index 98d4eca48..8cf3a2230 100644
--- a/net/lcdringer/Makefile
+++ b/net/lcdringer/Makefile
@@ -31,7 +31,7 @@ include $(INCLUDE_DIR)/nls.mk
define Package/lcdringer
SECTION:=network
CATEGORY:=Network
- DEPENDS:=+libgee +libgstreamer1 +loudmouth @TARGET_brcm2708
+ DEPENDS:=+libgee +libgstreamer1 +loudmouth @TARGET_bcm27xx
TITLE:=lcdringer
URL:=https://www.flyn.org/projects/lcdringer/
endef
diff --git a/net/miniupnpd/Makefile b/net/miniupnpd/Makefile
index c35c4318a..d3cbf2981 100644
--- a/net/miniupnpd/Makefile
+++ b/net/miniupnpd/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=miniupnpd
PKG_VERSION:=2.1.20191006
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE_URL:=https://miniupnp.tuxfamily.org/files
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
diff --git a/net/miniupnpd/files/miniupnpd.hotplug b/net/miniupnpd/files/miniupnpd.hotplug
index 9820d4254..9e525f9b5 100644
--- a/net/miniupnpd/files/miniupnpd.hotplug
+++ b/net/miniupnpd/files/miniupnpd.hotplug
@@ -1,8 +1,6 @@
-#!/bin/sh
+#!/bin/sh /etc/rc.common
-/etc/init.d/miniupnpd enabled || exit 0
-
-. /lib/functions/service.sh
+enabled miniupnpd || exit 0
# If miniupnpd is not running:
# - check on _any_ event (even updates may contribute to network_find_wan*)
@@ -11,7 +9,7 @@
# - check only on ifup (otherwise lease updates etc would cause
# miniupnpd state loss)
-[ "$ACTION" != "ifup" ] && service_check /usr/sbin/miniupnpd && exit 0
+[ "$ACTION" != "ifup" ] && service_running miniupnpd && exit 0
tmpconf="/var/etc/miniupnpd.conf"
extiface=$(uci get upnpd.config.external_iface)
@@ -19,15 +17,13 @@ extzone=$(uci get upnpd.config.external_zone)
. /lib/functions/network.sh
-if [ -z "$extiface" ] ; then
+[ -z "$extiface" ] && {
# manual external zone (if dynamically find interfaces
# belonging to it) overrides network_find_wan*
- if [ -n "$extzone" ] ; then
- ifname=$(fw3 -q zone $extzone | head -1)
- fi
- [ -n "$extiface" ] || network_find_wan extiface
- [ -n "$extiface" ] || network_find_wan6 extiface
-fi
-
-[ -n "$ifname" ] || network_get_device ifname "$extiface"
+ [ -n "$extzone" ] && ifname=$(fw3 -q zone "$extzone" | head -1)
+ [ -z "$extiface" ] && network_find_wan extiface
+ [ -z "$extiface" ] && network_find_wan6 extiface
+}
+
+[ -z "$ifname" ] && network_get_device ifname "$extiface"
grep -q "ext_ifname=$ifname" "$tmpconf" || /etc/init.d/miniupnpd restart
diff --git a/net/miniupnpd/files/miniupnpd.init b/net/miniupnpd/files/miniupnpd.init
index 9a85d0078..01434e915 100644
--- a/net/miniupnpd/files/miniupnpd.init
+++ b/net/miniupnpd/files/miniupnpd.init
@@ -3,8 +3,8 @@
START=94
STOP=15
-
-SERVICE_USE_PID=1
+USE_PROCD=1
+PROG=/usr/sbin/miniupnpd
upnpd_get_port_range() {
local var="$1"; shift
@@ -26,9 +26,8 @@ upnpd_get_port_range() {
conf_rule_add() {
local cfg="$1"
- local tmpconf="$2"
- local action external_port_start external_port_end int_addr
- local internal_port_start internal_port_end comment
+ local action int_addr
+ local ext_start ext_end int_start int_end comment
config_get action "$cfg" action "deny" # allow or deny
upnpd_get_port_range "ext" "$cfg" ext_ports "0-65535" # external ports: x, x-y, x:y
@@ -39,7 +38,7 @@ conf_rule_add() {
# Make a single IP IP/32 so that miniupnpd.conf can use it.
[ "${int_addr%/*}" = "$int_addr" ] && int_addr="$int_addr/32"
- echo "$action $ext_start${ext_end:+-}$ext_end $int_addr $int_start${int_end:+-}$int_end #$comment" >>$tmpconf
+ echo "$action $ext_start${ext_end:+-}$ext_end $int_addr $int_start${int_end:+-}$int_end #$comment"
}
upnpd_write_bool() {
@@ -50,161 +49,145 @@ upnpd_write_bool() {
config_get_bool val config "$opt" "$def"
if [ "$val" -eq 0 ]; then
- echo "$alt=no" >> $tmpconf
+ echo "$alt=no"
else
- echo "$alt=yes" >> $tmpconf
+ echo "$alt=yes"
fi
}
-boot() {
- return
-}
-
-start() {
+upnpd() {
config_load "upnpd"
- local extiface intiface upload download logging secure enabled natpmp
- local extip port usesysuptime conffile serial_number model_number
- local uuid notify_interval presentation_url enable_upnp
+ local external_iface external_iface6 external_zone external_ip internal_iface
+ local upload download log_output port config_file serial_number model_number
+ local use_stun stun_host stun_port uuid notify_interval presentation_url
local upnp_lease_file clean_ruleset_threshold clean_ruleset_interval
- local ipv6_listening_ip enabled
+ local enabled
config_get_bool enabled config enabled 1
-
[ "$enabled" -eq 0 ] && return 1
- config_get extiface config external_iface
- config_get extzone config external_zone
- config_get intiface config internal_iface
- config_get extip config external_ip
+ config_get external_iface config external_iface
+ config_get external_zone config external_zone
+ config_get external_ip config external_ip
+ config_get internal_iface config internal_iface
config_get port config port 5000
config_get upload config upload
config_get download config download
- config_get_bool logging config log_output 0
- config_get conffile config config_file
+ config_get_bool log_output config log_output 0
+ config_get config_file config config_file
config_get serial_number config serial_number
config_get model_number config model_number
config_get uuid config uuid
+ config_get stun_host config stun_host
+ config_get stun_port config stun_port
config_get notify_interval config notify_interval
config_get presentation_url config presentation_url
config_get upnp_lease_file config upnp_lease_file
config_get clean_ruleset_threshold config clean_ruleset_threshold
config_get clean_ruleset_interval config clean_ruleset_interval
- config_get ipv6_listening_ip config ipv6_listening_ip
- local args ifname
+ local conf ifname ifname6
. /lib/functions/network.sh
- # manual external interface overrides everything
- if [ -z "$extiface" ] ; then
- # manual external zone (if dynamically find interfaces
- # belonging to it) overrides network_find_wan*
- if [ -n "$extzone" ] ; then
- ifname=$(fw3 -q zone $extzone | head -1)
- fi
- [ -n "$extiface" ] || network_find_wan extiface
- [ -n "$extiface" ] || network_find_wan6 extiface
- fi
-
- [ -n "$ifname" ] || network_get_device ifname $extiface
-
- if [ -n "$conffile" ]; then
- args="-f $conffile"
+ # manual external interface overrides everything
+ [ -z "$external_iface" ] && {
+ # manual external zone (if dynamically find interfaces
+ # belonging to it) overrides network_find_wan*
+ [ -n "$external_zone" ] && ifname=$(fw3 -q zone "$external_zone" | head -1)
+ [ -z "$external_iface" ] && network_find_wan external_iface
+ [ -z "$external_iface6" ] && network_find_wan6 external_iface6
+ }
+
+ [ -z "$ifname" ] && network_get_device ifname "$external_iface"
+ [ -z "$ifname6" ] && network_get_device ifname6 "$external_iface6"
+
+ if [ -n "$config_file" ]; then
+ conf="$config_file"
else
local tmpconf="/var/etc/miniupnpd.conf"
- args="-f $tmpconf"
+ conf="$tmpconf"
mkdir -p /var/etc
- echo "ext_ifname=$ifname" >$tmpconf
-
- [ -n "$extip" ] && \
- echo "ext_ip=$extip" >>$tmpconf
+ {
+ echo "ext_ifname=$ifname"
+ echo "ext_ifname6=$ifname6"
+ [ -n "$external_ip" ] && echo "ext_ip=$external_ip"
local iface
- for iface in ${intiface:-lan}; do
+ for iface in ${internal_iface:-lan}; do
local device
- network_get_device device "$iface" && {
- echo "listening_ip=$device" >>$tmpconf
- }
+ network_get_device device "$iface" && echo "listening_ip=$device"
+ network_get_device device "$iface" && echo "ipv6_listening_ip=$device"
done
- [ "$port" != "auto" ] && \
- echo "port=$port" >>$tmpconf
-
config_load "upnpd"
upnpd_write_bool enable_natpmp 1
upnpd_write_bool enable_upnp 1
upnpd_write_bool secure_mode 1
- upnpd_write_bool pcp_allow_thirdparty 0
upnpd_write_bool system_uptime 1
upnpd_write_bool igdv1 0 force_igd_desc_v1
+ upnpd_write_bool use_stun 0 ext_perform_stun
- [ -n "$upnp_lease_file" ] && \
- echo "lease_file=$upnp_lease_file" >>$tmpconf
-
- [ -n "$upload" -a -n "$download" ] && {
- echo "bitrate_down=$(($download * 1024 * 8))" >>$tmpconf
- echo "bitrate_up=$(($upload * 1024 * 8))" >>$tmpconf
+ [ "$use_stun" -eq 0 ] || {
+ [ -n "$stun_host" ] && echo "ext_stun_host=$stun_host"
+ [ -n "$stun_port" ] && echo "ext_stun_port=$stun_port"
}
- [ -n "${presentation_url}" ] && \
- echo "presentation_url=${presentation_url}" >>$tmpconf
-
- [ -n "${notify_interval}" ] && \
- echo "notify_interval=${notify_interval}" >>$tmpconf
-
- [ -n "${clean_ruleset_threshold}" ] && \
- echo "clean_ruleset_threshold=${clean_ruleset_threshold}" >>$tmpconf
-
- [ -n "${clean_ruleset_interval}" ] && \
- echo "clean_ruleset_interval=${clean_ruleset_interval}" >>$tmpconf
+ [ -n "$upload" ] && [ -n "$download" ] && {
+ echo "bitrate_down=$((download * 1024 * 8))"
+ echo "bitrate_up=$((upload * 1024 * 8))"
+ }
- [ -n "${ipv6_listening_ip}" ] && \
- echo "ipv6_listening_ip=${ipv6_listening_ip}" >>$tmpconf
+ [ -n "$upnp_lease_file" ] && touch "$upnp_lease_file" && echo "lease_file=$upnp_lease_file"
+ [ -n "$presentation_url" ] && echo "presentation_url=$presentation_url"
+ [ -n "$notify_interval" ] && echo "notify_interval=$notify_interval"
+ [ -n "$clean_ruleset_threshold" ] && echo "clean_ruleset_threshold=$clean_ruleset_threshold"
+ [ -n "$clean_ruleset_interval" ] && echo "clean_ruleset_interval=$clean_ruleset_interval"
+ [ -n "$serial_number" ] && echo "serial=$serial_number"
+ [ -n "$model_number" ] && echo "model_number=$model_number"
+ [ -n "$port" ] && echo "port=$port"
[ -z "$uuid" ] && {
uuid="$(cat /proc/sys/kernel/random/uuid)"
- uci set upnpd.config.uuid=$uuid
+ uci set upnpd.config.uuid="$uuid"
uci commit upnpd
}
- [ "$uuid" = "nocli" ] || \
- echo "uuid=$uuid" >>$tmpconf
-
- [ -n "${serial_number}" ] && \
- echo "serial=${serial_number}" >>$tmpconf
+ [ "$uuid" = "nocli" ] || echo "uuid=$uuid"
- [ -n "${model_number}" ] && \
- echo "model_number=${model_number}" >>$tmpconf
+ config_foreach conf_rule_add perm_rule
- config_foreach conf_rule_add perm_rule "$tmpconf"
+ } > "$tmpconf"
fi
-
if [ -n "$ifname" ]; then
# start firewall
iptables -L MINIUPNPD >/dev/null 2>&1 || fw3 reload
-
- if [ "$logging" = "1" ]; then
- SERVICE_DAEMONIZE=1 \
- service_start /usr/sbin/miniupnpd $args -d
- else
- SERVICE_DAEMONIZE= \
- service_start /usr/sbin/miniupnpd $args
- fi
else
logger -t "upnp daemon" "external interface not found, not starting"
fi
-}
-stop() {
- service_stop /usr/sbin/miniupnpd
+ procd_open_instance
+ procd_set_param command "$PROG"
+ procd_append_param command -f "$conf"
+ [ "$log_output" = "1" ] && procd_append_param command -d
+ procd_close_instance
+}
+stop_service() {
iptables -t nat -F MINIUPNPD 2>/dev/null
iptables -t nat -F MINIUPNPD-POSTROUTING 2>/dev/null
iptables -t filter -F MINIUPNPD 2>/dev/null
- [ -x /usr/sbin/ip6tables ] && {
- ip6tables -t filter -F MINIUPNPD 2>/dev/null
- }
+ [ -x /usr/sbin/ip6tables ] && ip6tables -t filter -F MINIUPNPD 2>/dev/null
+}
+
+start_service() {
+ config_load "upnpd"
+ config_foreach upnpd "upnpd"
+}
+
+service_triggers() {
+ procd_add_reload_trigger "upnpd"
}
diff --git a/net/miniupnpd/files/upnpd.config b/net/miniupnpd/files/upnpd.config
index 299664362..4e7466495 100644
--- a/net/miniupnpd/files/upnpd.config
+++ b/net/miniupnpd/files/upnpd.config
@@ -4,8 +4,8 @@ config upnpd config
option enable_upnp 1
option secure_mode 1
option log_output 0
- option download 1024
- option upload 512
+ option download 1024
+ option upload 512
#by default, looked up dynamically from ubus
# option external_iface wan
option internal_iface lan
diff --git a/net/miniupnpd/patches/100-no-daemon.patch b/net/miniupnpd/patches/100-no-daemon.patch
new file mode 100644
index 000000000..3d51fcaa7
--- /dev/null
+++ b/net/miniupnpd/patches/100-no-daemon.patch
@@ -0,0 +1,25 @@
+--- a/miniupnpd.c
++++ b/miniupnpd.c
+@@ -1727,21 +1727,7 @@ init(int argc, char * * argv, struct runtime_vars * v)
+ }
+ }
+
+- if(debug_flag)
+- {
+- pid = getpid();
+- }
+- else
+- {
+-#ifdef USE_DAEMON
+- if(daemon(0, 0)<0) {
+- perror("daemon()");
+- }
+- pid = getpid();
+-#else
+- pid = daemonize();
+-#endif
+- }
++ pid = getpid();
+
+ openlog_option = LOG_PID|LOG_CONS;
+ if(debug_flag)
diff --git a/net/udpxy/Makefile b/net/udpxy/Makefile
index a9fc6311d..f70533a0d 100644
--- a/net/udpxy/Makefile
+++ b/net/udpxy/Makefile
@@ -8,21 +8,19 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=udpxy
-PKG_SOURCE_VERSION:=53e4672a7522311c40e9f6110ff256041c52c8b4
-PKG_VERSION:=2016-09-18-$(PKG_SOURCE_VERSION)
+PKG_VERSION:=1.0-24.1
PKG_RELEASE:=1
-PKG_SOURCE_PROTO:=git
-PKG_SOURCE_URL:=https://github.com/pcherenkov/udpxy.git
-PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_MIRROR_HASH:=bb6ca16706b011cc473d296ebc6d6e57fe5cfc2a0fc46e81399fba01d6484b3e
-PKG_MAINTAINER:=Álvaro Fernández Rojas <noltari@gmail.com>
+PKG_SOURCE_URL:=https://codeload.github.com/pcherenkov/udpxy/tar.gz/$(PKG_VERSION)?
+PKG_HASH:=27e5d3d2bae29522354d1505a3cc931c96953846d68eeb25bb99fe9b0cb6cbe0
-PKG_LICENSE:=GPL-3.0
-PKG_LICENSE_FILES:=gpl.txt
+PKG_MAINTAINER:=Álvaro Fernández Rojas <noltari@gmail.com>
+PKG_LICENSE:=GPL-3.0-or-later
+PKG_LICENSE_FILES:=chipmunk/gpl.txt
PKG_INSTALL:=1
+PKG_BUILD_PARALLEL:=1
include $(INCLUDE_DIR)/package.mk
diff --git a/utils/collectd/Makefile b/utils/collectd/Makefile
index a0283de4f..809489a60 100644
--- a/utils/collectd/Makefile
+++ b/utils/collectd/Makefile
@@ -368,7 +368,7 @@ $(eval $(call BuildPlugin,chrony,chrony status input,chrony,))
$(eval $(call BuildPlugin,conntrack,connection tracking table size input,conntrack,))
$(eval $(call BuildPlugin,contextswitch,context switch input,contextswitch,))
$(eval $(call BuildPlugin,cpu,CPU input,cpu,))
-$(eval $(call BuildPlugin,cpufreq,CPU Freq input,cpufreq,@(TARGET_x86||TARGET_x86_64||TARGET_mvebu||TARGET_ipq806x||TARGET_armvirt||TARGET_ipq40xx||TARGET_brcm2708_bcm2709))) # Only enable on targets with CPUs supporting frequency scaling
+$(eval $(call BuildPlugin,cpufreq,CPU Freq input,cpufreq,@(TARGET_x86||TARGET_x86_64||TARGET_mvebu||TARGET_ipq806x||TARGET_armvirt||TARGET_ipq40xx||TARGET_bcm27xx_bcm2709))) # Only enable on targets with CPUs supporting frequency scaling
$(eval $(call BuildPlugin,csv,CSV output,csv,))
$(eval $(call BuildPlugin,curl,cURL input,curl,+PACKAGE_collectd-mod-curl:libcurl))
#$(eval $(call BuildPlugin,dbi,relational database input,dbi,+PACKAGE_collectd-mod-dbi:libdbi))
diff --git a/utils/rtty/Makefile b/utils/rtty/Makefile
index 4b6a536cd..5f0d13897 100644
--- a/utils/rtty/Makefile
+++ b/utils/rtty/Makefile
@@ -9,11 +9,11 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=rtty
PKG_VERSION:=7.1.1
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL=https://github.com/zhaojh329/rtty/releases/download/v$(PKG_VERSION)
-PKG_HASH:=05cc5fcf126041f3bc79d92123ff2a19da25806f77fc12286498ee85da139a74
+PKG_HASH:=72ff1b7abd8e6c7f395a024125135d69ca2a24aa0dbdc3e974a0bc7adb477214
CMAKE_INSTALL:=1
PKG_LICENSE:=MIT