aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--lang/perl-http-message/Makefile6
-rw-r--r--lang/perl-uri/Makefile4
-rw-r--r--lang/python/Makefile1
-rw-r--r--libs/libidn/Makefile4
-rw-r--r--libs/liblo/patches/001-fix-musl-include.patch11
-rw-r--r--libs/libstrophe/Config.in14
-rw-r--r--libs/libstrophe/Makefile65
-rw-r--r--libs/sqlite3/Makefile4
-rw-r--r--net/dhcpcd/patches/001-fix-musl.patch13
-rw-r--r--net/gnunet/Makefile4
-rw-r--r--net/gnunet/files/gnunet.defaults40
-rw-r--r--net/gnunet/files/gnunet.init48
-rw-r--r--net/kismet/patches/010-dont-add-host-include-paths.patch6
-rw-r--r--net/kismet/patches/020-musl-include-fixes.patch22
-rw-r--r--net/stunnel/Makefile4
-rw-r--r--net/stunnel/patches/010_fix_getnameinfo.patch25
-rw-r--r--net/stunnel/patches/012-cron-without-pthread-fix.patch14
-rw-r--r--net/transmission/Makefile3
-rw-r--r--net/transmission/files/transmission.config2
-rw-r--r--net/transmission/files/transmission.init71
-rw-r--r--utils/bluez/Makefile9
-rw-r--r--utils/bluez/patches/201-readline.patch8
-rw-r--r--utils/pps-tools/Makefile1
-rw-r--r--utils/rtl-sdr/Makefile14
24 files changed, 283 insertions, 110 deletions
diff --git a/lang/perl-http-message/Makefile b/lang/perl-http-message/Makefile
index ecbb31f08..f0bc5cb44 100644
--- a/lang/perl-http-message/Makefile
+++ b/lang/perl-http-message/Makefile
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=perl-http-message
-PKG_VERSION:=6.06
+PKG_VERSION:=6.10
PKG_RELEASE:=1
-PKG_SOURCE_URL:=http://www.cpan.org/authors/id/G/GA/GAAS
+PKG_SOURCE_URL:=http://www.cpan.org/authors/id/E/ET/ETHER
PKG_SOURCE:=HTTP-Message-$(PKG_VERSION).tar.gz
-PKG_MD5SUM:=e563ac516e28d33f65bc0f295f625f85
+PKG_MD5SUM:=b8a68ce1898691c536714eeae3f963d4
PKG_LICENSE:=GPL-1.0+ Artistic-1.0-Perl
PKG_MAINTAINER:=Marcel Denia <naoir@gmx.net>
diff --git a/lang/perl-uri/Makefile b/lang/perl-uri/Makefile
index 3508d903c..e3f566efb 100644
--- a/lang/perl-uri/Makefile
+++ b/lang/perl-uri/Makefile
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=perl-uri
-PKG_VERSION:=1.68
+PKG_VERSION:=1.69
PKG_RELEASE:=1
PKG_SOURCE_URL:=http://www.cpan.org/authors/id/E/ET/ETHER/
PKG_SOURCE:=URI-$(PKG_VERSION).tar.gz
-PKG_MD5SUM:=4a954ab8d79f831616ca817ba4b26cb9
+PKG_MD5SUM:=3c56aee0300bce5a440ccbd558277ea0
PKG_LICENSE:=GPL-1.0+ Artistic-1.0-Perl
PKG_MAINTAINER:=Marcel Denia <naoir@gmx.net>
diff --git a/lang/python/Makefile b/lang/python/Makefile
index 0caa92ba2..935fc3960 100644
--- a/lang/python/Makefile
+++ b/lang/python/Makefile
@@ -221,6 +221,7 @@ HOST_CONFIGURE_ARGS+= \
--without-cxx-main \
--without-pymalloc \
--with-threads \
+ --with-system-expat=$(STAGING_DIR_HOST) \
--prefix=$(STAGING_DIR_HOST) \
--with-ensurepip=upgrade \
CONFIG_SITE= \
diff --git a/libs/libidn/Makefile b/libs/libidn/Makefile
index 99f4803cb..8bfe2a8e0 100644
--- a/libs/libidn/Makefile
+++ b/libs/libidn/Makefile
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=libidn
-PKG_VERSION:=1.31
+PKG_VERSION:=1.32
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@GNU/libidn
-PKG_MD5SUM:=83806230fc0989a24cf9dfe6685563d9
+PKG_MD5SUM:=4dd8356ba577287ea7076bfa1554b534
PKG_LICENSE:=GPL-2.0+ GPL-3.0+ LGPL-2.1+ LGPL-3.0+ Apache-2.0
PKG_LICENSE_FILES:=COPYING COPYINGv2 COPYINGv3 COPYING.LESSERv2 COPYING.LESSERv3 java/LICENSE-2.0.txt
diff --git a/libs/liblo/patches/001-fix-musl-include.patch b/libs/liblo/patches/001-fix-musl-include.patch
new file mode 100644
index 000000000..f974bd3d1
--- /dev/null
+++ b/libs/liblo/patches/001-fix-musl-include.patch
@@ -0,0 +1,11 @@
+--- a/src/server.c
++++ b/src/server.c
+@@ -48,7 +48,7 @@
+ #include <netdb.h>
+ #include <sys/socket.h>
+ #ifdef HAVE_POLL
+-#include <sys/poll.h>
++#include <poll.h>
+ #endif
+ #include <sys/un.h>
+ #include <arpa/inet.h>
diff --git a/libs/libstrophe/Config.in b/libs/libstrophe/Config.in
new file mode 100644
index 000000000..ec45f754c
--- /dev/null
+++ b/libs/libstrophe/Config.in
@@ -0,0 +1,14 @@
+choice
+ depends on PACKAGE_libstrophe
+ prompt "Select XML library"
+ default libstrophe-expat
+
+config libstrophe-expat
+ bool "expat"
+ select PACKAGE_libexpat
+
+config libstrophe-libxml2
+ bool "libxml2"
+ select PACKAGE_libxml2
+
+endchoice
diff --git a/libs/libstrophe/Makefile b/libs/libstrophe/Makefile
new file mode 100644
index 000000000..662791650
--- /dev/null
+++ b/libs/libstrophe/Makefile
@@ -0,0 +1,65 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libstrophe
+PKG_VERSION:=0.8.7
+PKG_RELEASE=1
+
+PKG_LICENSE:=GPL-3.0
+PKG_LICENSE_FILES:=COPYING
+PKG_MAINTAINER:=Chih-Wei Chen <changeway@gmail.com>
+
+PKG_SOURCE_URL:=https://github.com/strophe/libstrophe/archive/
+PKG_SOURCE:=$(PKG_VERSION).tar.gz
+
+PKG_FIXUP:=autoreconf
+PKG_INSTALL:=1
+
+PKG_CONFIG_DEPENDS:= \
+ CONFIG_libstrophe-libxml2 \
+ CONFIG_libstrophe-expat
+
+include $(INCLUDE_DIR)/package.mk
+
+ifeq ($(CONFIG_libstrophe-libxml2),y)
+CONFIGURE_ARGS += \
+ --with-libxml2
+endif
+
+define Package/libstrophe
+ SECTION:=libs
+ CATEGORY:=Libraries
+ TITLE:=XMPP client library
+ URL:=http://strophe.im/libstrophe
+ DEPENDS:= +libopenssl +libstrophe-libxml2:libxml2 +libstrophe-expat:libexpat
+ MENU:=1
+endef
+
+define Package/libstrophe/description
+ A simple, lightweight C library for writing XMPP clients
+endef
+
+define Package/libstrophe/config
+ source "$(SOURCE)/Config.in"
+endef
+
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/
+ $(CP) $(PKG_INSTALL_DIR)/usr/include/ $(1)/usr/
+
+ $(INSTALL_DIR) $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libstrophe.{la,a,so*} $(1)/usr/lib/
+endef
+
+define Package/libstrophe/install
+ $(INSTALL_DIR) $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libstrophe.so.* $(1)/usr/lib
+endef
+
+$(eval $(call BuildPackage,libstrophe))
diff --git a/libs/sqlite3/Makefile b/libs/sqlite3/Makefile
index 7f5d58a7c..0fdbedfc9 100644
--- a/libs/sqlite3/Makefile
+++ b/libs/sqlite3/Makefile
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=sqlite
-PKG_VERSION:=3081002
+PKG_VERSION:=3081101
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-autoconf-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.sqlite.org/2015/
-PKG_MD5SUM:=a18bfc015cd49a1e7a961b7b77bc3b37
+PKG_MD5SUM:=298c8d6af7ca314f68de92bc7a356cbe
PKG_LICENSE:=PUBLICDOMAIN
PKG_LICENSE_FILES:=
diff --git a/net/dhcpcd/patches/001-fix-musl.patch b/net/dhcpcd/patches/001-fix-musl.patch
new file mode 100644
index 000000000..5751a4c16
--- /dev/null
+++ b/net/dhcpcd/patches/001-fix-musl.patch
@@ -0,0 +1,13 @@
+--- a/dhcp6.c
++++ b/dhcp6.c
+@@ -1047,8 +1047,8 @@ logsend:
+
+ ctx = ifp->ctx->ipv6;
+ dst.sin6_scope_id = ifp->index;
+- ctx->sndhdr.msg_name = (caddr_t)&dst;
+- ctx->sndhdr.msg_iov[0].iov_base = (caddr_t)state->send;
++ ctx->sndhdr.msg_name = (void *)&dst;
++ ctx->sndhdr.msg_iov[0].iov_base = (void *)state->send;
+ ctx->sndhdr.msg_iov[0].iov_len = state->send_len;
+
+ /* Set the outbound interface */
diff --git a/net/gnunet/Makefile b/net/gnunet/Makefile
index 9660a314f..898b8d394 100644
--- a/net/gnunet/Makefile
+++ b/net/gnunet/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=gnunet
-PKG_SOURCE_VERSION:=36139
+PKG_SOURCE_VERSION:=36190
PKG_VERSION:=0.10.1-svn$(PKG_SOURCE_VERSION)
PKG_RELEASE:=1
@@ -167,6 +167,8 @@ define Package/gnunet/install
$(INSTALL_BIN) ./files/gnunet.init $(1)/etc/init.d/gnunet
$(INSTALL_DIR) $(1)/lib/upgrade/keep.d
$(INSTALL_DATA) ./files/gnunet.upgrade $(1)/lib/upgrade/keep.d/gnunet
+ $(INSTALL_DIR) $(1)/etc/uci-defaults
+ $(INSTALL_BIN) ./files/gnunet.defaults $(1)/etc/uci-defaults/gnunet
endef
define Build/InstallDev
diff --git a/net/gnunet/files/gnunet.defaults b/net/gnunet/files/gnunet.defaults
new file mode 100644
index 000000000..dbb505066
--- /dev/null
+++ b/net/gnunet/files/gnunet.defaults
@@ -0,0 +1,40 @@
+#!/bin/sh
+
+[ -e /etc/config/gnunet ] && exit 0
+
+touch /etc/config/gnunet
+
+uci set gnunet.datastore=gnunet-config
+uci set gnunet.datastore.DATABASE=heap
+uci set gnunet.datastore.QUOTA="4 MB"
+
+uci set gnunet.fs=gnunet-config
+uci set gnunet.fs.CONTENT_PUSHING=NO
+uci set gnunet.fs.CONTENT_CACHING=NO
+
+# limit dhtcache memory usage to 4 MB
+uci set gnunet.dhtcache=gnunet-config
+uci set gnunet.dhtcache.QUOTA="4 MB"
+
+# enable dns2gns
+uci set gnunet.dns2gns=gnunet-config
+uci set gnunet.dns2gns.AUTOSTART=YES
+uci set gnunet.dns2gns.FORCESTART=YES
+
+# enable v4/v6 protocol translation for EXIT/VPN
+uci set gnunet.pt=gnunet-config
+uci set gnunet.pt.FORCESTART=YES
+
+uci set gnunet.exit=gnunet-config
+uci set gnunet.exit.AUTOSTART=YES
+uci set gnunet.exit.FORCESTART=YES
+uci set gnunet.exit.EXIT_IPV4=YES
+uci set gnunet.exit.EXIT_RANGE_IPV4_POLICY="169.254.86.1:7;169.254.86.1:5201;"
+
+# iperf (TCP) and echo (UDP) for battlemesh
+uci set gnunet.iperf=gnunet-exit-service
+uci set gnunet.iperf.TCP_REDIRECTS="5201:169.254.86.1:5201"
+uci set gnunet.echo=gnunet-exit-service
+uci set gnunet.echo.UDP_REDIRECTS="7:169.254.86.1:7"
+
+uci commit gnunet
diff --git a/net/gnunet/files/gnunet.init b/net/gnunet/files/gnunet.init
index 8b810d7b0..aa8742295 100644
--- a/net/gnunet/files/gnunet.init
+++ b/net/gnunet/files/gnunet.init
@@ -47,6 +47,8 @@ prepare_config() {
mkdir -p /etc/gnunet
chown gnunet:gnunet /etc/gnunet
}
+
+ # defaults paths
gnunet-config -c $CONFIGFILE -s PATHS -o GNUNET_CONFIG_HOME -V /etc/gnunet
gnunet-config -c $CONFIGFILE -s PEER -o PRIVATE_KEY -V /etc/gnunet/private_key.ecc
gnunet-config -c $CONFIGFILE -s identity -o EGODIR -V /etc/gnunet/identity/egos
@@ -54,19 +56,6 @@ prepare_config() {
gnunet-config -c $CONFIGFILE -s nse -o PROOFFILE -V /etc/gnunet/proof.dat
gnunet-config -c $CONFIGFILE -s namestore-sqlite -o FILENAME -V /etc/gnunet/namestore.sqlite
- # minimal datastore (todo: make this configurable)
- gnunet-config -c $CONFIGFILE -s datastore -o DATABASE -V heap
- gnunet-config -c $CONFIGFILE -s datastore -o QUOTA -V "4 MB"
- gnunet-config -c $CONFIGFILE -s fs -o CONTENT_PUSHING -V NO
- gnunet-config -c $CONFIGFILE -s fs -o CONTENT_CACHING -V NO
-
- # limit dhtcache memory usage to 4 MB
- gnunet-config -c $CONFIGFILE -s dhtcache -o QUOTA -V "4 MB"
-
- # enable dns2gns
- gnunet-config -c $CONFIGFILE -s dns2gns -o AUTOSTART -V YES
- gnunet-config -c $CONFIGFILE -s dns2gns -o FORCESTART -V YES
-
# enable all installed transport plugins
transport_plugins=$(gnunet-config -c $CONFIGFILE -s transport -o PLUGINS)
for transplug in /usr/lib/gnunet/libgnunet_plugin_transport_*.so; do
@@ -77,18 +66,27 @@ prepare_config() {
done
gnunet-config -c $CONFIGFILE -s transport -o PLUGINS -V "$transport_plugins"
- gnunet-config -c $CONFIGFILE -s pt -o FORCESTART -V YES
- gnunet-config -c $CONFIGFILE -s exit -o AUTOSTART -V YES
- gnunet-config -c $CONFIGFILE -s exit -o FORCESTART -V YES
- gnunet-config -c $CONFIGFILE -s exit -o EXIT_IPV4 -V YES
- # ssh and www services
-# gnunet-config -c $CONFIGFILE -s exit -o EXIT_RANGE_IPV4_POLICY -V "169.254.86.1:22;169.254.86.1:80;"
-# gnunet-config -c $CONFIGFILE -s ssh.gnunet. -o TCP_REDIRECTS -V "22:169.254.86.1:22"
-# gnunet-config -c $CONFIGFILE -s www.gnunet. -o TCP_REDIRECTS -V "80:169.254.86.1:80"
- # iperf (TCP) and echo (UDP) for battlemesh
- gnunet-config -c $CONFIGFILE -s exit -o EXIT_RANGE_IPV4_POLICY -V "169.254.86.1:7;169.254.86.1:5201;"
- gnunet-config -c $CONFIGFILE -s iperf.gnunet. -o TCP_REDIRECTS -V "5201:169.254.86.1:5201"
- gnunet-config -c $CONFIGFILE -s echo.gnunet. -o UDP_REDIRECTS -V "7:169.254.86.1:7"
+ # apply config from UCI
+ _gnunet_section=""
+ config_cb()
+ {
+ # $1 "Type"
+ # $2 "Name"
+ local __TYPE="$1"
+ local __NAME="$2"
+ [ "${__TYPE}" = "gnunet-config" ] && _gnunet_section="${__NAME}"
+ [ "${__TYPE}" = "gnunet-exit-service" ] && _gnunet_section="${__NAME}.gnunet."
+ }
+ option_cb() {
+ # $1 name of variable
+ # $2 value
+ local __OPT="$1"
+ local __VAL="$2"
+ gnunet-config -c $CONFIGFILE -s ${_gnunet_section} -o ${__OPT} -V "${__VAL}"
+ }
+ config_load gnunet
+
+ return 0
}
start_service() {
diff --git a/net/kismet/patches/010-dont-add-host-include-paths.patch b/net/kismet/patches/010-dont-add-host-include-paths.patch
index 23a87bdcf..3b1858afb 100644
--- a/net/kismet/patches/010-dont-add-host-include-paths.patch
+++ b/net/kismet/patches/010-dont-add-host-include-paths.patch
@@ -1,9 +1,7 @@
-diff --git a/configure b/configure
-index 6936a47..9a85269 100755
--- a/configure
+++ b/configure
-@@ -6980,9 +6980,6 @@ else
- fi
+@@ -5456,9 +5456,6 @@ fi
+
-# Add additional cflags since some distros bury panel.h
diff --git a/net/kismet/patches/020-musl-include-fixes.patch b/net/kismet/patches/020-musl-include-fixes.patch
new file mode 100644
index 000000000..7f2d52cb9
--- /dev/null
+++ b/net/kismet/patches/020-musl-include-fixes.patch
@@ -0,0 +1,22 @@
+--- a/configfile.cc
++++ b/configfile.cc
+@@ -24,6 +24,7 @@
+ #include <stdlib.h>
+ #include <stdio.h>
+ #include <errno.h>
++#include <time.h>
+ #include "configfile.h"
+ #include "util.h"
+
+--- a/dumpfile_tuntap.cc
++++ b/dumpfile_tuntap.cc
+@@ -20,8 +20,8 @@
+
+ #include <errno.h>
+
+-#include "dumpfile_tuntap.h"
+ #include "ifcontrol.h"
++#include "dumpfile_tuntap.h"
+ #include "ipc_remote.h"
+
+ #ifndef SYS_CYGWIN
diff --git a/net/stunnel/Makefile b/net/stunnel/Makefile
index 0b928b7f6..58a6bbea6 100644
--- a/net/stunnel/Makefile
+++ b/net/stunnel/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=stunnel
-PKG_VERSION:=5.14
+PKG_VERSION:=5.20
PKG_RELEASE:=1
PKG_LICENSE:=GPL-2.0+
@@ -17,7 +17,7 @@ PKG_LICENSE_FILES:=COPYING COPYRIGHT.GPL
PKG_SOURCE_URL:=http://stunnel.cybermirror.org/archive/5.x/
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_MD5SUM:=e716501960dc6856d80f92547298f724
+PKG_MD5SUM:=3264375026c2b496b5d258e243222de8
PKG_FIXUP:=autoreconf
PKG_INSTALL:=1
diff --git a/net/stunnel/patches/010_fix_getnameinfo.patch b/net/stunnel/patches/010_fix_getnameinfo.patch
deleted file mode 100644
index 03acfafac..000000000
--- a/net/stunnel/patches/010_fix_getnameinfo.patch
+++ /dev/null
@@ -1,25 +0,0 @@
---- a/src/prototypes.h
-+++ b/src/prototypes.h
-@@ -590,7 +590,7 @@ extern GETNAMEINFO s_getnameinfo;
-
- #endif /* USE_WIN32 */
-
--int getnameinfo(const struct sockaddr *, int, char *, int, char *, int, int);
-+int getnameinfo(const struct sockaddr *, socklen_t, char *, socklen_t, char *, socklen_t, unsigned int);
-
- #endif /* !defined HAVE_GETNAMEINFO */
-
---- a/src/resolver.c
-+++ b/src/resolver.c
-@@ -538,8 +538,9 @@ const char *s_gai_strerror(int err) {
- /* implementation is limited to functionality needed by stunnel */
-
- #ifndef HAVE_GETNAMEINFO
--int getnameinfo(const struct sockaddr *sa, int salen,
-- char *host, int hostlen, char *serv, int servlen, int flags) {
-+int getnameinfo(const struct sockaddr *sa, socklen_t salen,
-+ char *host, socklen_t hostlen, char *serv, socklen_t servlen,
-+ unsigned int flags) {
-
- #if defined(USE_WIN32) && !defined(_WIN32_WCE)
- if(s_getnameinfo)
diff --git a/net/stunnel/patches/012-cron-without-pthread-fix.patch b/net/stunnel/patches/012-cron-without-pthread-fix.patch
new file mode 100644
index 000000000..0f644b3c1
--- /dev/null
+++ b/net/stunnel/patches/012-cron-without-pthread-fix.patch
@@ -0,0 +1,14 @@
+Index: stunnel-5.20/src/cron.c
+===================================================================
+--- stunnel-5.20.orig/src/cron.c
++++ stunnel-5.20/src/cron.c
+@@ -46,6 +46,9 @@ NOEXPORT void cron_thread(void *arg);
+ #endif
+ #if defined(USE_PTHREAD) || defined(USE_WIN32)
+ NOEXPORT void cron_worker(void);
++#endif
++
++#ifndef OPENSSL_NO_DH
+ NOEXPORT void cron_dh_param(void);
+ #endif
+
diff --git a/net/transmission/Makefile b/net/transmission/Makefile
index 8b50cd69c..1cd4b91f6 100644
--- a/net/transmission/Makefile
+++ b/net/transmission/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=transmission
PKG_VERSION:=2.84
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=http://download-origin.transmissionbt.com/files/ http://mirrors.m0k.org/transmission/files
@@ -34,6 +34,7 @@ define Package/transmission-daemon
$(call Package/transmission/template)
DEPENDS:=+libcurl +libopenssl +libpthread +libevent2 +librt
MENU:=1
+ USERID:=transmission=224:transmission=224
endef
define Package/transmission-cli
diff --git a/net/transmission/files/transmission.config b/net/transmission/files/transmission.config
index 31e2d5af4..2ea69d057 100644
--- a/net/transmission/files/transmission.config
+++ b/net/transmission/files/transmission.config
@@ -3,6 +3,8 @@ config transmission
option config_dir '/tmp/transmission'
#option user 'nobody'
option mem_percentage 50
+ option nice 10
+ option ionice_flags '-c 3'
option alt_speed_down 50
option alt_speed_enabled false
option alt_speed_time_begin 540
diff --git a/net/transmission/files/transmission.init b/net/transmission/files/transmission.init
index 535ace8bb..f7b1d41e1 100644
--- a/net/transmission/files/transmission.init
+++ b/net/transmission/files/transmission.init
@@ -47,8 +47,10 @@ transmission() {
local USE
local user
- local download_dir
+ local download_dir config_dir
local mem_percentage
+ local config_overwrite nice ionice_flags
+ local cmdline
section_enabled "$section" || return 1
@@ -56,6 +58,10 @@ transmission() {
config_get user "$cfg" 'user'
config_get download_dir "$cfg" 'download_dir' '/var/etc/transmission'
config_get mem_percentage "$cfg" 'mem_percentage' '50'
+ config_get config_overwrite "$cfg" config_overwrite 1
+ config_get nice "$cfg" nice 0
+ config_get ionice_flags "$cfg" ionice_flags ''
+ which ionice > /dev/null || ionice_flags=''
local MEM=$(sed -ne 's!^MemTotal:[[:space:]]*\([0-9]*\) kB$!\1!p' /proc/meminfo)
if test "$MEM" -gt 1;then
@@ -69,38 +75,45 @@ transmission() {
[ -z "$user" ] || chown -R $user $config_dir
}
- echo "{" > $config_file
-
- append_params "$cfg" \
- alt_speed_down alt_speed_enabled alt_speed_time_begin alt_speed_time_day \
- alt_speed_time_enabled alt_speed_time_end alt_speed_up blocklist_enabled \
- cache_size_mb download_queue_enabled download_queue_size \
- dht_enabled encryption idle_seeding_limit idle_seeding_limit_enabled \
- incomplete_dir_enabled lazy_bitfield_enabled lpd_enabled message_level \
- peer_limit_global peer_limit_per_torrent peer_port \
- peer_port_random_high peer_port_random_low peer_port_random_on_start \
- pex_enabled port_forwarding_enabled preallocation prefetch_enabled \
- ratio_limit ratio_limit_enabled rename_partial_files rpc_authentication_required \
- rpc_enabled rpc_port rpc_whitelist_enabled queue_stalled_enabled \
- queue_stalled_minutes scrape_paused_torrents_enabled script_torrent_done_enabled \
- seed_queue_enabled seed_queue_size \
- speed_limit_down speed_limit_down_enabled speed_limit_up \
- speed_limit_up_enabled start_added_torrents trash_original_torrent_files \
- umask upload_slots_per_torrent utp_enabled scrape_paused_torrents \
- watch_dir_enabled
-
- append_params_quotes "$cfg" \
- blocklist_url bind_address_ipv4 bind_address_ipv6 download_dir incomplete_dir \
- peer_congestion_algorithm peer_socket_tos rpc_bind_address rpc_password rpc_url \
- rpc_username rpc_whitelist script_torrent_done_filename watch_dir
-
- echo "\""invalid-key"\": false" >> $config_file
- echo "}" >> $config_file
+ [ "$config_overwrite" == 0 ] || {
+
+ echo "{" > $config_file
+
+ append_params "$cfg" \
+ alt_speed_down alt_speed_enabled alt_speed_time_begin alt_speed_time_day \
+ alt_speed_time_enabled alt_speed_time_end alt_speed_up blocklist_enabled \
+ cache_size_mb download_queue_enabled download_queue_size \
+ dht_enabled encryption idle_seeding_limit idle_seeding_limit_enabled \
+ incomplete_dir_enabled lazy_bitfield_enabled lpd_enabled message_level \
+ peer_limit_global peer_limit_per_torrent peer_port \
+ peer_port_random_high peer_port_random_low peer_port_random_on_start \
+ pex_enabled port_forwarding_enabled preallocation prefetch_enabled \
+ ratio_limit ratio_limit_enabled rename_partial_files rpc_authentication_required \
+ rpc_enabled rpc_port rpc_whitelist_enabled queue_stalled_enabled \
+ queue_stalled_minutes scrape_paused_torrents_enabled script_torrent_done_enabled \
+ seed_queue_enabled seed_queue_size \
+ speed_limit_down speed_limit_down_enabled speed_limit_up \
+ speed_limit_up_enabled start_added_torrents trash_original_torrent_files \
+ umask upload_slots_per_torrent utp_enabled scrape_paused_torrents \
+ watch_dir_enabled
+
+ append_params_quotes "$cfg" \
+ blocklist_url bind_address_ipv4 bind_address_ipv6 download_dir incomplete_dir \
+ peer_congestion_algorithm peer_socket_tos rpc_bind_address rpc_password rpc_url \
+ rpc_username rpc_whitelist script_torrent_done_filename watch_dir
+
+ echo "\""invalid-key"\": false" >> $config_file
+ echo "}" >> $config_file
+ }
+
+ cmdline="/usr/bin/transmission-daemon -g $config_dir -f"
+ [ "$ionice_flags" ] && cmdline="ionice $ionice_flags $cmdline"
procd_open_instance
- procd_set_param command /usr/bin/transmission-daemon -g $config_dir -f
+ procd_set_param command $cmdline
procd_set_param respawn retry=60
procd_set_param user "$user"
+ procd_set_param nice "$nice"
if test -z "$USE";then
procd_set_param limits core="0 0"
else
diff --git a/utils/bluez/Makefile b/utils/bluez/Makefile
index ebc164639..ce1497582 100644
--- a/utils/bluez/Makefile
+++ b/utils/bluez/Makefile
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=bluez
-PKG_VERSION:=5.30
-PKG_RELEASE:=2
+PKG_VERSION:=5.31
+PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
-PKG_SOURCE_URL:=http://www.kernel.org/pub/linux/bluetooth/
-PKG_MD5SUM:=24ba1d1e8e7ef5b8f4033a3059d7600e
+PKG_SOURCE_URL:=@KERNEL/linux/bluetooth/
+PKG_MD5SUM:=cb1db487b65dd4d57a2dd6b8f063c393
PKG_LICENSE:=GPL-2.0+
PKG_LICENSE_FILES:=COPYING
@@ -120,6 +120,7 @@ define Package/bluez-utils/install
$(CP) $(PKG_INSTALL_DIR)/usr/bin/bccmd $(1)/usr/bin/
$(CP) $(PKG_INSTALL_DIR)/usr/bin/bluemoon $(1)/usr/bin/
$(CP) $(PKG_INSTALL_DIR)/usr/bin/btmon $(1)/usr/bin/
+ $(CP) $(PKG_BUILD_DIR)/tools/btmgmt $(1)/usr/bin/
$(CP) $(PKG_INSTALL_DIR)/usr/bin/ciptool $(1)/usr/bin/
$(CP) $(PKG_INSTALL_DIR)/usr/bin/hciattach $(1)/usr/bin/
$(CP) $(PKG_INSTALL_DIR)/usr/bin/hciconfig $(1)/usr/bin/
diff --git a/utils/bluez/patches/201-readline.patch b/utils/bluez/patches/201-readline.patch
index 58396dcb0..dba14b456 100644
--- a/utils/bluez/patches/201-readline.patch
+++ b/utils/bluez/patches/201-readline.patch
@@ -1,6 +1,6 @@
--- a/Makefile.in
+++ b/Makefile.in
-@@ -2055,7 +2055,7 @@ unit_tests = $(am__append_32) unit/test-
+@@ -2394,7 +2394,7 @@ unit_tests = $(am__append_32) unit/test-
@CLIENT_TRUE@ monitor/uuid.h monitor/uuid.c
@CLIENT_TRUE@client_bluetoothctl_LDADD = gdbus/libgdbus-internal.la @GLIB_LIBS@ @DBUS_LIBS@ \
@@ -9,7 +9,7 @@
@MONITOR_TRUE@monitor_btmon_SOURCES = monitor/main.c monitor/bt.h \
@MONITOR_TRUE@ monitor/display.h monitor/display.c \
-@@ -2226,7 +2226,7 @@ unit_tests = $(am__append_32) unit/test-
+@@ -2594,7 +2594,7 @@ unit_tests = $(am__append_32) unit/test-
@EXPERIMENTAL_TRUE@tools_hcieventmask_LDADD = lib/libbluetooth-internal.la
@EXPERIMENTAL_TRUE@tools_btmgmt_SOURCES = tools/btmgmt.c src/uuid-helper.c client/display.c
@EXPERIMENTAL_TRUE@tools_btmgmt_LDADD = lib/libbluetooth-internal.la src/libshared-mainloop.la \
@@ -18,7 +18,7 @@
@EXPERIMENTAL_TRUE@tools_btinfo_SOURCES = tools/btinfo.c monitor/bt.h
@EXPERIMENTAL_TRUE@tools_btinfo_LDADD = src/libshared-mainloop.la
-@@ -2266,13 +2266,13 @@ unit_tests = $(am__append_32) unit/test-
+@@ -2642,13 +2642,13 @@ unit_tests = $(am__append_32) unit/test-
@READLINE_TRUE@ client/display.h
@READLINE_TRUE@attrib_gatttool_LDADD = lib/libbluetooth-internal.la \
@@ -34,7 +34,7 @@
@READLINE_TRUE@tools_obex_server_tool_SOURCES = $(gobex_sources) $(btio_sources) \
@READLINE_TRUE@ tools/obex-server-tool.c
-@@ -2282,13 +2282,13 @@ unit_tests = $(am__append_32) unit/test-
+@@ -2658,13 +2658,13 @@ unit_tests = $(am__append_32) unit/test-
@READLINE_TRUE@ client/display.h client/display.c
@READLINE_TRUE@tools_bluetooth_player_LDADD = gdbus/libgdbus-internal.la \
diff --git a/utils/pps-tools/Makefile b/utils/pps-tools/Makefile
index 653f90fbc..91918e58b 100644
--- a/utils/pps-tools/Makefile
+++ b/utils/pps-tools/Makefile
@@ -26,7 +26,6 @@ define Package/pps-tools
SECTION:=utils
CATEGORY:=Utilities
TITLE:=PPS-tools
- DEPENDS:=@LINUX_3_10||@LINUX_3_13||@LINUX_3_14||@LINUX_3_18
endef
define Package/pps-tools/description
diff --git a/utils/rtl-sdr/Makefile b/utils/rtl-sdr/Makefile
index 093b22cef..c716fb2ab 100644
--- a/utils/rtl-sdr/Makefile
+++ b/utils/rtl-sdr/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2013 OpenWrt.org
+# Copyright (C) 2015 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -7,14 +7,18 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=rtl-sdr
-PKG_VERSION:=2014-02-10
-PKG_RELEASE:=$(PKG_SOURCE_VERSION)
+PKG_VERSION:=0.5.3-20150608-$(PKG_SOURCE_VERSION)
+PKG_RELEASE:=1
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=git://git.osmocom.org/rtl-sdr.git
+PKG_SOURCE_VERSION:=e3c03f738f5aef4dc51e2b741fbdb542b9cc1bb1
+
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=6ee557360645da158e3065111349c318894b497b
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
+PKG_SOURCE:=$(PKG_SOURCE_SUBDIR).tar.gz
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_SOURCE_SUBDIR)
+PKG_BUILD_PARALLEL:=1
+
CMAKE_INSTALL:=1
PKG_LICENSE:=GPLv2