aboutsummaryrefslogtreecommitdiff
path: root/utils
diff options
context:
space:
mode:
authorHannu Nyman <hannu.nyman@iki.fi>2024-03-24 20:39:05 +0200
committerHannu Nyman <hannu.nyman@iki.fi>2024-03-24 23:23:16 +0200
commitb8d0049e7cb5ab5aaeb1c5517008dab4404faf6a (patch)
treeb637e998cf6fbbfe9f5f145916d6204fc5c7b2a8 /utils
parent887805fa95fe8e53501260a12f592d71dd4c6c13 (diff)
irqbalance: update to version 1.9.4
Update irqbalance to version 1.9.4. * refresh version in meson patch * remove EINVAL handling patch as upstream seems to have silenced the log spam for unmanageable IRQs Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
Diffstat (limited to 'utils')
-rw-r--r--utils/irqbalance/Makefile6
-rw-r--r--utils/irqbalance/patches/010-meson.patch4
-rw-r--r--utils/irqbalance/patches/020-mark-EINVAL-error-permanent.patch15
3 files changed, 5 insertions, 20 deletions
diff --git a/utils/irqbalance/Makefile b/utils/irqbalance/Makefile
index d1486a44e..8a6d7d1bc 100644
--- a/utils/irqbalance/Makefile
+++ b/utils/irqbalance/Makefile
@@ -5,13 +5,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=irqbalance
-PKG_VERSION:=1.9.3
-PKG_RELEASE:=3
+PKG_VERSION:=1.9.4
+PKG_RELEASE:=1
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://github.com/Irqbalance/irqbalance.git
PKG_SOURCE_VERSION:=v$(PKG_VERSION)
-PKG_MIRROR_HASH:=ff2936e9b7486e802206cbf9e16aa6cb7e1501bdf502441d31f409d104e757b8
+PKG_MIRROR_HASH:=92af1d0e6775e1b66bc34da95443d9f2d953ec0c3c276dc55f9558029f9c42b8
PKG_MAINTAINER:=Hannu Nyman <hannu.nyman@iki.fi>
PKG_LICENSE:=GPL-2.0-or-later
diff --git a/utils/irqbalance/patches/010-meson.patch b/utils/irqbalance/patches/010-meson.patch
index 71a8ebae7..9418e1c2b 100644
--- a/utils/irqbalance/patches/010-meson.patch
+++ b/utils/irqbalance/patches/010-meson.patch
@@ -5,7 +5,7 @@ Subject: [PATCH] add meson
Signed-off-by: Rosen Penev <rosenp@gmail.com>
-[update version string to 1.9.3]
+[update version string to 1.9.4]
---
meson.build | 43 +++++++++++++++++++++++++++++++++++++++++++
@@ -18,7 +18,7 @@ Signed-off-by: Rosen Penev <rosenp@gmail.com>
+++ b/meson.build
@@ -0,0 +1,43 @@
+project('irqbalance', 'c',
-+ version : '1.9.3',
++ version : '1.9.4',
+ default_options : ['warning_level=1']
+)
+
diff --git a/utils/irqbalance/patches/020-mark-EINVAL-error-permanent.patch b/utils/irqbalance/patches/020-mark-EINVAL-error-permanent.patch
deleted file mode 100644
index 44eb15dc0..000000000
--- a/utils/irqbalance/patches/020-mark-EINVAL-error-permanent.patch
+++ /dev/null
@@ -1,15 +0,0 @@
---- a/activate.c
-+++ b/activate.c
-@@ -98,11 +98,11 @@ error:
- case ENOSPC: /* Specified CPU APIC is full. */
- case EAGAIN: /* Interrupted by signal. */
- case EBUSY: /* Affinity change already in progress. */
-- case EINVAL: /* IRQ would be bound to no CPU. */
- case ERANGE: /* CPU in mask is offline. */
- case ENOMEM: /* Kernel cannot allocate CPU mask. */
- /* Do not blacklist the IRQ on transient errors. */
- break;
-+ case EINVAL: /* IRQ would be bound to no CPU. */
- default:
- /* Any other error is considered permanent. */
- info->flags |= IRQ_FLAG_AFFINITY_UNMANAGED;