aboutsummaryrefslogtreecommitdiff
path: root/utils
diff options
context:
space:
mode:
authorkrant <aleksey.vasilenko@gmail.com>2024-02-23 11:19:45 +0200
committerRosen Penev <rosenp@gmail.com>2024-02-24 12:09:54 -0800
commita58ce16a026b19655760531268a38f83c580620a (patch)
treef2433452ed4aa4d7243ccb26eb2306c0db7cf36a /utils
parentc1b4e80825d6855d66899dc32490b0ce9537aff5 (diff)
avrdude: fix dependencies
- libftdi, libhidapi, libusb-0.1 was incorrectly leaking into the build. - libgpiod was incorrectly missing out despite LINUXGPIO feature was explicitly requested. Signed-off-by: krant <aleksey.vasilenko@gmail.com>
Diffstat (limited to 'utils')
-rw-r--r--utils/avrdude/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/utils/avrdude/Makefile b/utils/avrdude/Makefile
index 77d7ded11..037bbb861 100644
--- a/utils/avrdude/Makefile
+++ b/utils/avrdude/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=avrdude
PKG_VERSION:=7.3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://github.com/avrdudes/avrdude
@@ -29,7 +29,7 @@ define Package/avrdude
SUBMENU:=Microcontroller programming
TITLE:=AVR Downloader/UploaDEr
URL:=https://github.com/avrdudes/avrdude
- DEPENDS:=+libncurses +libreadline +libusb-1.0 +libftdi1 +libelf
+ DEPENDS:=+libncurses +libreadline +libusb-1.0 +libftdi1 +libelf +libgpiod
endef
define Package/avrdude/description
@@ -37,6 +37,10 @@ define Package/avrdude/description
endef
CMAKE_OPTIONS += \
+ -DHAVE_LIBUSB=OFF \
+ -DHAVE_LIBFTDI=OFF \
+ -DHAVE_LIBHIDAPI=OFF \
+ -DHAVE_LIBSERIALPORT=OFF \
-DHAVE_LINUXGPIO=ON
define Package/avrdude/conffiles