aboutsummaryrefslogtreecommitdiff
path: root/utils
diff options
context:
space:
mode:
authorkrant <aleksey.vasilenko@gmail.com>2024-02-21 17:27:04 +0200
committerRosen Penev <rosenp@gmail.com>2024-02-21 22:00:35 -0800
commit7fbb810af3c1aeb475bc5893d0b6b25bb9435e77 (patch)
tree578dba59cb1c8e56bcbd979b01dbdfee2f3961c0 /utils
parent365ab3cfcd93b92fee2136976d938f9c848d0c9d (diff)
sysstat: update to 12.7.5
- Update package URLs - Add missing xz dependency - Fix incorrectly set sa_dir - Refresh the patch Signed-off-by: krant <aleksey.vasilenko@gmail.com>
Diffstat (limited to 'utils')
-rw-r--r--utils/sysstat/Makefile11
-rw-r--r--utils/sysstat/files/sysstat.config1
-rwxr-xr-xutils/sysstat/files/sysstat.init2
-rw-r--r--utils/sysstat/patches/010-ldflags.patch32
4 files changed, 23 insertions, 23 deletions
diff --git a/utils/sysstat/Makefile b/utils/sysstat/Makefile
index 3625f5410..d2f454da8 100644
--- a/utils/sysstat/Makefile
+++ b/utils/sysstat/Makefile
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=sysstat
-PKG_VERSION:=12.4.5
+PKG_VERSION:=12.7.5
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
-PKG_SOURCE_URL:=http://pagesperso-orange.fr/sebastien.godard/
-PKG_HASH:=ef445acea301bbb996e410842f6290a8d049e884d4868cfef7e85dc04b7eee5b
+PKG_SOURCE_URL:=https://sysstat.github.io/sysstat-packages
+PKG_HASH:=57664040a549d33bb06a1121c7124d4cadd9b8b35f815856c194393047cd4d6b
PKG_MAINTAINER:=Marko Ratkaj <markoratkaj@gmail.com>
PKG_LICENSE:=GPL-2.0-or-later
@@ -31,8 +31,8 @@ define Package/sysstat
SECTION:=utils
CATEGORY:=Utilities
TITLE:=Sysstat performance monitoring tools
- URL:=http://pagesperso-orange.fr/sebastien.godard/index.html
- DEPENDS:=$(INTL_DEPENDS)
+ URL:=https://sysstat.github.io/
+ DEPENDS:=$(INTL_DEPENDS) +xz
endef
define Package/sysstat/description
@@ -48,6 +48,7 @@ endef
CONFIGURE_VARS+= \
sa_lib_dir="/usr/lib/sysstat" \
+ sa_dir="/var/log/sysstat" \
conf_dir="/etc/sysstat"
CONFIGURE_ARGS+= \
diff --git a/utils/sysstat/files/sysstat.config b/utils/sysstat/files/sysstat.config
index 638b3798c..5193460dd 100644
--- a/utils/sysstat/files/sysstat.config
+++ b/utils/sysstat/files/sysstat.config
@@ -2,6 +2,5 @@ config sysstat 'sysstat'
option log_history '7'
option compressafter '10'
option sadc_options ''
- option sa_dir '/var/log/sysstat'
option zip 'xz'
option enabled 'true'
diff --git a/utils/sysstat/files/sysstat.init b/utils/sysstat/files/sysstat.init
index e7b75e246..6e6b092c6 100755
--- a/utils/sysstat/files/sysstat.init
+++ b/utils/sysstat/files/sysstat.init
@@ -13,7 +13,6 @@ validate_sysstat_section() {
'log_history:uinteger' \
'compressafter:uinteger' \
'sadc_options:string' \
- 'sa_dir:string' \
'zip:string' \
'enabled:string'
}
@@ -30,7 +29,6 @@ start_sysstat_instance() {
echo "HISTORY=$log_history"
echo "COMPRESSAFTER=$compressafter"
echo "SADC_OPTIONS=\"$sadc_options\""
- echo "SA_DIR=\"$sa_dir\""
echo "ZIP=\"$zip\""
echo "ENABLED=\"$enabled\""
} > $SYSSTAT_CFG
diff --git a/utils/sysstat/patches/010-ldflags.patch b/utils/sysstat/patches/010-ldflags.patch
index 654071195..05f76bf45 100644
--- a/utils/sysstat/patches/010-ldflags.patch
+++ b/utils/sysstat/patches/010-ldflags.patch
@@ -1,24 +1,26 @@
--- a/Makefile.in
+++ b/Makefile.in
-@@ -80,7 +80,7 @@ SYSCONFIG_FILE = @SYSCONFIG_FILE@
- # Compiler flags
- CFLAGS = @CFLAGS@ -Wall -Wstrict-prototypes -pipe -O2
- DFLAGS = @DFLAGS@
--LFLAGS = @STRIP@
-+LDFLAGS += @STRIP@
- DFLAGS += -DSA_DIR=\"$(SA_DIR)\" -DSADC_PATH=\"$(SADC_PATH)\"
- DFLAGS += $(DFSENSORS)
- DFLAGS += $(DFPCP)
-@@ -120,7 +120,7 @@ ifeq ($(SYSPARAM),y)
- DFLAGS += -DHAVE_SYS_PARAM_H
+@@ -109,9 +109,7 @@ ifdef TFLAGS
+ DFLAGS += $(TFLAGS)
endif
+
+-ifndef LFLAGS
+-LFLAGS = @STRIP@ @LDFLAGS@
+-endif
++LDFLAGS += @STRIP@
+
+ # Commands
+ ifndef MSGFMT
+@@ -152,7 +150,7 @@ endif
+ ifndef NLS
NLS = @NLS@
+ endif
-LFLAGS += @LFINTL@
+LDFLAGS += @LFINTL@
ifeq ($(NLS),y)
REQUIRE_NLS = -DUSE_NLS -DPACKAGE=\"$(PACKAGE)\" -DLOCALEDIR=\"$(NLS_DIR)\"
endif
-@@ -198,7 +198,7 @@ NLSPOT= $(NLSPO:.po=.pot)
+@@ -248,7 +246,7 @@ NLSPOT= $(NLSPO:.po=.pot)
$(CC) -o $@ -c $(CFLAGS) $(DFLAGS) $<
% : %.o
@@ -27,16 +29,16 @@
all: sadc sar sadf iostat tapestat mpstat pidstat cifsiostat locales
-@@ -286,7 +286,7 @@ librdsensors.a: rd_sensors.o
+@@ -338,7 +336,7 @@ librdsensors.a: rd_sensors.o
sadc.o: sadc.c sa.h version.h common.h rd_stats.h rd_sensors.h
-sadc: LFLAGS += $(LFSENSORS)
+sadc: LDFLAGS += $(LFSENSORS)
- sadc: sadc.o act_sadc.o sa_wrap.o sa_common_sadc.o common_sadc.o systest.o librdstats.a librdsensors.a
+ sadc: sadc.o act_sadc.o sa_wrap.o sa_common_light.o common_light.o systest.o librdstats.a librdsensors.a libsyscom.a
-@@ -296,7 +296,7 @@ sar: sar.o act_sar.o format_sar.o sa_com
+@@ -348,7 +346,7 @@ sar: sar.o act_sar.o format_sar.o sa_com
sadf.o: sadf.c sadf.h version.h sa.h common.h rd_stats.h rd_sensors.h