aboutsummaryrefslogtreecommitdiff
path: root/utils
diff options
context:
space:
mode:
authorkrant <aleksey.vasilenko@gmail.com>2024-02-22 08:32:26 +0200
committerRosen Penev <rosenp@gmail.com>2024-02-22 10:49:41 -0800
commit65955c3b1e38dca76bec4864430e1abadc20dae6 (patch)
treeddbcd93d991b627e4d6cca820a3a6dcb0f492ede /utils
parent0e7554cbf4f3e81ca8ea2536f46815547444e49b (diff)
bluez: update to 5.72
- Use HTTPS for URL - Don't set default configure option - Refresh the patches Signed-off-by: krant <aleksey.vasilenko@gmail.com>
Diffstat (limited to 'utils')
-rw-r--r--utils/bluez/Makefile7
-rw-r--r--utils/bluez/patches/201-readline.patch127
-rw-r--r--utils/bluez/patches/202-fix-endianness.patch4
-rw-r--r--utils/bluez/patches/205-refresh_adv_manager_for_non-LE_devices.patch2
-rw-r--r--utils/bluez/patches/210-util-define-MAX_INPUT.patch2
5 files changed, 70 insertions, 72 deletions
diff --git a/utils/bluez/Makefile b/utils/bluez/Makefile
index bee4e79a9..e1299edda 100644
--- a/utils/bluez/Makefile
+++ b/utils/bluez/Makefile
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=bluez
-PKG_VERSION:=5.66
+PKG_VERSION:=5.72
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@KERNEL/linux/bluetooth/
-PKG_HASH:=39fea64b590c9492984a0c27a89fc203e1cdc74866086efb8f4698677ab2b574
+PKG_HASH:=499d7fa345a996c1bb650f5c6749e1d929111fa6ece0be0e98687fee6124536e
PKG_LICENSE:=GPL-2.0-or-later
PKG_LICENSE_FILES:=COPYING
@@ -29,7 +29,7 @@ include $(INCLUDE_DIR)/nls.mk
define Package/bluez/Default
TITLE:=Bluetooth
- URL:=http://www.bluez.org/
+ URL:=https://www.bluez.org/
endef
define Package/bluez-libs
@@ -84,7 +84,6 @@ TARGET_CFLAGS += -D_GNU_SOURCE
CONFIGURE_ARGS += \
--enable-static \
- --enable-shared \
--enable-client \
--enable-datafiles \
--enable-experimental \
diff --git a/utils/bluez/patches/201-readline.patch b/utils/bluez/patches/201-readline.patch
index e58b504b3..7f6051abc 100644
--- a/utils/bluez/patches/201-readline.patch
+++ b/utils/bluez/patches/201-readline.patch
@@ -1,75 +1,74 @@
---- a/Makefile.in
-+++ b/Makefile.in
-@@ -3598,7 +3598,7 @@ unit_tests = $(am__append_62) unit/test-
- @CLIENT_TRUE@ client/player.h client/player.c
+--- a/Makefile.tools
++++ b/Makefile.tools
+@@ -16,7 +16,7 @@ client_bluetoothctl_SOURCES = client/mai
+ client/mgmt.h client/mgmt.c
+ client_bluetoothctl_LDADD = lib/libbluetooth-internal.la \
+ gdbus/libgdbus-internal.la src/libshared-glib.la \
+- $(GLIB_LIBS) $(DBUS_LIBS) -lreadline
++ $(GLIB_LIBS) $(DBUS_LIBS) -lreadline -lncurses
+ endif
- @CLIENT_TRUE@client_bluetoothctl_LDADD = gdbus/libgdbus-internal.la src/libshared-glib.la \
--@CLIENT_TRUE@ $(GLIB_LIBS) $(DBUS_LIBS) -lreadline
-+@CLIENT_TRUE@ $(GLIB_LIBS) $(DBUS_LIBS) -lreadline -lncurses
+ if ZSH_COMPLETIONS
+@@ -382,7 +382,7 @@ tools_meshctl_SOURCES = tools/meshctl.c
+ tools/mesh-gatt/onoff-model.c
+ tools_meshctl_LDADD = gdbus/libgdbus-internal.la src/libshared-glib.la \
+ lib/libbluetooth-internal.la \
+- $(GLIB_LIBS) $(DBUS_LIBS) -ljson-c -lreadline
++ $(GLIB_LIBS) $(DBUS_LIBS) -ljson-c -lreadline -lncurses
- @ZSH_COMPLETIONS_TRUE@zshcompletiondir = $(ZSH_COMPLETIONDIR)
- @ZSH_COMPLETIONS_TRUE@dist_zshcompletion_DATA = completion/zsh/_bluetoothctl
-@@ -3877,7 +3877,7 @@ unit_tests = $(am__append_62) unit/test-
+ EXTRA_DIST += tools/mesh-gatt/local_node.json tools/mesh-gatt/prov_db.json
+ endif
+@@ -401,7 +401,7 @@ tools_mesh_cfgclient_SOURCES = tools/mes
+ mesh/crypto.h mesh/crypto.c
- @DEPRECATED_TRUE@@MESH_TRUE@@TOOLS_TRUE@tools_meshctl_LDADD = gdbus/libgdbus-internal.la src/libshared-glib.la \
- @DEPRECATED_TRUE@@MESH_TRUE@@TOOLS_TRUE@ lib/libbluetooth-internal.la \
--@DEPRECATED_TRUE@@MESH_TRUE@@TOOLS_TRUE@ $(GLIB_LIBS) $(DBUS_LIBS) -ljson-c -lreadline
-+@DEPRECATED_TRUE@@MESH_TRUE@@TOOLS_TRUE@ $(GLIB_LIBS) $(DBUS_LIBS) -ljson-c -lreadline -lncurses
+ tools_mesh_cfgclient_LDADD = lib/libbluetooth-internal.la src/libshared-ell.la \
+- $(ell_ldadd) -ljson-c -lreadline
++ $(ell_ldadd) -ljson-c -lreadline -lncurses
- @MESH_TRUE@@TOOLS_TRUE@tools_mesh_cfgclient_SOURCES = tools/mesh-cfgclient.c \
- @MESH_TRUE@@TOOLS_TRUE@ tools/mesh/model.h tools/mesh/config-model.h \
-@@ -3891,7 +3891,7 @@ unit_tests = $(am__append_62) unit/test-
- @MESH_TRUE@@TOOLS_TRUE@ mesh/crypto.h mesh/crypto.c
+ bin_PROGRAMS += tools/mesh-cfgtest
- @MESH_TRUE@@TOOLS_TRUE@tools_mesh_cfgclient_LDADD = lib/libbluetooth-internal.la src/libshared-ell.la \
--@MESH_TRUE@@TOOLS_TRUE@ $(ell_ldadd) -ljson-c -lreadline
-+@MESH_TRUE@@TOOLS_TRUE@ $(ell_ldadd) -ljson-c -lreadline -lncurses
+@@ -507,7 +507,7 @@ noinst_PROGRAMS += tools/btmgmt tools/ob
+ tools_obex_client_tool_SOURCES = $(gobex_sources) $(btio_sources) \
+ tools/obex-client-tool.c
+ tools_obex_client_tool_LDADD = lib/libbluetooth-internal.la \
+- src/libshared-glib.la $(GLIB_LIBS) -lreadline
++ src/libshared-glib.la $(GLIB_LIBS) -lreadline -lncurses
- @MESH_TRUE@@TOOLS_TRUE@tools_mesh_cfgtest_SOURCES = tools/mesh-cfgtest.c
- @MESH_TRUE@@TOOLS_TRUE@tools_mesh_cfgtest_LDADD = lib/libbluetooth-internal.la src/libshared-ell.la \
-@@ -3948,7 +3948,7 @@ unit_tests = $(am__append_62) unit/test-
- @READLINE_TRUE@ tools/obex-client-tool.c
+ tools_obex_server_tool_SOURCES = $(gobex_sources) $(btio_sources) \
+ tools/obex-server-tool.c
+@@ -518,16 +518,16 @@ tools_bluetooth_player_SOURCES = tools/b
+ client/player.c
+ tools_bluetooth_player_LDADD = gdbus/libgdbus-internal.la \
+ src/libshared-glib.la \
+- $(GLIB_LIBS) $(DBUS_LIBS) -lreadline
++ $(GLIB_LIBS) $(DBUS_LIBS) -lreadline -lncurses
- @READLINE_TRUE@tools_obex_client_tool_LDADD = lib/libbluetooth-internal.la \
--@READLINE_TRUE@ src/libshared-glib.la $(GLIB_LIBS) -lreadline
-+@READLINE_TRUE@ src/libshared-glib.la $(GLIB_LIBS) -lreadline -lncurses
+ tools_obexctl_SOURCES = tools/obexctl.c
+ tools_obexctl_LDADD = gdbus/libgdbus-internal.la src/libshared-glib.la \
+- $(GLIB_LIBS) $(DBUS_LIBS) -lreadline
++ $(GLIB_LIBS) $(DBUS_LIBS) -lreadline -lncurses
- @READLINE_TRUE@tools_obex_server_tool_SOURCES = $(gobex_sources) $(btio_sources) \
- @READLINE_TRUE@ tools/obex-server-tool.c
-@@ -3959,15 +3959,15 @@ unit_tests = $(am__append_62) unit/test-
- @READLINE_TRUE@tools_bluetooth_player_SOURCES = tools/bluetooth-player.c client/player.c
- @READLINE_TRUE@tools_bluetooth_player_LDADD = gdbus/libgdbus-internal.la \
- @READLINE_TRUE@ src/libshared-glib.la \
--@READLINE_TRUE@ $(GLIB_LIBS) $(DBUS_LIBS) -lreadline
-+@READLINE_TRUE@ $(GLIB_LIBS) $(DBUS_LIBS) -lreadline -lncurses
+ tools_btmgmt_SOURCES = tools/btmgmt.c src/uuid-helper.c client/display.c \
+ client/mgmt.c
+ tools_btmgmt_LDADD = lib/libbluetooth-internal.la src/libshared-mainloop.la \
+- -lreadline
++ -lreadline -lncurses
+ if DEPRECATED
+ noinst_PROGRAMS += attrib/gatttool
- @READLINE_TRUE@tools_obexctl_SOURCES = tools/obexctl.c
- @READLINE_TRUE@tools_obexctl_LDADD = gdbus/libgdbus-internal.la src/libshared-glib.la \
--@READLINE_TRUE@ $(GLIB_LIBS) $(DBUS_LIBS) -lreadline
-+@READLINE_TRUE@ $(GLIB_LIBS) $(DBUS_LIBS) -lreadline -lncurses
+@@ -537,7 +537,7 @@ attrib_gatttool_SOURCES = attrib/gatttoo
+ attrib/utils.c src/log.c client/display.c \
+ client/display.h
+ attrib_gatttool_LDADD = lib/libbluetooth-internal.la \
+- src/libshared-glib.la $(GLIB_LIBS) -lreadline
++ src/libshared-glib.la $(GLIB_LIBS) -lreadline -lncurses
- @READLINE_TRUE@tools_btmgmt_SOURCES = tools/btmgmt.c src/uuid-helper.c client/display.c
- @READLINE_TRUE@tools_btmgmt_LDADD = lib/libbluetooth-internal.la src/libshared-mainloop.la \
--@READLINE_TRUE@ -lreadline
-+@READLINE_TRUE@ -lreadline -lncurses
+ endif
+ endif
+@@ -583,5 +583,5 @@ tools/btpclient.$(OBJEXT): src/libshared
- @DEPRECATED_TRUE@@READLINE_TRUE@attrib_gatttool_SOURCES = attrib/gatttool.c attrib/att.c attrib/gatt.c \
- @DEPRECATED_TRUE@@READLINE_TRUE@ attrib/gattrib.c btio/btio.c \
-@@ -3976,7 +3976,7 @@ unit_tests = $(am__append_62) unit/test-
- @DEPRECATED_TRUE@@READLINE_TRUE@ client/display.h
-
- @DEPRECATED_TRUE@@READLINE_TRUE@attrib_gatttool_LDADD = lib/libbluetooth-internal.la \
--@DEPRECATED_TRUE@@READLINE_TRUE@ src/libshared-glib.la $(GLIB_LIBS) -lreadline
-+@DEPRECATED_TRUE@@READLINE_TRUE@ src/libshared-glib.la $(GLIB_LIBS) -lreadline -lncurses
-
- @CUPS_TRUE@cupsdir = $(libdir)/cups/backend
- @CUPS_TRUE@profiles_cups_bluetooth_SOURCES = profiles/cups/main.c \
-@@ -3996,7 +3996,7 @@ unit_tests = $(am__append_62) unit/test-
- @BTPCLIENT_TRUE@tools_btpclient_DEPENDENCIES = lib/libbluetooth-internal.la $(ell_dependencies)
- @BTPCLIENT_TRUE@tools_btpclientctl_SOURCES = tools/btpclientctl.c client/display.c
- @BTPCLIENT_TRUE@tools_btpclientctl_LDADD = src/libshared-mainloop.la src/libshared-glib.la \
--@BTPCLIENT_TRUE@ lib/libbluetooth-internal.la -lreadline
-+@BTPCLIENT_TRUE@ lib/libbluetooth-internal.la -lreadline -lncurses
-
-
- # SPDX-License-Identifier: GPL-2.0
+ tools_btpclientctl_SOURCES = tools/btpclientctl.c client/display.c
+ tools_btpclientctl_LDADD = src/libshared-mainloop.la src/libshared-glib.la \
+- lib/libbluetooth-internal.la -lreadline
++ lib/libbluetooth-internal.la -lreadline -lncurses
+ endif
diff --git a/utils/bluez/patches/202-fix-endianness.patch b/utils/bluez/patches/202-fix-endianness.patch
index c0086cc28..30876e321 100644
--- a/utils/bluez/patches/202-fix-endianness.patch
+++ b/utils/bluez/patches/202-fix-endianness.patch
@@ -1,9 +1,9 @@
--- a/src/shared/util.h
+++ b/src/shared/util.h
-@@ -15,6 +15,7 @@
- #include <byteswap.h>
+@@ -18,6 +18,7 @@
#include <string.h>
#include <sys/types.h>
+ #include <sys/uio.h>
+#include <endian.h>
#define ARRAY_SIZE(arr) (sizeof(arr) / sizeof((arr)[0]))
diff --git a/utils/bluez/patches/205-refresh_adv_manager_for_non-LE_devices.patch b/utils/bluez/patches/205-refresh_adv_manager_for_non-LE_devices.patch
index b79667bb0..18fb44f73 100644
--- a/utils/bluez/patches/205-refresh_adv_manager_for_non-LE_devices.patch
+++ b/utils/bluez/patches/205-refresh_adv_manager_for_non-LE_devices.patch
@@ -34,7 +34,7 @@ This commit prevents the call to btd_adv_manager_refresh for non-LE devices.
--- a/src/adapter.c
+++ b/src/adapter.c
-@@ -634,7 +634,9 @@ static void settings_changed(struct btd_
+@@ -643,7 +643,9 @@ static void settings_changed(struct btd_
*/
if (!adapter->discovery_discoverable)
store_adapter_info(adapter);
diff --git a/utils/bluez/patches/210-util-define-MAX_INPUT.patch b/utils/bluez/patches/210-util-define-MAX_INPUT.patch
index e2af0bf65..492e5a424 100644
--- a/utils/bluez/patches/210-util-define-MAX_INPUT.patch
+++ b/utils/bluez/patches/210-util-define-MAX_INPUT.patch
@@ -1,6 +1,6 @@
--- a/src/shared/util.c
+++ b/src/shared/util.c
-@@ -23,6 +23,9 @@
+@@ -24,6 +24,9 @@
#include <dirent.h>
#include <limits.h>
#include <string.h>