aboutsummaryrefslogtreecommitdiff
path: root/utils
diff options
context:
space:
mode:
authorkrant <aleksey.vasilenko@gmail.com>2024-02-12 01:23:25 +0200
committerRosen Penev <rosenp@gmail.com>2024-02-22 16:03:28 -0800
commit46ed5094692d4da54cdea3db6b7fa78d8044781a (patch)
treec1ace25d8212e818686f3fda1388df645d7230d3 /utils
parent61ba390b651f9b563073d6995b863d99830a86ac (diff)
screen: update to 4.9.1
- Remove upstreamed patch Signed-off-by: krant <aleksey.vasilenko@gmail.com>
Diffstat (limited to 'utils')
-rw-r--r--utils/screen/Makefile6
-rw-r--r--utils/screen/patches/001-CVE-2021-26937.patch64
2 files changed, 3 insertions, 67 deletions
diff --git a/utils/screen/Makefile b/utils/screen/Makefile
index 26a707c5d..d28b69fa7 100644
--- a/utils/screen/Makefile
+++ b/utils/screen/Makefile
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=screen
-PKG_VERSION:=4.8.0
-PKG_RELEASE:=2
+PKG_VERSION:=4.9.1
+PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@GNU/screen
-PKG_HASH:=6e11b13d8489925fde25dfb0935bf6ed71f9eb47eff233a181e078fde5655aa1
+PKG_HASH:=26cef3e3c42571c0d484ad6faf110c5c15091fbf872b06fa7aa4766c7405ac69
PKG_MAINTAINER:=Etienne CHAMPETIER <champetier.etienne@gmail.com>
PKG_LICENSE:=GPL-3.0-or-later
diff --git a/utils/screen/patches/001-CVE-2021-26937.patch b/utils/screen/patches/001-CVE-2021-26937.patch
deleted file mode 100644
index 3bc04cb8c..000000000
--- a/utils/screen/patches/001-CVE-2021-26937.patch
+++ /dev/null
@@ -1,64 +0,0 @@
-Description: [CVE-2021-26937] Fix out of bounds array access
-Author: Michael Schröder <mls@suse.de>
-Bug-Debian: https://bugs.debian.org/982435
-Bug: https://savannah.gnu.org/bugs/?60030
-Bug: https://lists.gnu.org/archive/html/screen-devel/2021-02/msg00000.html
-Bug-OSS-Security: https://www.openwall.com/lists/oss-security/2021/02/09/3
-Origin: https://lists.gnu.org/archive/html/screen-devel/2021-02/msg00010.html
-
---- a/encoding.c
-+++ b/encoding.c
-@@ -43,7 +43,7 @@ static int encmatch __P((char *, char *
- # ifdef UTF8
- static int recode_char __P((int, int, int));
- static int recode_char_to_encoding __P((int, int));
--static void comb_tofront __P((int, int));
-+static void comb_tofront __P((int));
- # ifdef DW_CHARS
- static int recode_char_dw __P((int, int *, int, int));
- static int recode_char_dw_to_encoding __P((int, int *, int));
-@@ -1263,6 +1263,8 @@ int c;
- {0x30000, 0x3FFFD},
- };
-
-+ if (c >= 0xdf00 && c <= 0xdfff)
-+ return 1; /* dw combining sequence */
- return ((bisearch(c, wide, sizeof(wide) / sizeof(struct interval) - 1)) ||
- (cjkwidth &&
- bisearch(c, ambiguous,
-@@ -1330,11 +1332,12 @@ int c;
- }
-
- static void
--comb_tofront(root, i)
--int root, i;
-+comb_tofront(i)
-+int i;
- {
- for (;;)
- {
-+ int root = i >= 0x700 ? 0x801 : 0x800;
- debug1("bring to front: %x\n", i);
- combchars[combchars[i]->prev]->next = combchars[i]->next;
- combchars[combchars[i]->next]->prev = combchars[i]->prev;
-@@ -1396,9 +1399,9 @@ struct mchar *mc;
- {
- /* full, recycle old entry */
- if (c1 >= 0xd800 && c1 < 0xe000)
-- comb_tofront(root, c1 - 0xd800);
-+ comb_tofront(c1 - 0xd800);
- i = combchars[root]->prev;
-- if (c1 == i + 0xd800)
-+ if (i == 0x800 || i == 0x801 || c1 == i + 0xd800)
- {
- /* completely full, can't recycle */
- debug("utf8_handle_comp: completely full!\n");
-@@ -1422,7 +1425,7 @@ struct mchar *mc;
- mc->font = (i >> 8) + 0xd8;
- mc->fontx = 0;
- debug3("combinig char %x %x -> %x\n", c1, c, i + 0xd800);
-- comb_tofront(root, i);
-+ comb_tofront(i);
- }
-
- #else /* !UTF8 */