aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorHuangbin Zhan <zhanhb88@gmail.com>2020-05-09 05:43:57 +0800
committerzhanhb <6323014+zhanhb@users.noreply.github.com>2020-05-09 06:06:43 +0800
commit0ec746ccb6e87696a7a4986d87d55cda205031f0 (patch)
treebe37c6909d1e1bb8f2f948cce1b4092841d8fa03 /net
parent0206a87146fef2b20d18187832935f63641f5c9b (diff)
treewide: add conffiles
Signed-off-by: Huangbin Zhan <zhanhb88@gmail.com>
Diffstat (limited to 'net')
-rw-r--r--net/apfree-wifidog/Makefile6
-rw-r--r--net/aria2/Makefile6
-rw-r--r--net/clamav/Makefile13
-rw-r--r--net/dawn/Makefile6
-rw-r--r--net/dcwapd/Makefile6
-rw-r--r--net/frp/Makefile10
-rw-r--r--net/https-dns-proxy/Makefile6
-rw-r--r--net/kadnode/Makefile6
-rw-r--r--net/kcptun/Makefile6
-rw-r--r--net/kismet/Makefile4
-rw-r--r--net/nextdns/Makefile6
-rw-r--r--net/nlbwmon/Makefile3
-rw-r--r--net/oor/Makefile6
-rw-r--r--net/openvswitch/Makefile3
-rw-r--r--net/port-mirroring/Makefile6
-rw-r--r--net/ser2net/Makefile3
-rw-r--r--net/shadowsocks-libev/Makefile6
-rw-r--r--net/smartsnmpd/Makefile6
-rw-r--r--net/squid/Makefile3
-rw-r--r--net/u2pnpd/Makefile6
-rw-r--r--net/wifidog-ng/Makefile12
21 files changed, 105 insertions, 24 deletions
diff --git a/net/apfree-wifidog/Makefile b/net/apfree-wifidog/Makefile
index 7778bdfef..370ba70b6 100644
--- a/net/apfree-wifidog/Makefile
+++ b/net/apfree-wifidog/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=apfree-wifidog
PKG_VERSION:=3.11.1716
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://github.com/liudf0716/apfree_wifidog.git
@@ -40,6 +40,10 @@ define Package/apfree-wifidog/description
It's enhanced wifidog
endef
+define Package/apfree-wifidog/conffiles
+/etc/config/wifidogx
+endef
+
define Package/apfree-wifidog/install
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/wifidogx $(1)/usr/bin/wifidogx
diff --git a/net/aria2/Makefile b/net/aria2/Makefile
index 06be8cf02..1573d8eef 100644
--- a/net/aria2/Makefile
+++ b/net/aria2/Makefile
@@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=aria2
PKG_VERSION:=1.35.0
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://github.com/aria2/aria2/releases/download/release-$(PKG_VERSION)/
@@ -85,6 +85,10 @@ CONFIGURE_ARGS += \
TARGET_CXXFLAGS += -ffunction-sections -fdata-sections -flto
TARGET_LDFLAGS += -Wl,--gc-sections -flto
+define Package/aria2/conffiles
+/etc/config/aria2
+endef
+
define Package/aria2/install
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/aria2c $(1)/usr/bin
diff --git a/net/clamav/Makefile b/net/clamav/Makefile
index 92c3f377a..5a4da2a3a 100644
--- a/net/clamav/Makefile
+++ b/net/clamav/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=clamav
PKG_VERSION:=0.102.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://www.clamav.net/downloads/production/
@@ -56,9 +56,6 @@ define Package/freshclam/description
Database updater for ClamAV
endef
-define Package/clamav/conffiles
-endef
-
CONFIGURE_ARGS += \
--sysconfdir=/etc/clamav/ \
--enable-milter \
@@ -89,6 +86,10 @@ CONFIGURE_VARS += $(if $(CONFIG_IPV6),have_cv_ipv6=yes)
TARGET_CXXFLAGS += -ffunction-sections -fdata-sections -fno-rtti -flto
TARGET_LDFLAGS += -Wl,--gc-sections,--as-needed $(if $(CONFIG_USE_MUSL),-lfts)
+define Package/clamav/conffiles
+/etc/config/clamav
+endef
+
define Package/clamav/install
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/clamd $(1)/usr/sbin/
@@ -113,6 +114,10 @@ define Package/clamav/install
$(CP) ./files/bytecode.cvd $(1)/usr/share/clamav/
endef
+define Package/freshclam/conffiles
+/etc/config/freshclam
+endef
+
define Package/freshclam/install
$(INSTALL_DIR) $(1)/usr/sbin
$(CP) $(PKG_INSTALL_DIR)/usr/bin/freshclam $(1)/usr/sbin/
diff --git a/net/dawn/Makefile b/net/dawn/Makefile
index 2dc87e7e4..45ff9dbd0 100644
--- a/net/dawn/Makefile
+++ b/net/dawn/Makefile
@@ -6,7 +6,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=dawn
PKG_SOURCE_DATE:=2020-04-17
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://github.com/berlin-open-wireless-lab/DAWN.git
@@ -34,6 +34,10 @@ define Package/dawn/description
This package implements a decentralized wireless daemon.
endef
+define Package/dawn/conffiles
+/etc/config/dawn
+endef
+
define Package/dawn/install
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/dawn $(1)/usr/sbin/dawn
diff --git a/net/dcwapd/Makefile b/net/dcwapd/Makefile
index 3566f50fe..6608af6c6 100644
--- a/net/dcwapd/Makefile
+++ b/net/dcwapd/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=dcwapd
PKG_VERSION:=1.1.0
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/ewsi/$(PKG_NAME)/tar.gz/v$(PKG_VERSION)?
@@ -51,6 +51,10 @@ define Build/InstallDev
$(CP) $(PKG_INSTALL_DIR)/usr/lib/* $(1)/usr/lib/
endef
+define Package/dcwapd/conffiles
+/etc/config/dcwapd
+endef
+
define Package/dcwapd/install
$(INSTALL_DIR) $(1)/bin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/$(PKG_NAME) $(1)/bin/
diff --git a/net/frp/Makefile b/net/frp/Makefile
index 9315d7faa..5a26e80b5 100644
--- a/net/frp/Makefile
+++ b/net/frp/Makefile
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=frp
PKG_VERSION:=0.32.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/fatedier/frp/tar.gz/v${PKG_VERSION}?
@@ -61,6 +61,14 @@ define Package/frp/install
$(INSTALL_BIN) ./files/$(2).init $(1)/etc/init.d/$(2)
endef
+define Package/frpc/conffiles
+/etc/config/frpc
+endef
+
+define Package/frps/conffiles
+/etc/config/frps
+endef
+
define Package/frpc/install
$(call Package/frp/install,$(1),frpc)
endef
diff --git a/net/https-dns-proxy/Makefile b/net/https-dns-proxy/Makefile
index e06ff0799..5e97fb868 100644
--- a/net/https-dns-proxy/Makefile
+++ b/net/https-dns-proxy/Makefile
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=https-dns-proxy
PKG_VERSION:=2020-04-09
-PKG_RELEASE=1
+PKG_RELEASE=2
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://github.com/aarond10/https_dns_proxy
@@ -26,6 +26,10 @@ define Package/https-dns-proxy
CONFLICTS:=https_dns_proxy
endef
+define Package/https-dns-proxy/conffiles
+/etc/config/https-dns-proxy
+endef
+
define Package/https-dns-proxy/install
$(INSTALL_DIR) $(1)/usr/sbin $(1)/etc/init.d ${1}/etc/config
$(INSTALL_BIN) $(PKG_BUILD_DIR)/https_dns_proxy $(1)/usr/sbin/https-dns-proxy
diff --git a/net/kadnode/Makefile b/net/kadnode/Makefile
index 7d9ee07ee..224654650 100644
--- a/net/kadnode/Makefile
+++ b/net/kadnode/Makefile
@@ -3,7 +3,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=kadnode
PKG_VERSION:=2.3.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_LICENSE:=MIT
@@ -76,6 +76,10 @@ MAKE_FLAGS += FEATURES="$(FEATURES)"
TARGET_CFLAGS += -ffunction-sections -fdata-sections
TARGET_LDFLAGS += -Wl,--gc-sections
+define Package/kadnode/conffiles
+/etc/config/kadnode
+endef
+
define Package/kadnode/install
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/build/kadnode $(1)/usr/bin/
diff --git a/net/kcptun/Makefile b/net/kcptun/Makefile
index d512451ea..bb938fed7 100644
--- a/net/kcptun/Makefile
+++ b/net/kcptun/Makefile
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=kcptun
PKG_VERSION:=20200103
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/xtaci/kcptun/tar.gz/v${PKG_VERSION}?
@@ -34,6 +34,10 @@ define Package/kcptun-config
DEPENDS:=$(GO_ARCH_DEPENDS)
endef
+define Package/kcptun-config/conffiles
+/etc/config/kcptun
+endef
+
define Package/kcptun-config/install
$(INSTALL_DIR) $(1)/etc/config
$(INSTALL_CONF) ./files/kcptun.config $(1)/etc/config/kcptun
diff --git a/net/kismet/Makefile b/net/kismet/Makefile
index 511ab69ae..d61e4a297 100644
--- a/net/kismet/Makefile
+++ b/net/kismet/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=kismet
PKG_VERSION:=2016-07-R1
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_LICENSE:=LGPLv2.1
PKG_CPE_ID:=cpe:/a:kismet:kismet
@@ -41,10 +41,12 @@ define Package/kismet-client/conffiles
endef
define Package/kismet-drone/conffiles
+/etc/config/kismet_drone
/etc/kismet/kismet_drone.conf
endef
define Package/kismet-server/conffiles
+/etc/config/kismet_server
/etc/kismet/kismet.conf
endef
diff --git a/net/nextdns/Makefile b/net/nextdns/Makefile
index f64df9227..2d5c709b5 100644
--- a/net/nextdns/Makefile
+++ b/net/nextdns/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=nextdns
PKG_VERSION:=1.5.7
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE_PROTO:=git
PKG_SOURCE_VERSION:=v$(PKG_VERSION)
@@ -39,6 +39,10 @@ define Package/nextdns
DEPENDS:=$(GO_ARCH_DEPENDS) +ca-bundle
endef
+define Package/nextdns/conffiles
+/etc/config/nextdns
+endef
+
define Package/nextdns/install
$(call GoPackage/Package/Install/Bin,$(PKG_INSTALL_DIR))
diff --git a/net/nlbwmon/Makefile b/net/nlbwmon/Makefile
index bab78ed2b..6c5606344 100644
--- a/net/nlbwmon/Makefile
+++ b/net/nlbwmon/Makefile
@@ -1,7 +1,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=nlbwmon
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://github.com/jow-/nlbwmon.git
@@ -41,6 +41,7 @@ define Package/nlbwmon/install
endef
define Package/nlbwmon/conffiles
+/etc/config/nlbwmon
/usr/share/nlbwmon/protocols
endef
diff --git a/net/oor/Makefile b/net/oor/Makefile
index 62c3fa5dd..581c6e66f 100644
--- a/net/oor/Makefile
+++ b/net/oor/Makefile
@@ -17,7 +17,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=oor
PKG_VERSION:=1.3.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE_URL=https://github.com/OpenOverlayRouter/oor/releases/download/$(PKG_VERSION)/
@@ -45,6 +45,10 @@ define Package/oor/description
This packet provides support for the Locator-ID Separation Protocol, VXLAN-GPE.
endef
+define Package/oor/conffiles
+/etc/config/oor
+endef
+
define Package/oor/install
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/oor/oor $(1)/usr/sbin/
diff --git a/net/openvswitch/Makefile b/net/openvswitch/Makefile
index 76ba560e2..8f14a6ae6 100644
--- a/net/openvswitch/Makefile
+++ b/net/openvswitch/Makefile
@@ -17,7 +17,7 @@ include ./openvswitch.mk
#
PKG_NAME:=openvswitch
PKG_VERSION:=$(ovs_version)
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://www.openvswitch.org/releases/
PKG_HASH:=dd5f727427e36cab22bdeae61529d8c8fccacc53d968cfa7658f7f935ddda531
@@ -220,6 +220,7 @@ define ovs_common_install
$$(LN) /usr/share/openvswitch/scripts/ovs-ctl-wrapper $$(1)/usr/bin/ovs-kmod-ctl
endef
define Package/openvswitch-common/conffiles
+/etc/config/openvswitch
/etc/openvswitch
endef
$(eval $(call OvsPackageTemplate,common))
diff --git a/net/port-mirroring/Makefile b/net/port-mirroring/Makefile
index 0dce495c3..d803137a3 100644
--- a/net/port-mirroring/Makefile
+++ b/net/port-mirroring/Makefile
@@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=port-mirroring
PKG_VERSION:=1.4.4
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/mmaraya/port-mirroring/tar.gz/v$(PKG_VERSION)?
@@ -31,6 +31,10 @@ define Package/port-mirroring
MENU:=1
endef
+define Package/port-mirroring/conffiles
+/etc/config/port-mirroring
+endef
+
define Package/port-mirroring/install
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/bin/port-mirroring $(1)/usr/sbin/
diff --git a/net/ser2net/Makefile b/net/ser2net/Makefile
index 0d5de9e9f..dffcb4ba9 100644
--- a/net/ser2net/Makefile
+++ b/net/ser2net/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=ser2net
PKG_VERSION:=3.5.1
-PKG_RELEASE:=4
+PKG_RELEASE:=5
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SF/ser2net
@@ -37,6 +37,7 @@ define Package/ser2net/description
endef
define Package/ser2net/conffiles
+/etc/config/ser2net
/etc/ser2net.conf
endef
diff --git a/net/shadowsocks-libev/Makefile b/net/shadowsocks-libev/Makefile
index 88b5bffb9..85c088550 100644
--- a/net/shadowsocks-libev/Makefile
+++ b/net/shadowsocks-libev/Makefile
@@ -14,7 +14,7 @@ include $(TOPDIR)/rules.mk
#
PKG_NAME:=shadowsocks-libev
PKG_VERSION:=3.3.4
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://github.com/shadowsocks/shadowsocks-libev/releases/download/v$(PKG_VERSION)
@@ -42,6 +42,10 @@ define Package/shadowsocks-libev-config
URL:=https://github.com/shadowsocks/shadowsocks-libev
endef
+define Package/shadowsocks-libev-config/conffiles
+/etc/config/shadowsocks-libev
+endef
+
define Package/shadowsocks-libev-config/install
$(INSTALL_DIR) $(1)/etc/config
$(INSTALL_DATA) ./files/shadowsocks-libev.config $(1)/etc/config/shadowsocks-libev
diff --git a/net/smartsnmpd/Makefile b/net/smartsnmpd/Makefile
index 369a2e34d..ed067ca42 100644
--- a/net/smartsnmpd/Makefile
+++ b/net/smartsnmpd/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=smartsnmpd
PKG_VERSION:=2015-02-22
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://github.com/credosemi/smartsnmp
@@ -58,6 +58,10 @@ define Build/Configure
)
endef
+define Package/smartsnmpd/conffiles
+/etc/config/smartsnmpd
+endef
+
define Package/smartsnmpd/install
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/bin/smartsnmpd $(1)/usr/sbin/smartsnmpd
diff --git a/net/squid/Makefile b/net/squid/Makefile
index eb7b47e95..d8f27963c 100644
--- a/net/squid/Makefile
+++ b/net/squid/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=squid
PKG_VERSION:=4.6
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=http://www3.us.squid-cache.org/Versions/v4/ \
@@ -58,6 +58,7 @@ define Package/squid/config
endef
define Package/squid/conffiles
+ /etc/config/squid
/etc/squid/squid.conf
endef
diff --git a/net/u2pnpd/Makefile b/net/u2pnpd/Makefile
index abcd87217..d0f41d47a 100644
--- a/net/u2pnpd/Makefile
+++ b/net/u2pnpd/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=u2pnpd
PKG_VERSION:=0.5
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://github.com/mhei/u2pnpd/releases/download/v$(PKG_VERSION)
@@ -40,6 +40,10 @@ define Package/u2pnpd/description
knowing the IP address.
endef
+define Package/u2pnpd/conffiles
+/etc/config/u2pnpd
+endef
+
define Package/u2pnpd/install
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/u2pnpd $(1)/usr/bin/
diff --git a/net/wifidog-ng/Makefile b/net/wifidog-ng/Makefile
index 4e6431927..1d972cb0a 100644
--- a/net/wifidog-ng/Makefile
+++ b/net/wifidog-ng/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=wifidog-ng
PKG_VERSION:=2.0.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_LICENSE:=LGPL-2.1
PKG_LICENSE_FILES:=LICENSE
@@ -71,6 +71,16 @@ define Package/wifidog-ng/default/install
$(CP) ./files/wifidog-ng $(1)/usr/lib/lua
endef
+define Package/wifidog-ng/default/conffiles
+/etc/config/wifidog-ng
+/etc/wifidog-ng
+endef
+
+Package/wifidog-ng-nossl/conffiles = $(Package/wifidog-ng/default/conffiles)
+Package/wifidog-ng-openssl/conffiles = $(Package/wifidog-ng/default/conffiles)
+Package/wifidog-ng-wolfssl/conffiles = $(Package/wifidog-ng/default/conffiles)
+Package/wifidog-ng-mbedtls/conffiles = $(Package/wifidog-ng/default/conffiles)
+
Package/wifidog-ng-nossl/install = $(Package/wifidog-ng/default/install)
Package/wifidog-ng-openssl/install = $(Package/wifidog-ng/default/install)
Package/wifidog-ng-wolfssl/install = $(Package/wifidog-ng/default/install)