aboutsummaryrefslogtreecommitdiff
path: root/net/transmission
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-10-13 16:52:40 -0700
committerRosen Penev <rosenp@gmail.com>2020-10-13 21:07:46 -0700
commit27ba7533e1b80c0776420947e1567f8af237637b (patch)
tree07ce271e3711e3cbcedb7bd913e41989defeb115 /net/transmission
parentc1cec7b134b979c706d35cce6949dfe8be06ce5b (diff)
transmission: fix mbedtls search
mbedcrypto should be searched, not mbedtls. Also, there is no pkgconfig file with mbedtls. Fixed that as well. Removed Makefile hacks. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'net/transmission')
-rw-r--r--net/transmission/Makefile5
-rw-r--r--net/transmission/patches/020-mbedcrypto.patch13
2 files changed, 14 insertions, 4 deletions
diff --git a/net/transmission/Makefile b/net/transmission/Makefile
index 220459e5b..d853d47c1 100644
--- a/net/transmission/Makefile
+++ b/net/transmission/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=transmission
PKG_VERSION:=3.00
-PKG_RELEASE:=5
+PKG_RELEASE:=6
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@GITHUB/transmission/transmission-releases/master
@@ -137,9 +137,6 @@ CONFIGURE_ARGS += \
ifeq ($(BUILD_VARIANT),mbedtls)
CONFIGURE_ARGS += --with-crypto=polarssl
- CONFIGURE_VARS += \
- MBEDTLS_CFLAGS="-I$(STAGING_DIR)/usr/include/mbedtls" \
- MBEDTLS_LIBS="-lmbedtls -lmbedcrypto"
else
CONFIGURE_ARGS += --with-crypto=openssl
endif
diff --git a/net/transmission/patches/020-mbedcrypto.patch b/net/transmission/patches/020-mbedcrypto.patch
new file mode 100644
index 000000000..da0874fe1
--- /dev/null
+++ b/net/transmission/patches/020-mbedcrypto.patch
@@ -0,0 +1,13 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -152,8 +152,8 @@ AS_IF([test "x$want_crypto" = "xauto" -o "x$want_crypto" = "xcyassl"], [
+ )
+ ])
+ AS_IF([test "x$want_crypto" = "xauto" -o "x$want_crypto" = "xpolarssl"], [
+- PKG_CHECK_MODULES(MBEDTLS, [mbedtls >= $POLARSSL_MINIMUM],
+- [want_crypto="polarssl"; CRYPTO_PKG="polarssl"; CRYPTO_CFLAGS="$MBEDTLS_CFLAGS"; CRYPTO_LIBS="$MBEDTLS_LIBS"; POLARSSL_IS_MBEDTLS=yes],
++ AC_CHECK_LIB(mbedcrypto, mbedtls_strerror,
++ [want_crypto="polarssl"; CRYPTO_PKG="polarssl"; CRYPTO_LIBS="-lmbedcrypto"; POLARSSL_IS_MBEDTLS=yes],
+ [AC_CHECK_HEADER([polarssl/version.h],
+ [AC_EGREP_CPP([version_ok], [#include <polarssl/version.h>
+ #if defined (POLARSSL_VERSION_NUMBER) && POLARSSL_VERSION_NUMBER >= $POLARSSL_MINIMUM