aboutsummaryrefslogtreecommitdiff
path: root/net/sslh
diff options
context:
space:
mode:
authorJonathan McCrohan <jmccrohan@gmail.com>2017-10-21 22:12:39 +0100
committerJonathan McCrohan <jmccrohan@gmail.com>2017-10-21 22:12:39 +0100
commit770ca2d401143837e212fea3fd087ed8e7623998 (patch)
treea0189faa4021d08de3fb4f3c2ee2066b168950d5 /net/sslh
parent10473e43d21055ed75d6b37af24d74ca4531f3b5 (diff)
sslh: simplify Makefile
Fixes bug where sslh was being linked against libconfig, but libconfig CPPFLAGS were being ignored. Signed-off-by: Jonathan McCrohan <jmccrohan@gmail.com>
Diffstat (limited to 'net/sslh')
-rw-r--r--net/sslh/Makefile15
1 files changed, 2 insertions, 13 deletions
diff --git a/net/sslh/Makefile b/net/sslh/Makefile
index 695730d52..1a4e25c92 100644
--- a/net/sslh/Makefile
+++ b/net/sslh/Makefile
@@ -34,19 +34,8 @@ define Package/sslh/conffiles
/etc/sslh.conf
endef
-define Build/Compile
- $(MAKE) -C $(PKG_BUILD_DIR) \
- CC="$(TARGET_CC)" \
- CFLAGS="$(TARGET_CFLAGS)" \
- CPPFLAGS="$(TARGET_CPPFLAGS)" \
- LDFLAGS="$(TARGET_LDFLAGS)" \
- ENABLE_REGEX=1 \
- USELIBCONFIG=1 \
- USELIBWRAP= \
- USELIBPCRE= \
- $(if $(CONFIG_USE_GLIBC),USELIBPCRE=,USELIBPCRE=1)\
- all
-endef
+MAKE_FLAGS += \
+ $(if $(CONFIG_USE_GLIBC),USELIBPCRE=,USELIBPCRE=1)
define Package/sslh/install
$(INSTALL_DIR) $(1)/usr/sbin