aboutsummaryrefslogtreecommitdiff
path: root/net/dcwapd/Makefile
diff options
context:
space:
mode:
authorCarey Sonsino <csonsino@gmail.com>2019-09-30 14:14:02 +0000
committerCarey Sonsino <csonsino@gmail.com>2019-10-09 14:53:01 +0000
commit0f00bcb16efabfea0de52b1bcabea764e3396f78 (patch)
tree68becba4871a7fb3d0622ef1a86762ff33d92389 /net/dcwapd/Makefile
parentd3012ecf08770171e02e46db38ff6e39d82ba4b5 (diff)
dcwifi: Update component versions
update package versions and hashes remove bzero patches remove uclibc++ patch refactor directory structure relocate mrmctl in menuconfig update macremapper patch Signed-off-by: Carey Sonsino <careys@edgewaterwireless.com> Signed-off-by: Carey Sonsino <csonsino@gmail.com>
Diffstat (limited to 'net/dcwapd/Makefile')
-rw-r--r--net/dcwapd/Makefile76
1 files changed, 76 insertions, 0 deletions
diff --git a/net/dcwapd/Makefile b/net/dcwapd/Makefile
new file mode 100644
index 000000000..0fe336298
--- /dev/null
+++ b/net/dcwapd/Makefile
@@ -0,0 +1,76 @@
+#
+# Copyright (C) 2019 EWSI
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=dcwapd
+PKG_VERSION:=1.1.0
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://codeload.github.com/ewsi/$(PKG_NAME)/tar.gz/v$(PKG_VERSION)?
+PKG_HASH:=58e52bf4e7526b2f26319740549dbcc6f6ab505f587815ee8731e40f7fecb625
+
+PKG_MAINTAINER:=Carey Sonsino <careys@edgewaterwireless.com>
+PKG_LICENSE:=Apache-2.0
+PKG_LICENSE_FILES:=COPYING
+
+PKG_FIXUP:=autoreconf
+PKG_INSTALL:=1
+PKG_BUILD_PARALLEL:=1
+
+include $(INCLUDE_DIR)/uclibc++.mk
+include $(INCLUDE_DIR)/package.mk
+
+define Package/dcwapd
+ SECTION:=net
+ CATEGORY:=Network
+ SUBMENU:=Routing and Redirection
+ TITLE:=Dual-Channel WiFi AP daemon
+ URL:=https://www.edgewaterwireless.com
+ DEPENDS:=$(CXX_DEPENDS) +kmod-macremapper +libdcwsocket +libdcwproto +mrmctl +libuci
+endef
+
+define Package/dcwapd/description
+Implementation of the Dual-Channel WiFi AP daemon
+endef
+
+CONFIGURE_ARGS += \
+ --enable-platform=linuxjsonstatic \
+ --enable-shared
+
+TARGET_CXXFLAGS += -std=c++11 -DRAPIDJSON_HAS_CXX11_RVALUE_REFS=0 -ffunction-sections -fdata-sections -flto
+TARGET_LDFLAGS += -ldcwproto -ldcwsocket -lmrmfilterparser -luci -Wl,--gc-sections,--as-needed
+
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/* $(1)/usr/lib/
+endef
+
+define Package/dcwapd/install
+ $(INSTALL_DIR) $(1)/bin
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/$(PKG_NAME) $(1)/bin/
+ $(INSTALL_DIR) $(1)/usr/lib
+ # Note: $(INSTALL_BIN) does not keep symlinks, so use $(CP)
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/*.so* $(1)/usr/lib/
+
+# Utility files
+ $(INSTALL_DIR) $(1)/etc/$(PKG_NAME)
+ $(INSTALL_DATA) ./files/*.inc $(1)/etc/$(PKG_NAME)/
+ $(INSTALL_BIN) ./files/*.sh $(1)/etc/$(PKG_NAME)/
+# UCI config file copy - this is here for convenience and reference only
+ $(INSTALL_DATA) ./files/dcwapd.uci $(1)/etc/$(PKG_NAME)/
+
+# UCI config file
+ $(INSTALL_DIR) $(1)/etc/config
+ $(INSTALL_DATA) ./files/dcwapd.uci $(1)/etc/config/dcwapd
+
+# Init script
+ $(INSTALL_DIR) $(1)/etc/init.d
+ $(INSTALL_BIN) ./files/dcwapd.init.d $(1)/etc/init.d/dcwapd
+endef
+$(eval $(call BuildPackage,dcwapd))