aboutsummaryrefslogtreecommitdiff
path: root/net/clamav/Makefile
diff options
context:
space:
mode:
authorMarko Ratkaj <marko.ratkaj@sartura.hr>2017-10-18 12:38:18 +0200
committerMarko Ratkaj <marko.ratkaj@sartura.hr>2017-10-18 17:21:40 +0200
commitce66ecde24a81150f9bd11bfa5e0e330710ad896 (patch)
treec9f1cab6f248f18b9c52a011a16fe64db0459a27 /net/clamav/Makefile
parentddc98ba6f605a8fd190dd256c15bf21a59a9e57e (diff)
clamav: fix invalid zlib version error
ClamAV's configure script uses grep to check for bugy zlib version 1.2.1. Since current OpenWrt zlib version is 1.2.11 this check passes and build fails. This patch will disable this unneeded check and make sure we are looking for zlib on the right location. clamdtop was beeing built without it's ncurses dependency. Build system would link it to the host's ncurses making the program fail at run time. This patch will disable building of optional clamdtop, otherwise we need to add ncurses as a dependency and fix the search path. Increase PKG_RELEASE to reflect changes. Signed-off-by: Marko Ratkaj <marko.ratkaj@sartura.hr>
Diffstat (limited to 'net/clamav/Makefile')
-rw-r--r--net/clamav/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/net/clamav/Makefile b/net/clamav/Makefile
index 3cc1dfcf7..b4a9abc88 100644
--- a/net/clamav/Makefile
+++ b/net/clamav/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=clamav
PKG_VERSION:=0.99.2
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_LICENSE:=GPL-2.0
PKG_MAINTAINER:=Marko Ratkaj <marko.ratkaj@sartura.hr> \
@@ -72,6 +72,9 @@ define Build/Configure
--with-group nogroup \
--with-pcre="$(STAGING_DIR)/usr/" \
--with-openssl="$(STAGING_DIR)/usr/" \
+ --with-zlib="$(STAGING_DIR)/usr/" \
+ --disable-zlib-vcheck \
+ --disable-clamdtop \
)
endef