aboutsummaryrefslogtreecommitdiff
path: root/net/clamav/Makefile
diff options
context:
space:
mode:
authorHuangbin Zhan <zhanhb88@gmail.com>2020-05-09 05:43:57 +0800
committerzhanhb <6323014+zhanhb@users.noreply.github.com>2020-05-09 06:06:43 +0800
commit0ec746ccb6e87696a7a4986d87d55cda205031f0 (patch)
treebe37c6909d1e1bb8f2f948cce1b4092841d8fa03 /net/clamav/Makefile
parent0206a87146fef2b20d18187832935f63641f5c9b (diff)
treewide: add conffiles
Signed-off-by: Huangbin Zhan <zhanhb88@gmail.com>
Diffstat (limited to 'net/clamav/Makefile')
-rw-r--r--net/clamav/Makefile13
1 files changed, 9 insertions, 4 deletions
diff --git a/net/clamav/Makefile b/net/clamav/Makefile
index 92c3f377a..5a4da2a3a 100644
--- a/net/clamav/Makefile
+++ b/net/clamav/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=clamav
PKG_VERSION:=0.102.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://www.clamav.net/downloads/production/
@@ -56,9 +56,6 @@ define Package/freshclam/description
Database updater for ClamAV
endef
-define Package/clamav/conffiles
-endef
-
CONFIGURE_ARGS += \
--sysconfdir=/etc/clamav/ \
--enable-milter \
@@ -89,6 +86,10 @@ CONFIGURE_VARS += $(if $(CONFIG_IPV6),have_cv_ipv6=yes)
TARGET_CXXFLAGS += -ffunction-sections -fdata-sections -fno-rtti -flto
TARGET_LDFLAGS += -Wl,--gc-sections,--as-needed $(if $(CONFIG_USE_MUSL),-lfts)
+define Package/clamav/conffiles
+/etc/config/clamav
+endef
+
define Package/clamav/install
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/clamd $(1)/usr/sbin/
@@ -113,6 +114,10 @@ define Package/clamav/install
$(CP) ./files/bytecode.cvd $(1)/usr/share/clamav/
endef
+define Package/freshclam/conffiles
+/etc/config/freshclam
+endef
+
define Package/freshclam/install
$(INSTALL_DIR) $(1)/usr/sbin
$(CP) $(PKG_INSTALL_DIR)/usr/bin/freshclam $(1)/usr/sbin/