aboutsummaryrefslogtreecommitdiff
path: root/net/cgi-io/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-10-01 17:34:13 +0200
committerJohn Crispin <blogic@openwrt.org>2015-10-02 14:00:25 +0200
commitfe31939c0eb6d30dfc34ee625246e00c57880856 (patch)
tree8870e31009d29e9875e0e6edd3340ceaf53c4cff /net/cgi-io/Makefile
parent6205d6d3380e8c1ee863537c2eed41c811e39d5f (diff)
cgi-io: add a small helper cgi that can be used by RPCD based UIs
Signed-off-by: John Crispin <blogic@openwrt.org>
Diffstat (limited to 'net/cgi-io/Makefile')
-rw-r--r--net/cgi-io/Makefile44
1 files changed, 44 insertions, 0 deletions
diff --git a/net/cgi-io/Makefile b/net/cgi-io/Makefile
new file mode 100644
index 000000000..c36231a12
--- /dev/null
+++ b/net/cgi-io/Makefile
@@ -0,0 +1,44 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=cgi-io
+PKG_RELEASE:=1
+
+PKG_LICENSE:=GPL-2.0+
+
+PKG_MAINTAINER:=John Crispin <blogic@openwrt.org>
+
+include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/cmake.mk
+
+define Package/cgi-io
+ SECTION:=net
+ CATEGORY:=Network
+ SUBMENU:=Web Servers/Proxies
+ DEPENDS:=+libubox +libubus
+ TITLE:=CGI utility for handling up/downloading of files
+endef
+
+define Package/cgi-io/description
+ This package contains an cgi utility that is useful for up/downloading files
+endef
+
+define Build/Prepare
+ mkdir -p $(PKG_BUILD_DIR)
+ $(CP) ./src/* $(PKG_BUILD_DIR)/
+endef
+
+define Package/cgi-io/install
+ $(INSTALL_DIR) $(1)/usr/libexec $(1)/www/cgi-bin/
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/cgi-io $(1)/usr/libexec
+ $(LN) ../../usr/libexec/cgi-io $(1)/www/cgi-bin/cgi-upload
+ $(LN) ../../usr/libexec/cgi-io $(1)/www/cgi-bin/cgi-download
+endef
+
+$(eval $(call BuildPackage,cgi-io))