aboutsummaryrefslogtreecommitdiff
path: root/net/cgi-io/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2019-09-13 06:52:21 +0200
committerJohn Crispin <john@phrozen.org>2019-09-13 13:05:09 +0200
commitc8a86c8c8e1925eb7d84c52e702c4be5fc8ac76b (patch)
tree51ab5c66dceabb2eb5d52a0f2f779ec5e0db5004 /net/cgi-io/Makefile
parenta1057cea1fb895a732a6854f79d53a763c722ef7 (diff)
cgi-io: use different acl scopes for path and command permissions
Use the `cgi-io` scope to check for permission to execute the requested command (`upload`, `backup`) and the `file` scope to check path permissions. The reasoning of this change is that `cgi-io` is usually used in conjunction with `rpcd-mod-file` to transfer large file data out of band and `rpcd-mod-file` already uses the `file` scope to manage file path access permissions. After this change, both `rpc-mod-file` and `cgi-io` can share the same path acl rules. Write access to a path can be granted by using an ubus call in the following form: ubus call session grant '{ "ubus_rpc_session": "...", "scope": "file", "objects": [ [ "/var/lib/uploads/*", "write" ] ] }' Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'net/cgi-io/Makefile')
-rw-r--r--net/cgi-io/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/net/cgi-io/Makefile b/net/cgi-io/Makefile
index 4c4725787..4b2d664af 100644
--- a/net/cgi-io/Makefile
+++ b/net/cgi-io/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=cgi-io
-PKG_RELEASE:=8
+PKG_RELEASE:=9
PKG_LICENSE:=GPL-2.0-or-later
@@ -37,7 +37,7 @@ endef
define Package/cgi-io/install
$(INSTALL_DIR) $(1)/usr/libexec $(1)/www/cgi-bin/
$(INSTALL_BIN) $(PKG_BUILD_DIR)/cgi-io $(1)/usr/libexec
- $(LN) ../../usr/libexec/cgi-io $(1)/www/cgi-bin/cgi-upload
+ $(LN) ../../usr/libexec/cgi-io $(1)/www/cgi-bin/cgi-upload
$(LN) ../../usr/libexec/cgi-io $(1)/www/cgi-bin/cgi-backup
endef