aboutsummaryrefslogtreecommitdiff
path: root/net/cgi-io/Makefile
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2020-10-11 14:54:55 +0200
committerPetr Štetiar <ynezz@true.cz>2020-10-11 14:54:55 +0200
commit08be3279423ed19554905d9cf00a508be0586107 (patch)
tree4178fff4e4b3464b9a1b909bc622bd8396a71cce /net/cgi-io/Makefile
parentcb2b03a719265cb66f4c7b846e2e4528efbbd135 (diff)
cgi-io: move into out of tree project
No functional changes, just moved the sources into out of tree project[1] so it's going to be easier to do CI with unit testing, fuzzing etc. 1. https://git.openwrt.org/?p=project/cgi-io.git;a=shortlog Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'net/cgi-io/Makefile')
-rw-r--r--net/cgi-io/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/net/cgi-io/Makefile b/net/cgi-io/Makefile
index 814a1b2f5..13c33bbac 100644
--- a/net/cgi-io/Makefile
+++ b/net/cgi-io/Makefile
@@ -10,8 +10,14 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=cgi-io
PKG_RELEASE:=19
-PKG_LICENSE:=GPL-2.0-or-later
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_URL=$(PROJECT_GIT)/project/cgi-io.git
+PKG_SOURCE_DATE:=2020-10-11
+PKG_SOURCE_VERSION:=d2907bd12986c7b582adcf0f186d97fed399963b
+PKG_MIRROR_HASH:=e4ce1aabfa91e77f562d89afb0ae0aea2e3dd2d3998069819f3412acfc4ed26b
+CMAKE_INSTALL:=1
+PKG_LICENSE:=GPL-2.0-or-later
PKG_MAINTAINER:=John Crispin <blogic@openwrt.org>
include $(INCLUDE_DIR)/package.mk
@@ -29,11 +35,6 @@ define Package/cgi-io/description
This package contains an cgi utility that is useful for up/downloading files
endef
-define Build/Prepare
- mkdir -p $(PKG_BUILD_DIR)
- $(CP) ./src/* $(PKG_BUILD_DIR)/
-endef
-
define Package/cgi-io/install
$(INSTALL_DIR) $(1)/usr/libexec $(1)/www/cgi-bin/
$(INSTALL_BIN) $(PKG_BUILD_DIR)/cgi-io $(1)/usr/libexec