aboutsummaryrefslogtreecommitdiff
path: root/libs/tiff
diff options
context:
space:
mode:
authorSebastian Kemper <sebastian_ml@gmx.net>2023-03-07 22:31:41 +0100
committerSebastian Kemper <sebastian_ml@gmx.net>2023-03-07 22:31:44 +0100
commite3c6da4e25a96eae0cf249393af8599659a04b09 (patch)
treeff80f7087ebae3628aab7b99e502580977332067 /libs/tiff
parent58fcaf8fc4d56c929a43be14fcd5c10d349502ec (diff)
tiff: force libdeflate support to off
Commit 81d2b72 added a package providing libdeflate. Tiff by default links to it, causing a build error. Package libtiff is missing dependencies for the following libraries: libdeflate.so.0 This commit forces libdeflate use off to avoid this. No revision bump is done because the package is currently not compiling anyway. Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>
Diffstat (limited to 'libs/tiff')
-rw-r--r--libs/tiff/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/libs/tiff/Makefile b/libs/tiff/Makefile
index 3b65ca7c1..39d705232 100644
--- a/libs/tiff/Makefile
+++ b/libs/tiff/Makefile
@@ -64,7 +64,8 @@ CMAKE_OPTIONS += \
-Dzstd=OFF \
-Dwebp=OFF \
-Djpeg12=OFF \
- -Dcxx=OFF
+ -Dcxx=OFF \
+ -Dlibdeflate=OFF
define Build/InstallDev
$(call Build/InstallDev/cmake,$(1))