aboutsummaryrefslogtreecommitdiff
path: root/libs/tiff
diff options
context:
space:
mode:
authorSebastian Kemper <sebastian_ml@gmx.net>2018-03-04 19:04:40 +0100
committerSebastian Kemper <sebastian_ml@gmx.net>2018-03-04 19:14:10 +0100
commit883af8a5d1577230d0b1ea9e1740c7bf8aec2c70 (patch)
treed0e9f5a57be1be972b290296161d01cb8462df1d /libs/tiff
parent153b14cbfb32a7f959b1dffd5c481640413e957c (diff)
tiff: revert uclibc++ commit
This reverts 5b5659850dbaae4d2ac2e3f599015f71e341841e. In hindsight I have to admit I did not correctly understand the implications of the uclibc++.mk include. The include allows a package to follow the user's choice regarding which C++ library should be the standard. Linking against uClibc++ instead of libstd++ is not a problem when running musl (which is what I had incorrectly assumed), as both C++ libs are separate packages. And uClibc++ is a lot smaller than libstd++, which is probably why it is even the default C++ lib on OpenWrt currently. Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>
Diffstat (limited to 'libs/tiff')
-rw-r--r--libs/tiff/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/libs/tiff/Makefile b/libs/tiff/Makefile
index b666e0a0a..1d38b7798 100644
--- a/libs/tiff/Makefile
+++ b/libs/tiff/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=tiff
PKG_VERSION:=4.0.9
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://download.osgeo.org/libtiff
@@ -25,6 +25,7 @@ PKG_INSTALL:=1
PKG_CONFIG_DEPENDS:=CONFIG_PACKAGE_libtiffxx
+include $(INCLUDE_DIR)/uclibc++.mk
include $(INCLUDE_DIR)/package.mk
define Package/tiff/Default
@@ -46,7 +47,7 @@ $(call Package/tiff/Default)
SECTION:=libs
CATEGORY:=Libraries
TITLE+= library(c++ bindings)
- DEPENDS:=+libtiff +PACKAGE_libtiffxx:libstdcpp
+ DEPENDS:=+libtiff $(CXX_DEPENDS)
endef
define Package/tiff-utils