aboutsummaryrefslogtreecommitdiff
path: root/libs/tiff
diff options
context:
space:
mode:
authorSebastian Kemper <sebastian_ml@gmx.net>2018-02-24 11:58:39 +0100
committerSebastian Kemper <sebastian_ml@gmx.net>2018-02-24 11:58:41 +0100
commit47b3a829d727b3fb261583cb5582e56ff8ad8bb3 (patch)
tree8266f76eb8db231b4ecfcb4fce6a0bea660e8ea1 /libs/tiff
parentfad60143571b60927b52c81ffdf1869b358a9077 (diff)
tiff: update install defines
- Use $(INSTALL_DATA) for headers (and really copy only the headers). - Install _all_ symlinks. Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>
Diffstat (limited to 'libs/tiff')
-rw-r--r--libs/tiff/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/libs/tiff/Makefile b/libs/tiff/Makefile
index 78d931268..f3dc94fb6 100644
--- a/libs/tiff/Makefile
+++ b/libs/tiff/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=tiff
PKG_VERSION:=4.0.9
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://download.osgeo.org/libtiff
@@ -83,17 +83,17 @@ endef
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/{lib,include}
$(CP) $(PKG_INSTALL_DIR)/usr/lib/lib* $(1)/usr/lib/
- $(CP) $(PKG_INSTALL_DIR)/usr/include/* $(1)/usr/include/
+ $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/include/*.h $(1)/usr/include/
endef
define Package/libtiff/install
$(INSTALL_DIR) $(1)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libtiff.so.* $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libtiff.so* $(1)/usr/lib/
endef
define Package/libtiffxx/install
$(INSTALL_DIR) $(1)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libtiffxx.so.* $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libtiffxx.so* $(1)/usr/lib/
endef
define Package/tiff-utils/install