aboutsummaryrefslogtreecommitdiff
path: root/libs/tiff
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2021-06-01 18:21:22 -0700
committerRosen Penev <rosenp@gmail.com>2021-06-01 23:10:37 -0700
commit2072dc396f99a6fedff0c0e3f72c5b64093675d4 (patch)
tree97dd47a42f4f580cb2fd68a393ceeff1af608b90 /libs/tiff
parentd49f59cfc5471096322c038e5b5ce043ced7339a (diff)
tiff: update to 4.2.3
Remove automake patch as it's not used. Remove ftell patch as it seems to not be needed anymore. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'libs/tiff')
-rw-r--r--libs/tiff/Makefile6
-rw-r--r--libs/tiff/patches/001-autoconf-compat.patch31
-rw-r--r--libs/tiff/patches/005-fix-ftell-macro.patch11
3 files changed, 3 insertions, 45 deletions
diff --git a/libs/tiff/Makefile b/libs/tiff/Makefile
index fbdfbb45e..ae60a5403 100644
--- a/libs/tiff/Makefile
+++ b/libs/tiff/Makefile
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=tiff
-PKG_VERSION:=4.2.0
-PKG_RELEASE:=2
+PKG_VERSION:=4.3.0
+PKG_RELEASE:=$(AUTORELEASE)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://download.osgeo.org/libtiff
-PKG_HASH:=eb0484e568ead8fa23b513e9b0041df7e327f4ee2d22db5a533929dfc19633cb
+PKG_HASH:=0e46e5acb087ce7d1ac53cf4f56a09b221537fc86dfc5daaad1c2e89e1b37ac8
PKG_MAINTAINER:=Jiri Slachta <jiri@slachta.eu>
PKG_LICENSE:=BSD-3-Clause
diff --git a/libs/tiff/patches/001-autoconf-compat.patch b/libs/tiff/patches/001-autoconf-compat.patch
deleted file mode 100644
index fd779ea1a..000000000
--- a/libs/tiff/patches/001-autoconf-compat.patch
+++ /dev/null
@@ -1,31 +0,0 @@
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -25,7 +25,7 @@
-
- docdir = $(LIBTIFF_DOCDIR)
-
--AUTOMAKE_OPTIONS = 1.12 dist-zip foreign
-+AUTOMAKE_OPTIONS = dist-zip foreign
- ACLOCAL_AMFLAGS = -I m4
-
- docfiles = \
-@@ -60,7 +60,7 @@ distcheck-hook:
- rm -rf $(distdir)/_build/cmake
- rm -rf $(distdir)/_inst/cmake
-
--SUBDIRS = port libtiff tools build contrib test man html
-+SUBDIRS = port libtiff tools build contrib
-
- release:
- (rm -f $(top_srcdir)/RELEASE-DATE && echo $(LIBTIFF_RELEASE_DATE) > $(top_srcdir)/RELEASE-DATE)
---- a/test/Makefile.am
-+++ b/test/Makefile.am
-@@ -23,7 +23,7 @@
-
- # Process this file with automake to produce Makefile.in.
-
--AUTOMAKE_OPTIONS = 1.12 color-tests parallel-tests foreign
-+AUTOMAKE_OPTIONS = color-tests parallel-tests foreign
-
- LIBTIFF = $(top_builddir)/libtiff/libtiff.la
-
diff --git a/libs/tiff/patches/005-fix-ftell-macro.patch b/libs/tiff/patches/005-fix-ftell-macro.patch
deleted file mode 100644
index d5acde92c..000000000
--- a/libs/tiff/patches/005-fix-ftell-macro.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/libtiff/tiffiop.h
-+++ b/libtiff/tiffiop.h
-@@ -302,7 +302,7 @@ struct tiff {
- */
- #if defined(HAVE_FSEEKO)
- # define fseek(stream,offset,whence) fseeko(stream,offset,whence)
--# define ftell(stream,offset,whence) ftello(stream,offset,whence)
-+# define ftell(stream) ftello(stream)
- #endif
- #endif
- #if defined(__WIN32__) && \