aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorAndy Syam <privasisource@gmail.com>2023-12-23 12:16:41 +0800
committerRosen Penev <rosenp@gmail.com>2024-01-02 15:19:40 -0800
commit8b457dfc170ada25a1b1bf67913d7aacc738660c (patch)
tree4494c034e0688701154a6df38774cbf6eaa464f2 /lang
parent81a5b89c96bab4e312c5e54debede14aaee22ba1 (diff)
python-zope-event: add python-zope-event
https://pypi.org/project/zope.event/ source code https://github.com/zopefoundation/zope.event Signed-off-by: Andy Syam <privasisource@gmail.com>
Diffstat (limited to 'lang')
-rw-r--r--lang/python/python-zope-event/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/lang/python/python-zope-event/Makefile b/lang/python/python-zope-event/Makefile
new file mode 100644
index 000000000..4b4c0fdef
--- /dev/null
+++ b/lang/python/python-zope-event/Makefile
@@ -0,0 +1,35 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-zope-event
+PKG_VERSION:=5.0
+PKG_RELEASE:=1
+
+PYPI_NAME:=zope.event
+PKG_HASH:=bac440d8d9891b4068e2b5a2c5e2c9765a9df762944bda6955f96bb9b91e67cd
+
+PKG_LICENSE:=ZPL-2.1
+PKG_LICENSE_FILES:=LICENSE.txt
+PKG_MAINTAINER:=Andy Syam <privasisource@gmail.com>
+
+include ../pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include ../python3-package.mk
+
+define Package/python3-zope-event
+ SECTION:=lang
+ CATEGORY:=Languages
+ SUBMENU:=Python
+ TITLE:=Very basic event publishing system
+ URL:=https://github.com/zopefoundation/zope.event
+ DEPENDS:=+python3-light +python3-logging
+endef
+
+define Package/python3-zope-event/description
+The zope.event package provides a simple event system, including:
+An event publishing API, intended for use by applications which are unaware of any subscribers to their events.
+A very simple synchronous event-dispatching system, on which more sophisticated event dispatching systems can be built. For example, a type-based event dispatching system that builds on zope.event can be found in zope.component.
+endef
+
+$(eval $(call Py3Package,python3-zope-event))
+$(eval $(call BuildPackage,python3-zope-event))
+$(eval $(call BuildPackage,python3-zope-event-src))