aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python-msgpack
diff options
context:
space:
mode:
authorJan Pavlinec <jan.pavlinec@nic.cz>2020-10-19 12:09:55 +0200
committerJan Pavlinec <jan.pavlinec@nic.cz>2020-10-29 11:40:26 +0100
commitb72607729ca4d0cecdb1c707b24c9fc4fcf2a251 (patch)
tree71001121f701e5a71f757bb4d8241c4674480507 /lang/python/python-msgpack
parent4ca44601e8c17cfc9dce6063fc7d990ad7eb6e93 (diff)
python-msgpack: add new package
Signed-off-by: Jan Pavlinec <jan.pavlinec@nic.cz>
Diffstat (limited to 'lang/python/python-msgpack')
-rw-r--r--lang/python/python-msgpack/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/lang/python/python-msgpack/Makefile b/lang/python/python-msgpack/Makefile
new file mode 100644
index 000000000..29d443a2d
--- /dev/null
+++ b/lang/python/python-msgpack/Makefile
@@ -0,0 +1,41 @@
+#
+# Copyright (C) 2017-2020 CZ.NIC, z. s. p. o. (https://www.nic.cz/)
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-msgpack
+PKG_VERSION:=1.0.0
+PKG_RELEASE:=1
+
+PYPI_NAME:=msgpack
+PKG_HASH:=9534d5cc480d4aff720233411a1f765be90885750b07df772380b34c10ecb5c0
+
+PKG_MAINTAINER:=Jan Pavlinec <jan.pavlinec@nic.cz>
+PKG_LICENSE:=Apache-2.0
+PKG_LICENSE_FILES:=COPYING
+
+include ../pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include ../python3-package.mk
+
+define Package/python3-msgpack
+ SUBMENU:=Python
+ SECTION:=lang
+ CATEGORY:=Languages
+ TITLE:=MessagePack (de)serializer
+ URL:=https://msgpack.org/
+ DEPENDS:=+python3-light +libstdcpp
+endef
+
+define Package/python3-msgpack/description
+ MessagePack is an efficient binary serialization format.
+ It lets you exchange data among multiple languages like JSON.
+endef
+
+$(eval $(call Py3Package,python3-msgpack))
+$(eval $(call BuildPackage,python3-msgpack))
+$(eval $(call BuildPackage,python3-msgpack-src))