aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python-automat
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2020-02-24 04:41:16 +0800
committerJeffery To <jeffery.to@gmail.com>2020-02-24 04:41:16 +0800
commit9a049b6ececea03ecea995481b732e9429b25bb3 (patch)
tree7fc2baa84bc21cf5d7defb0894ad0e60f4344e45 /lang/python/python-automat
parent9c64725f3f1a5decfcfc912e522d056a6532dead (diff)
python-automat: Update to 20.2.0, refresh patches
Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'lang/python/python-automat')
-rw-r--r--lang/python/python-automat/Makefile4
-rw-r--r--lang/python/python-automat/patches/001-do-not-use-setuptools-scm-m2r.patch2
-rw-r--r--lang/python/python-automat/patches/002-omit-visualize.patch2
-rw-r--r--lang/python/python-automat/patches/003-omit-tests.patch2
4 files changed, 5 insertions, 5 deletions
diff --git a/lang/python/python-automat/Makefile b/lang/python/python-automat/Makefile
index d9265da49..804d3c881 100644
--- a/lang/python/python-automat/Makefile
+++ b/lang/python/python-automat/Makefile
@@ -8,11 +8,11 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=python-automat
-PKG_VERSION:=0.8.0
+PKG_VERSION:=20.2.0
PKG_RELEASE:=1
PYPI_NAME:=Automat
-PKG_HASH:=269a09dfb063a3b078983f4976d83f0a0d3e6e7aaf8e27d8df1095e09dc4a484
+PKG_HASH:=7979803c74610e11ef0c0d68a2942b152df52da55336e0c9d58daf1831cbdf33
PKG_LICENSE:=MIT
PKG_LICENSE_FILES:=LICENSE
diff --git a/lang/python/python-automat/patches/001-do-not-use-setuptools-scm-m2r.patch b/lang/python/python-automat/patches/001-do-not-use-setuptools-scm-m2r.patch
index babcda4b1..e749af361 100644
--- a/lang/python/python-automat/patches/001-do-not-use-setuptools-scm-m2r.patch
+++ b/lang/python/python-automat/patches/001-do-not-use-setuptools-scm-m2r.patch
@@ -26,5 +26,5 @@
- 'm2r',
- ],
install_requires=[
- "attrs>=16.1.0",
+ "attrs>=19.2.0",
"six",
diff --git a/lang/python/python-automat/patches/002-omit-visualize.patch b/lang/python/python-automat/patches/002-omit-visualize.patch
index 0d68d891f..ede279696 100644
--- a/lang/python/python-automat/patches/002-omit-visualize.patch
+++ b/lang/python/python-automat/patches/002-omit-visualize.patch
@@ -1,7 +1,7 @@
--- a/setup.py
+++ b/setup.py
@@ -27,15 +27,6 @@ setup(
- "attrs>=16.1.0",
+ "attrs>=19.2.0",
"six",
],
- extras_require={
diff --git a/lang/python/python-automat/patches/003-omit-tests.patch b/lang/python/python-automat/patches/003-omit-tests.patch
index 774b683d8..81f9e8b36 100644
--- a/lang/python/python-automat/patches/003-omit-tests.patch
+++ b/lang/python/python-automat/patches/003-omit-tests.patch
@@ -8,7 +8,7 @@
+ packages=find_packages(exclude=["*._test", "*._test.*"]),
package_dir={'automat': 'automat'},
install_requires=[
- "attrs>=16.1.0",
+ "attrs>=19.2.0",
@@ -30,6 +30,7 @@ setup(
author='Glyph',
author_email='glyph@twistedmatrix.com',