aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorW. Michael Petullo <mike@flyn.org>2022-12-19 11:14:39 -0600
committerDaniel Golle <daniel@makrotopia.org>2022-12-23 12:15:11 +0000
commitdf0b2eedd6d0b7f81851860afdee1b135850c115 (patch)
treee9fe16bdc328d29493f5835a79008a5d7a6ddb40
parentac78a5a21fded24cb3995967b9dc1ec042777e62 (diff)
krb5: update to 1.20.1
Besides updating the package to 1.20.1, this commit removed two patches that the new release made unnecessary. Signed-off-by: W. Michael Petullo <mike@flyn.org>
-rw-r--r--net/krb5/Makefile8
-rw-r--r--net/krb5/patches/001-fix-uninitialized-warning-errors.patch55
-rw-r--r--net/krb5/patches/002_remove_unnecessary_flag_in_macos_build.patch44
3 files changed, 4 insertions, 103 deletions
diff --git a/net/krb5/Makefile b/net/krb5/Makefile
index 0660515f8..bdad2543b 100644
--- a/net/krb5/Makefile
+++ b/net/krb5/Makefile
@@ -8,8 +8,8 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=krb5
-PKG_VERSION:=1.19.3
-PKG_RELEASE:=$(AUTORELEASE)
+PKG_VERSION:=1.20.1
+PKG_RELEASE:=1
PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
@@ -18,8 +18,8 @@ PKG_LICENSE_FILES:=NOTICE
PKG_CPE_ID:=cpe:/a:mit:kerberos
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://web.mit.edu/kerberos/dist/krb5/1.19
-PKG_HASH:=56d04863cfddc9d9eb7af17556e043e3537d41c6e545610778676cf551b9dcd0
+PKG_SOURCE_URL:=https://web.mit.edu/kerberos/dist/krb5/1.20
+PKG_HASH:=704aed49b19eb5a7178b34b2873620ec299db08752d6a8574f95d41879ab8851
PKG_BUILD_PARALLEL:=1
PKG_INSTALL:=1
diff --git a/net/krb5/patches/001-fix-uninitialized-warning-errors.patch b/net/krb5/patches/001-fix-uninitialized-warning-errors.patch
deleted file mode 100644
index 6d1e373dd..000000000
--- a/net/krb5/patches/001-fix-uninitialized-warning-errors.patch
+++ /dev/null
@@ -1,55 +0,0 @@
---- a/src/kadmin/ktutil/ktutil_funcs.c
-+++ b/src/kadmin/ktutil/ktutil_funcs.c
-@@ -65,7 +65,7 @@ krb5_error_code ktutil_delete(context, l
- krb5_kt_list *list;
- int idx;
- {
-- krb5_kt_list lp, prev;
-+ krb5_kt_list lp, prev = NULL;
- int i;
-
- for (lp = *list, i = 1; lp; prev = lp, lp = lp->next, i++) {
---- a/src/lib/kadm5/str_conv.c
-+++ b/src/lib/kadm5/str_conv.c
-@@ -133,7 +133,7 @@ raw_flagspec_to_mask(const char *s, int
- {
- int found = 0, invert = 0;
- size_t i;
-- krb5_flags flag;
-+ krb5_flags flag = 0;
- unsigned long ul;
-
- for (i = 0; !found && i < NFTBL; i++) {
---- a/src/lib/krad/packet.c
-+++ b/src/lib/krad/packet.c
-@@ -253,7 +253,7 @@ krad_packet_new_request(krb5_context ctx
- {
- krb5_error_code retval;
- krad_packet *pkt;
-- uchar id;
-+ uchar id = 0;
- size_t attrset_len;
-
- pkt = packet_new();
---- a/src/plugins/preauth/pkinit/pkinit_crypto_openssl.c
-+++ b/src/plugins/preauth/pkinit/pkinit_crypto_openssl.c
-@@ -3646,7 +3646,7 @@ pkinit_open_session(krb5_context context
- {
- CK_ULONG i, r;
- unsigned char *cp;
-- size_t label_len;
-+ size_t label_len = 0;
- CK_ULONG count = 0;
- CK_SLOT_ID_PTR slotlist;
- CK_TOKEN_INFO tinfo;
---- a/src/util/profile/prof_file.c
-+++ b/src/util/profile/prof_file.c
-@@ -270,7 +270,7 @@ errcode_t profile_update_file_data_locke
- unsigned long frac;
- time_t now;
- #endif
-- FILE *f;
-+ FILE *f = NULL;
- int isdir = 0;
-
- if ((data->flags & PROFILE_FILE_NO_RELOAD) && data->root != NULL)
diff --git a/net/krb5/patches/002_remove_unnecessary_flag_in_macos_build.patch b/net/krb5/patches/002_remove_unnecessary_flag_in_macos_build.patch
deleted file mode 100644
index 55aa7ac1c..000000000
--- a/net/krb5/patches/002_remove_unnecessary_flag_in_macos_build.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-commit 3c66c1fec7ce4edeff284a5e4abe32d0b4398539
-Author: Nikhil Benesch <nikhil.benesch@gmail.com>
-Date: Wed Dec 22 18:58:17 2021 -0500
-
- Remove unnecessary flag in macOS build
-
- The configuration logic for adding the `-search_paths_first` linker
- flag on Darwin does not correctly handle cross compilation. It should
- check the value of $krb5_cv_host rather than `uname -s` to detect when
- the compilation target is Darwin, rather than the build machine.
-
- It turns out `-search_paths_first` has been the default behavior of ld
- on macOS since XCode 4. So just remove that bit of logic entirely.
- (The flag was added in commit acd27af0e845f8b93de2e226cc2ec9ac8af52077
- in 2004; XCode 4 was released in 2010.)
-
- [ghudson@mit.edu: edited commit message]
-
---- a/src/aclocal.m4
-+++ b/src/aclocal.m4
-@@ -585,10 +585,6 @@ if test "$GCC" = yes ; then
- CFLAGS="$CFLAGS -fno-common"
- ;;
- esac
-- case "$LD $LDFLAGS" in
-- *-Wl,-search_paths_first*) ;;
-- *) LDFLAGS="${LDFLAGS} -Wl,-search_paths_first" ;;
-- esac
- fi
- else
- if test "`uname -s`" = AIX ; then
---- a/src/configure
-+++ b/src/configure
-@@ -4978,10 +4978,6 @@ $as_echo "$as_me: disabling the use of c
- CFLAGS="$CFLAGS -fno-common"
- ;;
- esac
-- case "$LD $LDFLAGS" in
-- *-Wl,-search_paths_first*) ;;
-- *) LDFLAGS="${LDFLAGS} -Wl,-search_paths_first" ;;
-- esac
- fi
- else
- if test "`uname -s`" = AIX ; then