aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorToni Uhlig <matzeton@googlemail.com>2023-05-23 04:38:07 +0200
committerToni Uhlig <matzeton@googlemail.com>2023-05-24 19:30:19 +0200
commitc9514136b7c4246a57b85474d1a8e376a9009d4a (patch)
treeeb17d83ea16815000a4f723c240e54f21cf0691b /CMakeLists.txt
parenta4e5bab9b2826ae50a48da275b6b441624aab50f (diff)
bump libnDPI to ...
* upstream changed regression test interface, needed to adapt * improved libnDPI helper build script * updated JSON schema Signed-off-by: Toni Uhlig <matzeton@googlemail.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 1 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ecb1dece3..9eaf17a88 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -214,12 +214,8 @@ if(BUILD_NDPI)
BUILD_IN_SOURCE 1)
add_custom_target(clean-libnDPI
- COMMAND rm -rf ${CMAKE_BINARY_DIR}/libnDPI ${CMAKE_BINARY_DIR}/libnDPI-prefix
+ COMMAND test -r ${CMAKE_SOURCE_DIR}/libnDPI/Makefile && rm -rf ${CMAKE_BINARY_DIR}/libnDPI && git submodule deinit ${CMAKE_SOURCE_DIR}/libnDPI || true
)
- add_custom_target(distclean-libnDPI
- COMMAND cd ${CMAKE_SOURCE_DIR}/libnDPI && git clean -df . && git clean -dfX .
- )
- add_dependencies(distclean-libnDPI clean-libnDPI)
set(STATIC_LIBNDPI_INSTALLDIR "${CMAKE_BINARY_DIR}/libnDPI")
add_dependencies(nDPId libnDPI)