aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorToni Uhlig <matzeton@googlemail.com>2022-11-05 23:30:53 +0100
committerToni Uhlig <matzeton@googlemail.com>2022-11-06 12:58:55 +0100
commit7515c8aeec3f6e60aa7e97e6903f6306ca7af34e (patch)
tree2583c254db17121facfd4b6b43cfe44abc064c55 /CMakeLists.txt
parent25f4ef74acb73340bd7cba7a7d45ab7191232283 (diff)
Experimental systemd support.
Signed-off-by: Toni Uhlig <matzeton@googlemail.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 69301cce6..172b0ffb7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -45,6 +45,7 @@ option(ENABLE_SANITIZER "Enable ASAN/LSAN/UBSAN." OFF)
option(ENABLE_SANITIZER_THREAD "Enable TSAN (does not work together with ASAN)." OFF)
option(ENABLE_MEMORY_PROFILING "Enable dynamic memory tracking." OFF)
option(ENABLE_ZLIB "Enable zlib support for nDPId (experimental)." OFF)
+option(ENABLE_SYSTEMD "Install systemd components." OFF)
option(BUILD_EXAMPLES "Build C examples." ON)
option(BUILD_NDPI "Clone and build nDPI from github." OFF)
if(BUILD_NDPI)
@@ -324,6 +325,11 @@ if(BUILD_EXAMPLES)
install(DIRECTORY examples/c-collectd/www DESTINATION share/nDPId/nDPIsrvd-collectd)
endif()
+if(ENABLE_SYSTEMD)
+ install(FILES packages/systemd/ndpisrvd.service DESTINATION lib/systemd/system)
+ install(FILES packages/systemd/ndpid@.service DESTINATION lib/systemd/system)
+endif()
+
install(TARGETS nDPId DESTINATION sbin)
install(TARGETS nDPIsrvd nDPId-test DESTINATION bin)
install(FILES dependencies/nDPIsrvd.py examples/py-flow-dashboard/plotly_dash.py