summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorToni Uhlig <matzeton@googlemail.com>2021-09-16 16:43:30 +0200
committerToni Uhlig <matzeton@googlemail.com>2021-09-16 16:43:30 +0200
commit655f38b68f83536054b240de2d3b7316bb407c6a (patch)
treedc0e002c6b355fd8c361961b975a16713a88ea0f /CMakeLists.txt
parent4edf3bf7e6024459dcd807c51ae5d7c81c3a646d (diff)
Fixed some typ0's and reduced ICMP timeout to 10s.
* nDPId: Renamed some of the misleading terms, still TODO for nDPIsrvd * CMake improvments Signed-off-by: Toni Uhlig <matzeton@googlemail.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 1 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1f94910ae..b929ba87b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -12,7 +12,7 @@ if(NOT MATH_FUNCTION_EXISTS AND NOT NEED_LINKING_AGAINST_LIBM)
list(APPEND CMAKE_REQUIRED_LIBRARIES m)
CHECK_FUNCTION_EXISTS(log2f MATH_FUNCTION_EXISTS)
if(MATH_FUNCTION_EXISTS)
- set(NEED_LINKING_AGAINST_LIBM True CACHE BOOL "" FORCE)
+ set(NEED_LINKING_AGAINST_LIBM TRUE CACHE BOOL "" FORCE)
else()
message(FATAL_ERROR "Failed making the log2f() function available")
endif()
@@ -56,9 +56,6 @@ if(NOT CROSS_COMPILE_TRIPLET STREQUAL "")
endif()
if(BUILD_NDPI)
- message(WARNING "Building nDPI from source is an experimental feature "
- "used for development/testing purposes.\n"
- "The build process may fail at any time.")
enable_testing()
add_test(NAME run_tests
COMMAND "${CMAKE_SOURCE_DIR}/test/run_tests.sh"