summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorToni Uhlig <matzeton@googlemail.com>2022-04-02 01:21:15 +0200
committerToni Uhlig <matzeton@googlemail.com>2022-04-02 01:21:15 +0200
commit645aeaf5b44ada9a4bcbc5e6d7ebf17ba4a82ea4 (patch)
tree43e557696628110c63245688743c7d10713e9164 /CMakeLists.txt
parent9f9e881b3fe5217210b7413912b42cd979da45ba (diff)
Avoid CMake searching for gcrypt as default.
* Not necessary anymore coz libnDPI has now a builtin gcrypt-light Signed-off-by: Toni Uhlig <matzeton@googlemail.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5b82e25cc..e4752e063 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -63,7 +63,7 @@ else()
endif()
if(STATIC_LIBNDPI_INSTALLDIR OR BUILD_NDPI OR NDPI_NO_PKGCONFIG)
- option(NDPI_WITH_GCRYPT "Link static libndpi library against libgcrypt." ON)
+ option(NDPI_WITH_GCRYPT "Link static libndpi library against libgcrypt." OFF)
option(NDPI_WITH_PCRE "Link static libndpi library against libpcre." OFF)
option(NDPI_WITH_MAXMINDDB "Link static libndpi library against libmaxminddb." OFF)
else()
@@ -99,7 +99,7 @@ if(NOT CROSS_COMPILE_TRIPLET STREQUAL "")
set(CMAKE_FIND_ROOT_PATH_MODE_PACKAGE ONLY)
endif()
-if(BUILD_NDPI AND NDPI_WITH_GCRYPT)
+if(BUILD_NDPI)
enable_testing()
add_test(NAME run_tests
COMMAND "${CMAKE_SOURCE_DIR}/test/run_tests.sh"