aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--README.md4
-rw-r--r--lang/rust/Makefile8
-rw-r--r--lang/rust/rustc_environment.mk2
-rw-r--r--lang/rust_host/Makefile2
4 files changed, 13 insertions, 3 deletions
diff --git a/README.md b/README.md
index 79762c2..0e87156 100644
--- a/README.md
+++ b/README.md
@@ -11,6 +11,10 @@ make distclean
make menuconfig
```
+If you change `my_openwrt_packages` to something else, you need to change the include path in
+`lang/rust/rustc_environment.mk` to `include $(TOPDIR)/package/feeds/[your-feed-name]/rust/rustc_targets.mk`.
+Otherwise, `rust/host` will not be able to compile as well as packages that depend on Rust (e.g. `suricata6`).
+
Why?
====
diff --git a/lang/rust/Makefile b/lang/rust/Makefile
index 3a2cf9a..cc9403c 100644
--- a/lang/rust/Makefile
+++ b/lang/rust/Makefile
@@ -14,7 +14,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=rust
-PKG_VERSION:=1.62.0
+PKG_VERSION:=1.62.1
PKG_RELEASE:=1
PKG_LICENSE:=Apache-2.0 MIT
@@ -106,6 +106,12 @@ define Host/Install
endef
define Host/Compile
+ @echo '========================='
+ @echo '= RUSTC_TARGET_ARCH ='
+ @echo '========================='
+ @echo '$(RUSTC_TARGET_ARCH)'
+ @echo '========================='
+ $(if $(RUSTC_TARGET_ARCH),,$(error RUSTC_TARGET_ARCH is not set. Did you change the package feed name?))
cd $(HOST_BUILD_DIR) && \
CARGO_HOME='$(CARGO_HOME)' \
CXXFLAGS='$(HOST_CXXFLAGS)' \
diff --git a/lang/rust/rustc_environment.mk b/lang/rust/rustc_environment.mk
index db0e350..539bd8b 100644
--- a/lang/rust/rustc_environment.mk
+++ b/lang/rust/rustc_environment.mk
@@ -1,4 +1,4 @@
--include $(TOPDIR)/package/feeds/packages/rust/rustc_targets.mk
+-include $(TOPDIR)/package/feeds/my_openwrt_packages/rust/rustc_targets.mk
# These RUSTFLAGS are common across all TARGETs
RUSTFLAGS += \
diff --git a/lang/rust_host/Makefile b/lang/rust_host/Makefile
index 4b0266c..f7dd4a4 100644
--- a/lang/rust_host/Makefile
+++ b/lang/rust_host/Makefile
@@ -13,7 +13,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=rust_host
-PKG_VERSION:=1.62.0
+PKG_VERSION:=1.62.1
PKG_RELEASE:=1
PKG_LICENSE:=Apache-2.0 MIT