aboutsummaryrefslogtreecommitdiff
path: root/example/Makefile.am
diff options
context:
space:
mode:
authorLuca Deri <deri@Lucas-MacBookPro.local>2015-04-19 07:25:59 +0200
committerLuca Deri <deri@Lucas-MacBookPro.local>2015-04-19 07:25:59 +0200
commit2e5ceac844c32fb52f4f3042be5b872f8b0b4ff0 (patch)
tree01af171f4af2b86efa64d0166dc540ee5c027c95 /example/Makefile.am
parent7fa4694dadf869d1de2baa99383308a163902f8f (diff)
Initial import from SVN
Diffstat (limited to 'example/Makefile.am')
-rw-r--r--example/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/example/Makefile.am b/example/Makefile.am
new file mode 100644
index 000000000..f98bae9ae
--- /dev/null
+++ b/example/Makefile.am
@@ -0,0 +1,12 @@
+bin_PROGRAMS = ndpiReader
+
+AM_CPPFLAGS = -I$(top_srcdir)/src/include @PCAP_INC@
+AM_CFLAGS = @PTHREAD_CFLAGS@
+
+LDADD = $(top_builddir)/src/lib/libndpi.la @JSON_C_LIB@ @PTHREAD_LIBS@ @PCAP_LIB@
+AM_LDFLAGS = -static
+
+ndpiReader_SOURCES = ndpiReader.c
+
+ndpiReader.o: ndpiReader.c
+