aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorlns <matzeton@googlemail.com>2022-05-30 00:32:31 +0200
committerlns <matzeton@googlemail.com>2022-05-30 19:22:22 +0200
commitfd5fa116f29d76269d90da78b6efa8cb2d6e6c07 (patch)
tree2192065ba2b96d7a93c8e3768093388604ee32f8 /configure.ac
parent912b69af60ce2408341fa440374195330fe46439 (diff)
* make check great again (not so much) * make doc/doc-view * CI updates Signed-off-by: lns <matzeton@googlemail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 895f1260e..2afd98181 100644
--- a/configure.ac
+++ b/configure.ac
@@ -102,7 +102,10 @@ if ! test "${with_only_libndpi+set}" = set; then :
JSONC_LIBS="${pkg_cv_JSONC_LIBS}"
JSONC_CFLAGS="${pkg_cv_JSONC_CFLAGS}"
], [AC_MSG_WARN([JSON-C not available. Disabled unit test.])])
- AC_CHECK_LIB([json-c], [json_object_put], [EXTRA_TARGETS="$EXTRA_TARGETS tests/unit"], [
+ AC_CHECK_LIB([json-c], [json_object_put], [
+ EXTRA_TARGETS="$EXTRA_TARGETS tests/unit"
+ build_unittests=yes
+ ],[
AC_MSG_WARN([JSON-C not available. Disabled unit test.])
JSONC_LIBS=""
JSONC_CFLAGS=""
@@ -114,6 +117,7 @@ if ! test "${with_only_libndpi+set}" = set; then :
EXTRA_TARGETS=""
])
fi
+AM_CONDITIONAL([BUILD_UNITTESTS], [test "x$build_unittests" = "xyes"])
HANDLE_TLS_SIGS="//"
AS_IF([test "x${enable_tls_sigs}" = "xyes"],[