aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorlns <matzeton@googlemail.com>2022-07-08 08:55:59 +0200
committerlns <matzeton@googlemail.com>2022-07-08 09:53:37 +0200
commite4c116359a5c06024151087cbc3cf851823eb9a7 (patch)
treecfa715ef5fdeea26087c6721059feebeeec97b91 /configure.ac
parentf8076e3a58e628d6761d16acdb4c8c7220a260ec (diff)
Enhances gprof usage.improved/gprof
* gprof results were incorrectly displayed Signed-off-by: lns <matzeton@googlemail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 260b8c1bd..8d58f8d56 100644
--- a/configure.ac
+++ b/configure.ac
@@ -33,6 +33,11 @@ AS_IF([test "${with_sanitizer+set}" = set -o "${with_thread_sanitizer+set}" = se
],[
CFLAGS="${CFLAGS} -g"
])
+AS_IF([test "${with_sanitizer+set}" = set -o "${with_thread_sanitizer+set}" = set],[
+ AS_IF([test "x$enable_gprof" = "xyes"], [
+ AC_MSG_ERROR([Configure options `--with-sanitizer' / `--with_thread_sanitizer' can not used together with `--enable-gprof'.])
+ ])
+])
AS_IF([test "${with_sanitizer+set}" = set],[
CFLAGS="${CFLAGS} -fsanitize=address -fsanitize=undefined -fno-sanitize=alignment -fsanitize=leak -fno-omit-frame-pointer"
@@ -287,7 +292,7 @@ AS_IF([test "x$enable_gprof" = "xyes"], [
])
GPROF_ENABLED=1
GPROF_LIBS="-ltcmalloc_and_profiler"
- GPROF_CFLAGS="${pkg_cv_PROFILER_CFLAGS} ${pkg_cv_TCMALLOC_CFLAGS}"
+ GPROF_CFLAGS="-g3 -fvisibility=default -fno-omit-frame-pointer ${pkg_cv_PROFILER_CFLAGS} ${pkg_cv_TCMALLOC_CFLAGS}"
])
AC_CHECK_LIB(pthread, pthread_setaffinity_np, AC_DEFINE_UNQUOTED(HAVE_PTHREAD_SETAFFINITY_NP, 1, [libc has pthread_setaffinity_np]))